Befaco Announments Thread

I previously posted about the Percall port I was working on. Since then I’ve been working with Befaco to bring a few more modules to VCV. Four new modules (including Percall) have been added with the intention of creating a new release, v1.1.0, these being Kickall, Chopping Kinky, Hex Mix VCA and Percall. I’ve also added the Befaco bananuts to the older modules :wink:

Download link for v1.1.0 (pre-release) v1.1.0 now released in the by library

The team at Befaco have taken a look and are happy, so now I am now looking for any feedback / testing before we submit to the library. I also have a few specific questions:

  • are the default values sensible (e.g. Kickall setting might not be)
  • any glitches / pops
  • are tooltips sensible
  • does it work on your platform (I can only test on Windows currently)
  • is CPU performance acceptable (I’ve tried to follow @Squinky guide!)
  • does polyphony work as expected?
  • Chopping Kinky
    • offers a range of oversampling - is this useful, or should a default just be set behind the scenes
    • polyphony - this needs to oversample 2-3 channels even in mono, so is CPU heavy, and waveshaping works best with mono - should I sum polyphonic channels or ignore channels > 1?
  • any comments on efficiency of implementation etc

Hope you enjoy and let me know how you get on!


Excellent news! Can’t wait to try these out! I’m on a Mac and I think I installed the new folder correctly. But the new modules do not show up in VCV Rack for me. The new svg files are in the folder though. The modules say v1.0.1 when I place them in Rack.

Mm at least on windows, if you download the .zip from Release Release v1.1.0 · hemmer/Befaco · GitHub and place in <RACK_USER_DIR>/plugins-v1, then when you open VCV it should install. However you shouldn’t click “Update” in the menu as that will (currently) downgrade to the library version, v1.0.1.

Eek, this is what I did. Currently trying to undo this. Thank you for the help!

Beautiful. Got it.

1 Like

Fantastic news!! Excellent work.

They look gorgeous :smiley:

I’m currently using the Martin Lueders polyphonic version of Befaco.

Tested your version and saw that F.I. the VCO is monophonic. Could it be possible for you to make this/and the other modules polyphonic ?

1 Like

ouh yeah! BTW @hemmer our Repelzen Remix is opensource and ported from an open source module from aepelzen, which is based on Befaco Hexmix… I remember he modeled the eq curve on the original hardware, they do have a sound of their own. feel free to pick anything you want from it to add the Hexmix if you want :smiley:


The the VCO going to hook the sync input up to anything?


Wow… Amazing!

@Yeager thanks! Yes I did look at merging in Martin’s changes, and we spoke a while back. There are a couple of minor things needing finished off there (e.g. this bug and some review comments), so I’ll take a look.

@pyer ooh that’s good to know - long term goal is to port as much as possible to VCV, so this would be a great addition, I’ll look into that for a future release.

@Squinky I’ve not touched the EvenVCO yet, but I’m now a bit more familiar with, e.g. the MinBlep papers. I know your EV3 is a good reference for this though. I think it just comes down to whether I want to delay getting this into the library a little bit (to fix up EvenVCO) or whether we do that as a subsequent release. Thanks for the reminder.


Fails on linux here:

[0.131 warn src/plugin.cpp:158] Could not load plugin /home/ewen/.Rack/plugins-v1/Befaco: Failed to load library /home/ewen/.Rack/plugins-v1/Befaco/ /lib/x86_64-linux-gnu/ version `GLIBC_2.29’ not found (required by /home/ewen/.Rack/plugins-v1/Befaco/

Really impressive work - very happy to see more Befaco in VCV!

Mm, I’m not sure why that is. I just tested with a fresh Linux Mint VM and it works. If you completely delete, and downgrade does the old version definitely work no issue? What version of VCV are you using?


1.1.6 local dev build.

I’ve seen this before with other modules but can’t remember exactly what the issue was, I do recall it was an easy fix though.

1 Like

From Instruo won't show up in Library - #6 by dlphillips it looks like the github build actions are using latest Ubuntu, I’ll try using ubuntu-18.04 tonight and send you an updated build.

1 Like

Hi, although this is an old comment by Vortico, it might be of use here:


Definitely worthwhile to install the vcv build toolchain.


I’ve merged in the @martinl1968 's polyphony changes, plus switched to building on Ubuntu 16.04 to keep compatible with glibc and libstdc++ requirements. @contemporaryinsanity - let me know if this works. I’ve also been addressing the review comments about polyphony and addressing some outstanding bugs there. I’ve tried to test the polyphony changes but the more eyes the better (plus I’ll continue to test myself).


Sorted :slight_smile: