Instruo won't show up in Library

Hi all, I am in need of some assistance with the new Instruo modules. I added them to my Library today through the website and opened up VCV to download them. However, when it finished updating, it said the Instruo .zip file didn’t install or something like that. (I accidentally clicked the message away too quickly, so I can only approximate what the message said.) I then restarted VCV and Instruo showed up in the updates section. I had it update and restarted VCV but the modules still did not show up. I poked around in the plugins-v1 folder and Instruo appears to be in there. Inside the Instruo folder there is the res folder, plus plugin.json and plugin.so. I tried deleting that folder and updating again, but the same thing happened: I have the folder, but it won’t show up in VCV. I also tried unsubscribing from the Instruo collection through the website and then subscribing again, which did not work either. If anyone has any ideas, please let me know. I was really excited to get to try these modules out, so I’m rather bummed out at the moment. I am running Ubuntu 18.04 if that helps.

Hi, I’ve had no problem installing on linux (arch). I’ve deleted the Instruo folder in v1-plugins and redownloaded. Before restarting Rack, I’ve checksummed the .zip file:

$ md5sum Instruo.zip 
69c89125db35595118d3486c82a18881  Instruo.zip

This file installs fine. Did you download the same files?

[0.207 warn src/plugin.cpp:158] Could not load plugin /home/ewen/.Rack/plugins-v1/Instruo: Failed to load library /home/ewen/.Rack/plugins-v1/Instruo/plugin.so: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /home/ewen/.Rack/plugins-v1/Instruo/plugin.so)

Can’t be bothered to attempt to fix it, still way beyond caring. Do like the look of that quantizer though :slight_smile:

looks like the plugins were compiled on arch linux system and are thus only compatible with arch linux - it might be good if they could recompile them on the recommended ubuntu-16.04 i think - then they should be compatible with most linux systems i guess …

update: maybe a newer ubuntu version like 18.04 might be ok too - arch linux seems to use a newer version of glibc (and its libm) which is too new for (at least older) ubuntu systems …

Thanks for the help. :slightly_smiling_face: Its my first time posting here.

Same problem here. I had understood Ubuntu 18.04 to be a minimum version for vetting a plugin before adding it to the Library. Has that changed ?

Working on my Mac, High Sierra. Worth trying to fix because these modules are incredible, I’m having way to much fun right now! :slight_smile:

I believe it’s glibc 2.23 and libstdc++ 5.4.0, which correspond to Ubuntu 16.04

1 Like

I’m on ubuntu 18.04 and 1.1.0 seems broken. it just keeps reinstalling over and over.

Edit: just understood the above, I’m stuck on glibc 2.27 :frowning: Looks like 20.04 has a new enough one.

That’s annoying. I just downloaded these, and rebuilt the squashed FS where I keep VCV. I guess I don’t need to push it out to my machines. Respect the existing minimums please, guys!

That also works with Slackware provided you patch VCV’s build to pass -D_GLIBCXX_USE_CXX11_ABI=1.

1 Like

Jason, the (or one of the) devs replied to my email… new build incoming later tonight or tomorrow. :slight_smile:

5 Likes

OK, that’s annoying. I tried it out on my Windows box and it was working. Came back to my regular Linux desktop and discovered the Instruo plug-ins don’t work. Only time I’ve had this happen all year. Hoping they get it fixed so I can play with it while on vacation.

I just booted it up today, updated it, and the Instruo modules show up and work now! :smile: My thanks to the devs for fixing the issue. :clap:

1 Like

Confirmed, yes, working and yay. Love these modules already. Thanks for the fast fix

As one who kvetched obnoxiously, I must say thanks to the Instruo crew for sorting this out so quickly.

New toys! :smiley:

1 Like