VCV Rack 2 does not load in Windows 10, Fatal SIG 22

Hello, like in many other threads here, vcv rack 2 doesn’t load. In the log there’s a Fatal Error 22 thrown.

It looks like this:

[0.002 info adapters/standalone.cpp:152 main] System time: 
[0.002 info src/settings.cpp:455 load] Loading settings C:/Users/stefa/OneDrive/Documents/Rack2/settings.json
[0.002 info adapters/standalone.cpp:175 main] Initializing environment
[0.004 info src/rtaudio.cpp:254 RtAudioDriver] Creating RtAudio WASAPI driver
[0.013 info src/rtaudio.cpp:269 RtAudioDriver] Found RtAudio WASAPI device 0: DMX 6Fire Waveplay 1/2 (Terratec DMX 6fire WDM Audio) (0 in, 2 out)
[0.075 fatal adapters/standalone.cpp:60 fatalSignalHandler] Fatal signal 22 SIG. Stack trace:
16:  0x0
15: raise 0x7ffd7698abe0
14: abort 0x7ffd7698f1e0
13: ZN9__gnu_cxx27__verbose_terminate_handlerEv 0x7ffd4da8f4c0
12: ZN10__cxxabiv111__terminateEPFvvE 0x7ffd4da85cd0
11: ZSt9terminatev 0x7ffd4db778d0
10: _cxa_throw 0x7ffd4db80670
9: ZN5RtApi5errorEN12RtAudioError4TypeE 0x7ffd4d5cda20
8: ZN11RtApiWasapi13getDeviceInfoEj 0x7ffd4d5d98a0
7: ZN4rack13RtAudioDriverC1EN7RtAudio3ApiE 0x7ffd4d60c710
6: ZN4rack11rtaudioInitEv 0x7ffd4d16c010
5: ZN4rack11rtaudioInitEv 0x7ffd4d16c010
4: ZN4rack11rtaudioInitEv 0x7ffd4d16c010
3: ZN4rack11rtaudioInitEv 0x7ffd4d16c010
2: ZN4rack11rtaudioInitEv 0x7ffd4d16c010
1: BaseThreadInitThunk 0x7ffd74e47020
0: RtlUserThreadStart 0x7ffd76cc2630
1 Like

Looks like something to do with your audio device driver. Try one of these:

  1. Close all other programs on the computer. Delete/rename the …/Documents/Rack2/autosave/patch.json file. Open Rack. The default patch should be on screen. Select your audio device in the audio module. Does it play or crash?

  2. Instead of using WASAPI(?) drivers in the audio module, try one of the other drivers, directsound, … whatever they’re called (I’m on Mac).

WASAPI is a standard driver for sound in Windows. hm there is no autosave, since rack couldn’t load. VCV Rack 1 is still installed and works, maybe uninstall this helps.

I think there’s stil a compatibility issue with “onedrive”.

Try moving your user dir somewhere else (not under OneDrive management), and start Rack with commandline option “-u” to specify the new location.

1 Like

Thanks for the suggestion, but that doesn’t seem to be it - changed the user folder location but still getting the exact same outcome.

1 Like

Yes thats another thing, windows puts everything to onedrive, users dont realise it. “Documents” is “Documents”. Hard to make out which is on OneDrive. Anyway, changing the windows sound output (in windows) did not work.

I go back to 1.1.6. for now…

v2 working fine for me on Win 10


If you have Jack audio or asio4all, try uninstalling. Worked for several others.


Thank you kindly. This worked for me having the same problem.

1 Like

Don’t have Jack or ASIO4ALL - have tried uninstalling a few other MIDI routing tools but still no luck. Have submitted a support ticket - will update here if it gets resolved.

1 Like

Hello Community, I have this issue too. For me the “Elektron Analog Four” integrated audio device is the cause of the problem. When it is turned off, it works fine. On VCV 1.1.6 this was no issue. Greetings, Christian

At last, solved it (for me at least). The virtual sound device I use FXSound for audio enhancement on music has for some reason also got an AUX input configured. No idea why as I’m not sure how I’d ever use it anyway. Still, disabling this has sorted it and Rack’s working now.


Sounds like it’ll be a different fix dependent on your own setup, but I guess disabling everything you don’t need is the way to troubleshoot.

Shit, I am getting the same now (after the earlier Jack audio problem that was solved)

I’m pretty sure I’ve uninstalled all programs that involve (virtual) audio devices, except my two main audio interfaces (even removed the realtek driver for the onboard soundcard and the HD audio driver from my GPU). All to no effect.

Anybody got any ideas where else to search? Like specific settings on my system I should check?

Any clue from the log.txt in the Rack user folder?

It is clear that the error occurs when calling the Wasapi driver.

I did fix it just now, after just bulldozering so many programs from my laptop. Go Time.

HI, my first post here. I had the same issue with my M-Audio FW410. If I disable it, it just runs without issues with an Audient Evo 4. Even if I plug the 410, VCV crashes. Tried even disableing every output, input and multichannel in every configuration and still, it wont run unless I disable the whole soundcard or unplug it. Is a pity that I can’t just disable WASAPI whatsoever in this case or use another sound device.

@joopvanderlinden MerkDak


If you have Jack audio or asio4all, try uninstalling. Worked for several others.

1 Like

Ah. I have asio4all installed. Will try to remove that tomorrow. Thanks

1 Like