VCV Rack 2 does not load in Windows 10, Fatal SIG 22

Yeah, these driver related crashes would be good to fix…

Rack 2.0 ran without any problem. It’s the latest release that crashes. So I would think something could changed back

Rack 2.0.0 crashes for me, so does 2.0.1

1 Like

I uninstalled asio4all, but no luck :frowning:


When searching through the registry, i found a reference to Jack Asio. Deleted that. That did the trick :slight_smile:


I’m getting Fatal signal 11 SIG?

Seems like a separate issue

I don’t know.

You could try starting Rack from the command line, adding the -d option, It might log something before it dies.


1 Like

Another debugging possibility, is to get rtaudio, and build it to get “audioprobe.exe” - it will show the interfaces present on a windows system as rtaudio see them - if it bugs out, rtaudio is the culprit. VCV Rack2 uses rtaudio.

to do that:

install msys64-mingw64 to run:

git clone
cd rtaudio; make
cd tests

Thanks for this suggestion. Apparently…the license key is failing to download…I guess that’s what Fail Sig 11 stands for.

I’ll download free just to confirm

Edit: Yep, its licensing issues instead of computer issues. That’s disappointing

1 Like

Yeah…I’ve submitted a form to them. Thanks

Hey hey! I was able to work around the issue!

Uninstalled Rack2Pro, Restarted my computer, deleted the Rack2 folder in Documents, reinstalled Rack2Pro.

Opens right up


Disabling real time protection in windows security worked for me.

Had the same issue with v2.0.1 (1.1.6 works just fine). Found this thread and tried disabling several audio devices. In my case it was the “iConnectMIDI2+” device. This one is not virtual, it is a driver for strreaming audio from an iOS device over the iConnect MIDI interface to the PC…

All in all I hope that this driver issue get’s fixed in upcoming versions… I never had that much trouble getting a DAW to start up…

I ran into the exact same problem as the OP. I’m running VCV Rack 2 Free on Windows 11. After troubleshooting I discovered that the RtAudio driver fails to load (when I start VCV Rack 2) only after I’ve run VCV Rack 1.6.

To be explicit … After I restart my PC, I can open, run, close and re-open VCV Rack 2 as often as I like. But once I’ve run VCV Rack 1.6 and then closed it, VCV Rack 2 will fail to open due to the RtAudio driver failing to load. In both Rack 2 and Rack 1.6 I’m sending audio to a Focusrite device using an ASIO driver.

btw, I hope someone has logged a VCV bug that asio4All (or other asios?) crashes VCV on windows? Seems like a) it’s new, and b) it happens a lot!

I also had this issue, fatal sig 22 error. After uninstalls for all asio and midi drivers, and checking my hardware setup it turned out to be an outdated driver for my iconnectivity iconnectmidi 2.

1 Like

Thanks, I just updated the driver and now it works without deactivating the interface.

@joopvanderlinden Hello Joop, I had the same issue! After deleting Jack Audio / Jack Asio VCV RACK 2 launches again! Thanks for your suggestion. Best Heiko

good to hear that!