Ableton Live step sequencing not triggering properly

I’ve already sent a support report on this, but wanted to start a topic as well.

When creating a new step sequence in the midi clip editor in Ableton Live (any version) the notes generated are odd in that the end timestamp / sample of the previous note is exactly the same as the start timestamp / sample of the next note. This means that the gate output in the MIDI to CV converter doesn’t have a break, which means things like envelopes etc won’t be retriggered as expected. Desired behaviour is that if the end and start times are identical to force a gap so the gate works, but if they overlap so that the start time of a new note is before the end time of the previous note, then the gate should not have a gap. This allows for legato play by increasing the length of the note to overlap with the new note, but still preserve expected behaviour when doing step sequencing with the default note lengths Live generates.

Here is a project with two clips, the desired behaviour is that the first clip should sound pretty much identical to the second one, but only the second one works since I manually edited the note lengths to get the gate to have a gap. This means quick step sequencing with the mouse / paint or using something like Push is pretty much broken since the whole point of this workflow is for quickly entering the sequence.


Also Ableton always sends 0 volt from 1v\oct midi module output after stopping the transpost, just weird

1 Like

probably helps stop hanging notes in various scenarios

It’s not convenient but can you gatemod everything on the way in from Ableton?

When creating a note based step sequence notes will be of different lengths. Some of these I’d like to manually tie together for legato type glide by manually making them longer, but by default I want them to not tie.

Unless there is a device that can look at each notes length, and adjust that length fractionally shorter then it won’t work.

Would it help using the Note Length MIDI FX prior to sending to CV out?

Maybe adjust gate/length to 97% ?

That doesn’t work. Please re-read my previous post about having various note lengths in the sequence. edit: Here is a video showing the issue clearly:

Ah sorry think I had only seen your original post, yeah not sure how to get round that other than using different step sequencers for different note durations.

I got bored of waiting for a fix so I just did it, it was quicker to fix than the time it took to make the video to show the issue:

The forked repository is here, and this fork also adds unison channels (on the “cytomic” branch):

And I also forked the fundamental repository to fix the noise generation to sound consistent with different sample rates (on the “cytomic” branch):


Having the option is probably best. I can see the logic of doing it the way it is now. It makes it so a midi-note is a representation of a gate. I think Korg’s ms-20 emulation (and Softube modular) works the way it is now. But probably the majority of plugins don’t. By the way, the Push doesn’t have an option to set a default note length? I don’t have one but I would be annoyed by that.

There is no way that I know of to get Live to make any notes entered in their grid midi editor to be just less than the full grid size length, so this also applies to using the mouse to enter / paint notes as well as all versions of Push.

Its same with Bitwig not just an Ableton issue.

RTRG re-triggers on legsto or not.

It would be nice if it had an option to not re-trigger on legato.

Still a problem in 2.4.1 :frowning:

We must just be outliers wanting to use vcv rack like a regular plugin synth by sending it notes from the outside world, shame on us for not making drones! :wink:

Fingers crossed not too much longer since it really is a pretty basic fix that is totally optional so won’t impact existing functionality in any way when not enabled.

1 Like

It’s not just Ableton, it’s probably with any DAW, I guess. I’m using Reaper and I also tried Bitwig - same issue.

I’d consider it as broken MIDI implementation and I don’t care that one or two VSTis have the same flaw. I own a couple of hardware synths and they all do it right as well, except the Behringer Model D. I don’t get it either why this hasn’t been fixed a long time ago resp. why it doesn’t seem to bother more people.

How did support react to your inquiry re: this?

I much appreciate your fix but for now I will not use it 'cause I’m renitent and too lazy to compile software I paid for myself. :smiley:

edit: formatting

I don’t have that problem - using Studio One. And in any case, there is a way to shorten all gate lengths to less than 100%, should the problem arise.

1 Like

Uh, OK, thanks for the info - that’s interesting!

I might have jumped to conclusions here. Having tried with two different DAWs and seeing other users with a third DAW having the same issues I thought it must have something to do with Rack2. But it could as well be something specific to our systems, of course.

My main machine is macOS, I’ll do another test with Reaper on a Linux notebook when I find the time the upcoming week.


1 Like

Yeah, I’m not sure why it works for some, and not others. Im on Windows. But it could also be the sample rate, or some other factors. If I punch in a series of notes in the DAW, the gates come through fine in VCV. On the scope there is a small gap between them. Maybe with other settings, or other DAWs, this gap is too small for VCV to recognise. Im just guessing here, but I hope they sort it out for all.

There are processing units that can create fixed length notes, but I want to write a fluid mono bassline with various length notes, some with ties (overlapped) some not, and there is no solution to this other than manually edit every note to be slightly shorter if I want it to trigger correctly, which as shown in the video takes a long time and breaks this otherwise fun workflow. I want it the other way around, to edit every note I want tied. Every major plugin synth I’ve used can handle the note gates properly in mono mode, apart from VCV Rack 2.

The latest reply from VCV Rack tech support is:

"We are still looking into this issue.

While we do so, in looking into this issue, I think there is one existing option that may achieve what you’re after with no changes to the code. If you set your VCV MIDI to CV module to have any more than one channel of polyphony, adjacent notes will play back as you expect."

Ok, sure, two notes will trigger, but that’s not useful for a mono bassline with glide, and then this same case comes up for poly when the channels count matches the note count with co-incident off/on.

1 Like