VCV Rack won't open on Windows 11

Hello everyone,

I haven’t used VCV Rack for a long time and decided to install it again on my new machine but, even though I’m able to install it, the program won’t start. It processes for about two seconds and then nothing happens. I have the newest 2.2.3 version and even tried versions all the way down to 2.0.0 but with these, I can’t even install the program because Windows Defender sees it as a risk. If I ignore this warning and open it anyways, it’s the same issue. Curiously, the 1.1.6 version gave me no problems and works perfectly. Also, whithin those 2 seconds, there’s a little sound distortion (don’t know if it’s useful). In the newest version, I’ve also tried deactivating real-time protection but it didn’t help at all. I’m using Windows 11 and have an ASIO compatible interface. I’m sorry if this problem has already been covered but I couldn’t find a solution in any of the other topics. I would appreciate some help. And thank you in advance.

Sincerely, Me.

I’m not sure, maybe this ?: (on second thought, If the installer works, that’s probably not it)

If that doesn’t solve it:
a) Does your CPU meet the minimum requirement ?

b) does your GPU meet the minimum requirement ?

1 Like

Hi, thanks for the reply. For the CPU I have an Intel Core I9 12900K and for the GPU I have an Nvidia RTX 3080 ti, so it meets the minimum requirements. The first solution you proposed iinvolves disabling a setting of the system’s security so I don’t know if I should even try it. Thank you very much for responding and for the suggestions but, unfortunetly, they didn’t work. Any other tips?

Anything in the log file (Documents/Rack2/Log.txt)?

1 Like

Okay, I don’t know what just happened but it’s running. I had the 1.1.6 version installed and open and when I went and installed the 2.2.3 version, it said I couldn’t open two sessions at the same time and the newer version opened. I went to the log file as I was doing this. I have no idea of what just happened and how I solved the problem (kind of pains me) but I restarted Windows and it appears to be working. Do you have any idea of what happened? And, of course, thank you both for your quick responses. I was starting to lose hope.

Are you opening Rack by double clicking a project file ? Or by starting VCV Rack.(the .exe)? Starting it from a project file gives problems, just open a file from within VCV Rack.

Another bug/annoyance that occasionally pops up, is windows that somehow are incorrectly positioned and thus not diplayed.

Also, people running into problems with special ISO character not in the ASCII character table in their path names (âccèñts / ру́сский алфави́т etc). Running the rack data dir on a MS onenote drive - or other drives somehow protected and/or managed by other software. The Rack command launch options and/or environment variables as described can be used to work around / troubleshoot filesystem related problems.

Thank you for your suggestion. Whether I open Rack from a project file or from the .exe, it won’t start. Today I started my PC and tried to open Rack both ways and it didn’t work. I went ahead and installed the 1.1.6 version, opened it, upgraded it from within the app and the 2.2.3 version appeared. Now it’s functioning perfectly but I fear I’ll have to do this process evrytime I restart my PC now. It revolts me to not know how this is happening.

Okay, I went to that topic and could verify what it said in that file:

“windowMaximized”: true, “windowSize”: [ 1024.0, 720.0 ], “windowPos”: [ 738.0, 538.0

As you can see, the first parameter is set to true which doesn’t coincide with that problem. The numbers on the bottom do seem to be kind of random but if it says that the window is maximized on top then I think the problem has nothing to do with that parameter or the following values. But I could be wrong. Thank you again for the suggestion.

I am having the same issue. After I restart my computer it will let me reload VCV rack and claims one of my modules from the patch was “buggy” so it opens a blank patch. I didn’t have this issue until I started opening other people’s patches. Now it seems to happen on a regular basis but usually if I am importing selections or opening patches that are not my own. A bit frustrating and it is actually one of the reason I have yet to upgrade to pro.