VCV Rack 2 (free version) fails to start under Windows 7

I just downloaded and installed VCV Rack 2 (the free version), but when I try to start it, I immediately get a pop-up screen with an error message (see below), and the main window never opens. I was running v1.1.16 on the same machine and didn’t have this problem, although it was very sluggish at times (due to the age of my hardware and lack of a dedicated graphics board, I think). I uninstalled the previous version, thinking there might be some conflict (even though I read that they can run side-by-side, although not at the same time). However, I still get the same error.


I’m running under Windows 7 sp 1 (64-bit) on a quad-core processor (an AMD Phenom II X4 810). I think I meet all the requirements, except maybe for SSE4.2 support. The specs for the CPU say it supports up to SSE4a.

Could this explain the error message, or is there some other problem?


I think that’s it.

Rack 2 free is complied to supports cpu’s with at least the “nehalem” architecture. The first AMD to match that with regards to SSE (Streaming SIMD Extensions) is the “Bulldozer” - it was intruduced in 2011.

You may be able to build Rack2 from source for your older architecture - I don’t know - perhaps some CPU instructions are used that only exist in the later architecture, and it’s not only the complier flag that needs to be changed. I don’t know the source code that well.

Thanks, I just wanted confirmation that this is the problem. I have a newer laptop running Windows 10, I don’t think I’ll have a problem with it. I just wanted to test Rack 2 on an older machine first. I’m a little paranoid about installing it on my “production” machine.

I think your production machine will be OK.

Rack2 doesn’t make a mess - it installs to it’s own dir, that you get to specify during installation - and to your documents dir in a new rack2 folder.

The pro version also installs “VCV Rack 2.dll” and “VCV Rack 2 FX.dll” to a vst plugin folder you specify. It doesn’t use the registry. Doesn’t install any drivers or services.

1 Like

If you solve the issue by compiling for old arch you probably won’t be able to use downloaded plugins? They get built with the same options.

1 Like

And binary distributed, closed source plugins you would never be able to get running on a +10 year old AMD.

However, one migh be able to run it using an emulator (Intel® Software Development Emulator)

1 Like

Thanks, but I don’t think I’ll bother. As long as it runs on my newer laptop, I’m OK with it. However, that brings up another issue that I was wondering about. It would seem that v1.1.16 was compiled with different options (since it does run on my old machine). What about all the plugin modules? Does each developer choose which compile options to use? Or does the SDK force them to use the same options? (I’ve never tried to compile a plugin myself, so I have no idea.)

The sdk forces it. Or at least strongly suggests it. That option comes from a make file that comes with the sdk. One can do anything, but you couldn’t do it accidentally.

1 Like