VCV fails to launch Win7pro64bit

(Breathingtosong) #1

Installed without error, but first time to launch it crashes. I have a fully updated Win7 OS, an Intel board with a dual core 3gh processor, 4gig RAM. I have never been able to launch, crashed the first time.

(I could not find any system or OS requirements for this product?)

(Andrew Belt) #2

It helps to add details about the behavior of the crash.

(Breathingtosong) #3

The error reads that there was a corrupted module. But I have never launched the application to add the first module. My biggest question however is the system requirements, I cannot find the specification. I am: Win7pro64bit on intell chipset / duo-core 3gh / 4gbRAM /

(Americo Silva) #4

Hi! i have the same problem,

BEX64
Application Name: Rack.exe
Application Version: 0.0.0.0
Application Timestamp: 00000000
Fault Module Name: StackHash_1dc2
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Offset: 0000000000000000
Exception Code: c0000005
Exception Data: 0000000000000008
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 1dc2
Additional Information 2: 1dc22fb1de37d348f27e54dbb5278e7d
Additional Information 3: cbc5
Additional Information 4: cbc5ec6970b2af35927ad67117ca57e2

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt


i use windows 7 ultimate edition 64bit
intel core 2 duo T8300 2.60 ghz
4gb ram
ona mac via bootcamp

1rst time launch

what i can do for run this amazing piece of software? :cold_sweat:

(Patman / NYSTHI Manual) #5

@SupraOM, Have you tried running it on the mac side of things?

1 Like
(Patman / NYSTHI Manual) #6

@breathingtosong, when you say “crash” - what happens?

Do you get some form of error message? if so, can you take a screenshot?

Does it blip a window up and then just quit on you? if you want help, you have to give more info, otherwise diagnosis is impossible.

1 Like
(Americo Silva) #7

Hi Patman, thaks 4u response…, i cannot run osx right now because osx (yossemite) partition its lots but when i can but as soon as I can I will publish the results.

I have never been able to run satisfactorily, the VCV Rack has always said:

" Rack has recovered from a crash, possibly caused by a faulty module in your patch. Clear your patch and start over? "

when click yes, the program crash and show faulty load module> StackHash_1dc2

Attached the screenshots, thank you very much I am very excited with this software that I am sure will change the way I do music, you appreciate them a lot community thanks for the interest :man_technologist: :bowing_man:

Screenshot_1

(Americo Silva) #8

(Patman / NYSTHI Manual) #9

Have you tried to delete any autosave.vcv (and rename any template.vcv) in your Rack directory (usually in driveletter:\\Users\Username\Documents\Rack, although it’s been ages since Win7 for me)

1 Like
(Americo Silva) #10

Hi Patman!!! well…, theres no any autosave or .vcv files, even if i launch (unsuccessfully crashed) the host there not any vcv file :cold_sweat::cold_sweat::cold_sweat:

(Jon Heal) #11

This “fix” I found applies to gaming, but you might try it on your machine to see if it helps:

"If you have BEX64 problems on Windows 7, try setting the exe to compatibility mode for “windows 7”

Do you know how to set Rack.exe. to run in Win7 compatibility mode? I can explain if not.

1 Like
(Americo Silva) #12

Hi Jon! thanks for u response, I set the compatibility mode to windows 7 like u suggest but VCV rack keep crashing on same BEX64 error!!!

Also try other compatibility modes, such as windows vista sp1, sp2 and server 2008 without success.

I will be trying to find a BEX64 solution by google to see if I can find a solution.

(Americo Silva) #13

Hi friends i make my own build from github using this tutorial https://www.youtube.com/watch?v=Gm2z1fVpsB0

when i use ¨make run¨ i get
make: *** [Makefile:61: run] Segmentation fault
the vcv rack dont launch

trying againg Make run
the vcv rack makes the attempt to boot and the same error showsup when i try to launch it directly from the installation of windows, I mean it crashed and says; Rack has recovered from a crash, possibly caused by a faulty module in your patch. Clear your patch and start over?

there any solutions?

(Stephan) #14

I have no idea about the compilation process on Win7,
but
I would try to start the precompiled (downloaded) version of VCV with an empty plugin folder
(copy the content of it to another folder as backup, and then delete eveything inside the plugin folder)
Have you tried that?

1 Like
(Clement Battung) #15

Hello

Can you give us the model of your CPU ?

because rack (precompiled version) is compiled with “-march=nocona” which implies SSE2/SSE3 options

maybe if you have an older CPU, it needs to be compiled without those options

(Americo Silva) #16

Hi Clement, thanks 4 u response., i think my cpu can run SSE2/SSE3 instructions., Core 2 duo T8300 Penryn… I really wish I could run vcv rack Thanks for the help
Screenshot_2

(Americo Silva) #17

thanks for the help amigo, in fact I have cleaned the plugins folder from documents and when launching Rack.exe automatically recreates it and returns the same error., even try to delete the modules of the ¨res¨ folder inside ¨plugins¨ without success. I would like to try an old version (prebuilded) but I can not get it anywhere. I’ll keep trying anyway

(Americo Silva) #18

also try to change some values ​​of setting.json, placing the samplerate according to the driver, check version to false, power meter to false, “skipAutosaveOnLaunch”: true. All without success :cold_sweat:

(Daniele Zerbini) #19

Can you access this info?

  • Click Start , click Control Panel , and then double-click System .
  • Click the Advanced tab. Then, under Performance , click Settings .
  • Click the Data Execution Prevention tab.
1 Like
(Americo Silva) #20

Yes, I can access but there is no option available