VCV fails to launch Win7pro64bit

The options are disabled because you have no administrator privileges. That could be a Bootcamp default setting.Try to google about “How to Get Full Administrator Rights in Windows 7”. Once you have it, you should manage to right-click the Rack executable and select “Run as administrator”.
If not even this should work, you can try to change your Data Execution Prevention settings (but be cautious). Here a step-by-step:

1 Like

@SupraOM, I missed the “on Mac via Bootcamp” part? Why are you trying to run it on Windows 7 at all when it runs on the Mac naively?

Hello everyone, I just remembered that the DEP options were disabled because previously I had disabled the DEP through bcdedit.exe / set {current} nx AlwaysOff.

In spite of that, I granted FULL control permissions to all types of users as DIZZY suggests., I activated again the DEP restart …, I tried through the options of DEP (in advance System Options) to turn off the DEP only for RACK. exe says "you can not set DEP attributes on 64-bit executables. I tried disabling the DEP again the DEP bcdedit.exe / set {current} nx AlwaysOff restarting, reinstalling the VCV rack once inside program files and a second time out of program files in a different partition, try to boot with administrator control and in all compatibility modes again without success.

The only way I could run VCV Rack was through a Linux installation (mint) that I realized with the sole purpose of exploring this wonderful software.

I do my music in renoise and I have many working files with vst installed under windows that is why I would like to successfully run the VCV Rack and make bridge with my host.

In response to Jon; I use windows 7 via bootcamp because my old macbook 4,1 hardly runs the latest updates of some programs like reaktor in environments under osx 10.8 …, despite that I have been able to install yossemite 10.10 but I do not like some glitches that cause some ktex drivers outdated

thank you all for your interest, I kept looking for how to run VCV rack without problems in my system.

P.S. Sorry my bad english

Mmmh, hard life. The only thing that comes to mind, at this point, is to try and disable the Execute Disable Bit from the Bios. Or inspecting Windows Application logs, or using diagnosis tools like Process Monitor. But things start to become tricky. Maybe sending a crash report to Microsoft, one can never say :slight_smile:

1 Like

hahahaha really hard life. You run VCV Rack in windows?, You could send me the folder Rack in documents to recreate it in My Documents since for some reason Rack.exe does not create the file autosave.vcv or any file vcv. Maybe with a bit of luck it can flow


@SupraOM Mmmh again… :smiley: really the Rack/Documents folder is nothing more than a blank canvas. Rack is creating it all freshly at first launch. Then it’s populated with the specifics of your work environment. So just copying the files from a different working machine is only going to get things worse (I mean, you are trying to load a set of plugins that won’t match with yours, you are loading preference settings from a different machine, you are trying to login with an invalid token).
Indeed the autosave.vcv file is often the first thing to remove when a usually working Rack begin crashing at launch.
So the better thing you can eventually try is simply a clean uninstall and reinstall of the application (launching the downloaded Windows installer).
However if you are still curious, I have just sent you a zipfile containing the fresh structure created by Rack at first launch (that is: the plugins folder with the Fundamental plugin copied in it at startup, the settings.json file with the default values for my system, the log.txt file for my first launch, and the autosave.vcv blank template autogenerated when exiting the program, without no operations, no patching and no modules loaded).
That said, I hope you recover your Mac! :wink:

did anyone find a solution to this as i am having exactly the same problem , cant even get it to start ,

1 Like