Rack won't open after fresh install

I really need some help, I’ve just downloaded this for the first time and I’m encountering the problem of Rack only running in the background (ie it is in the task manager’s background processes, but using 0% CPU and a static 24.6MB of ram). The problem does not seem to be antivirus-related, and I do not use One Drive. Because the program won’t run properly I don’t have a log to reference. Running as an admin does nothing.

Running win10 64x with Ryzen 7 1700, 16 gigs ram and GTX 960.

Did the installation go smoothly ? Maybe uninstalling and installing again might solve it. Try to run the Installer itself in Admin. If it still doesn’t change, then i would advise checking if your graphic card drivers are up to date :slight_smile:

Reinstalling does nothing, and the installer already runs as admin by default. Drivers are up to date

Perhaps Process Monitor can show what it’s doing ?

1 Like

If you open if from a command line prompt perhaps it will “log” some messages to the console before it dies.

1 Like

I don’t think the problem is that it starts and dies, it seems to just be in a limbo of failing to start

I don’t know how one would know, but it you say so.

I dont know if any of this will be helpful - but a few things to try:

Check the installation folder permissions, or uninstall and try reinstalling into a different folder/drive.

Check Windows Event Logs.

Your running the installer as admin? Try running rack as admin.

Not antivirus related? Using Windows Defender? temp disable it or create an exclusion to be sure.

If you have any 3rd party security software, temp disable those too… to test. Even try killing any un-needed shit in the systray.

Got a usb audio interface? Try disconnecting it then starting rack. I have a similar spec to you and while I’ve never had this issue, my Audient iD14 interface was acting weird for months before i figured out that it was the usb root hub it was hooked into (MSI mobo). Just swapping usb port and cable wasn’t enough in my case.

In fact, try removing any non-essential usb devices, just to be sure.

(this ones a bit of a stretch) I had an issue recently with Waves plugins not loading. That turned out to be a C++ redistributable problem. Rack is based on C right? Maybe theres a dependency that aint working in the same manner so repairing c++ redists via add or remove programs or downloading the lastest installer from ms might do something. (probably not though.)

good luck!


Thanks for the software! I can’t really make much sense of this to be honest, to me it’s just miles of unidentifiable processes.

The first screenshot is how it started, the second is when it started messing up, and the last is how it looked when it gave up and stopped. This all occurred within 2 seconds.

1 Like

Unfortunately the simpler of these tips have been already tested. When it gets into stuff like disabling processes and removing programs, I really have no options here as my PC is a large editing suite with tons of software and creative tools. Trying to find something causing compatibility problems would be like trying to find a specific rock inside a volcano full of melted rocks

Yep, i hear that.

Looking at the process monitor screenshots, one thing that stands out in the first image is Uninstall Monitor. I don’t know what it is or what it does but if its running when rack is loading, it may be interrupting its startup so maybe try switching it off?

what looks like it may be an issue is the user name has a cedilla (Darç) and this is getting escaped into two characters on the path lookup leading to path not found error (about halfway down the second logfile screenshot). Most of the code can obviously handle unicode characters fine, but this line stood out to me…


exactly, the errors could just be normal though.

To rule that out.

Try starting rack.exe from the commandline, specifying a user dir without any “international” characters in it:

rack.exe -u “C:\test_dir_with_only_ascii_characters”

that’s a good point - I think I’ve heard about this issue before - maybe that is it. As a programmer I would for sure say that in general you should not make a username that is non-ascii. A lot of software (that I have worked on) will fail. Yes, it’s a bug in the software, but…

1 Like

yeah it’s my day job. Which is why I’ve tried to avoid getting involved in VCV code as music’s my getaway, but as a dev for 25+ years I’ve hit most of the issues and still got the brick wall marks on my forehead to prove it.

1 Like

I once had to deal with a “stop ship” issue because Java didn’t know what to do with paths that had unicode surrogate pairs in them! (which tend to only come up in people’s names). I do have to agree that programming VCV is an odd hobby for somebody like me who spends all day programming. The only line in the sand I draw is “work is for making money, dsp is for fun”.

1 Like

I’m thankful for all the work you guys (and gals) have put into VCV rack. At some point if I feel I have something unique to contribute I may get involved, but I’ll probably leave it to people who are better suited to real time systems work. My specialism is back end systems integration, mainly async web services so not really much of an overlap. :slight_smile:

Well, if you ever felt the desire to make some modules I’m sure you would be good at it. For sure you don’t need to be a master of everything. That’s one of the great things about VCV - so many people bringing different things.

Thanks for pointing this out, you’re probably right. Unfortunately it’s a rather difficult problem to fix and very risky. I’ll put in the feature request to add a work-around during initialization.

How would I reference the correct file without using the file name?