Rack doesn't start

Everything was working finer but I tried to start rack and no go. I rebooted and still no such luck. Here is the last part of the log showing the error? Any help would be appreciated.

[2.054 info src/plugin.cpp:171 loadPlugin] Loading plugin from I:/OneDrive/Documents/Rack2/plugins/Valley [2.055 info src/plugin.cpp:242 loadPlugin] Loaded Valley 2.0.4 [2.055 info src/plugin.cpp:171 loadPlugin] Loading plugin from I:/OneDrive/Documents/Rack2/plugins/VCV-Console [2.488 fatal adapters/standalone.cpp:49 fatalSignalHandler] Fatal signal 11. Stack trace: 15: 0x0 14: 0x0 13: _C_specific_handler 0x7ffbf0897f60 12: _chkstk 0x7ffbf16b2300 11: RtlRaiseException 0x7ffbf1661070 10: KiUserExceptionDispatcher 0x7ffbf16b0f20 9: ZN4rack3drm7Context4loadEv 0x7ffafd2b6010 8: init 0x7ffafd2a2e60 7: ZN4rack6plugin13normalizeSlugERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE 0x7ffb0ae9b600 6: ZN4rack6plugin4initEv 0x7ffb0ae9c2f0 5: ZN4rack6plugin4initEv 0x7ffb0ae9c2f0 4: ZN4rack6plugin4initEv 0x7ffb0ae9c2f0 3: ZN4rack6plugin4initEv 0x7ffb0ae9c2f0 2: ZN4rack6plugin4initEv 0x7ffb0ae9c2f0 1: BaseThreadInitThunk 0x7ffbf0137600 0: RtlUserThreadStart 0x7ffbf1662680

You can try moving settings.json away from the same folder as the log.txt (or renaming it). It would be interesting to look at it to see if it’s corrupt, so you might need to save it for a bug report.

Others have had success by deleting the files in the “autosave” folder.

When asking for help on a crash, it’s usually best to say what version of Rack precisely, and the OS and OS version you’re on (however since we see OneDrive in there it’s presumably Windows, but still need OS version ).

This appears to be crashing in the VCVConsole plugin. You should report it to VCV - Support (vcvrack.com). The plugin could be an innocent victim here. The engine locks a mutex in JSON parsing sometimes and sometimes not, which is a tricky thing to always get correct.

Others will tell you to not use a OneDrive folder. There’s a command-line option to tell rack where the user folder is located, and you can point it somewhere the OneDrive isn’t potentially getting in the way.

2 Likes

Yeah, you have your documents folder on OneDrive - bad idea!

I have been using OneDrive for some time and have found it to be a very useful program. I have had no problems with it. I tried moving the settings file but no good. I have reported all of this to support so we will see. I am on Win10 with the latest updates and all of that. I am running the latest version of Rack Pro.

And you say that why?

Because it makes VCV crash.

1 Like

You may enjoy it n general, but it happens that vcv doesn’t like that. There are various workarounds. It is perhaps a limitation of vcv that this happens. None the less you should not do it.

What exactly happens? Someone stated that OneDrive makes Rack crash; what evidence is there of that? Also, do people contend that this “problem” is unique to OneDrive or does this also happen with Google drive or other virtual solutions.

If you are interesting you can ask google “one drive vcv rack” gave a lot of hits. If you want a 100% repro bug scenario - sorry, I’m not interested. Just trying to pass on the common wisdom. If you want to start an argument about it, that’s fine, too.

1 Like

I will do that. I’m not trying to argue about this; that’s just plain silly. I am just curious about the situation.

I have researched this and I only found one documented instance of Rack having a problem and it being fixed by removing OneDrive and it was questionable at best. The user claimed OneDrive was affecting his system in a manner that I question. The claim was that OneDrive was changing paths to his documents folder on its own. If this was happening, which I doubt, it would have had other major effects on his system causing far more problems than just Rack. No one else reported anything like that. Other than that, there were several people who said OneDrive is bad without any supporting facts at all.

Just because someone says something and other people repeat it does not make it true. After reading all of the search results I think I found the original source of this rumor. People should stop spreading unsubstantiated information like this; it is not helpful and leads people to doing unnecessary work.

I think this was where it was diagnosed first - I have linked to it several times, in case the information could help other people.

BTW. This is not VCV professional support, they prefer you use this form:

Come on, just tell @shofb the real info! I know you are holding out!

Yes, that is the only documented instance that I found and I seriously doubt it. As I said if that was happening his whole system would be really screwed up and he would have far more problems than Rack. Given the number of people using OneDrive successfully I think it’s somewhat irresponsible to assume that OneDrive is flawed and causes serious problems to Rack.

stop being an idiot, please. No one has said there is anything wrong with your precious one drive. People are saying that VCV does not like to have it’s autosave folder in a one drive folder. You are free to disagree and forever be unable to use VCV. totally fine. totally your choice.

I’m sorry you think that trying to get to the truth about something makes me an idiot. I fail to see how disagreeing with people spreading false information makes me an idiot here and somehow makes me unable to use VCV. The idiots are people that buy into something based on no evidence at all and then spread that false information confusing the issue. Do you always attack someone for being interested in finding the truth and who happens to disagree with you? Grow up “precious OneDrive” LOL

blocked.

Hilarious. This person comes on this thread, directly attacks me for no reason and then when I defend myself blocks me. Very mature. Doesn’t matter since he was contributing nothing of any value to the thread except unverified innuendos. See ya kid.

Here is one situation where onedrive causes problems for users, in a scenario very much like Rack plugins. Let me know how many examples you want. But I would turn to technical logic as well: When you have a program, like Rack or many others, that needs ownership of files for their integrity, it’s a bad idea to at the same time have a service that also assumes ownership of those files, and can lock them and read and write them.

Here’s another one:

And here’s another one:

3 Likes

Have you at least tried disabling one drive. I‘m one of the undocumented cases where VCV worked fine after disabling one drive. @Squinky, @LarsBjerregaard and me have been on the forums for some time and have seen numerous questions about VCV not running. And numerous times one drive was the problem.