Rack not launching on Win10 [Solved : it was OneDrive's automatic backup's fault]


I’ve installed VCV rack on a new laptop (Rack 1.1.6, Windows 10) and I can’ launch it. Every time I try, the process is created and I can see it in the tasks manager using about 38MB of memory but nothing is displayed. I can kill it from the tasks manager and then the same thing happens when I try again.

I searched the forum and read some similar topics but nothing mentioned in them worked for me so far.

Here’s what I tried :

  • Running the exe as admin
  • Forcing it to use my RTX2070 graphics card instead of using the default Intel one.
  • Disabling Windows Defender
  • Telling Windows Defender to let it use whatever it needs (I can see Rack.exe properly listed in the apps that are allowed to use the network/etc.)
  • Running in compatiblity mode for Win8 and Win7

Still, I always get the same result. I suspect that this might be related to my graphics card. I updated the drivers to the latest available from NVidia, btw.

Does anyone have an idea of what could cause that issue ?

Here’s more details about the laptop :

OS Name Microsoft Windows 10 Home

Version 10.0.18363 Build 18363 Processor Intel® Core™ i7-9750H CPU @ 2.60GHz, 2601 Mhz, 6 Core(s), 12 Logical Processor(s)

BIOS Version/Date Intel Corp. QCCFL357.0048.2019.0808.1937, 08/08/2019

Locale Japan

Installed Physical Memory (RAM) 16,0 GB

Name Intel® UHD Graphics 630

Driver Version

Name NVIDIA GeForce RTX 2070 with Max-Q Design

Driver Version

Edit : no log file is created anywhere (documents folder or user folder, I checked everywhere)

From what i can see, VCV is launched properly in fact no error is displayed and no log is created. But you still can’t see the window. Is it correct? Does the logo show in the taskbar?


You’re right, it would be more correct to say that the application launches but nothing is displayed. Hence my guess that this could be related to the graphics cards.

There’s nothing in the taskbar (or when pressing alt-tab), the only way to see that something is going on is to look in the tasks manager.

Hi, do you only have windows defender as protection?

Did you try disabling one of the graphics cards in the device manager of Windows?

Yes, and I tried to deactivate it, and also explicitly allowed Rack.exe to use the network and even to disable scans on it…

Yes, I just tried that with either card and got the same result…

Is there a way to compile VCV Rack with Visual Studio ? If so I could maybe run it in debug and see what’s going on (though I don’t know the codebase at all…).

This guide shows how to set up Rack building and debugging inside VS Code:


Try and open the Windows log viewer and see if something gets written in the Applications log.

Usually Windows Defender doesn’t interfere with VCV Rack. This shouldn’t be the problem. Have you disabled Windows Defender from services?

one more idea:
where have you installed VCV?
I would try to uninstall it and install it in a different location.
and maybe if it still doesn’t work, uninstall again and install it in yet another location …

Thanks for the suggestions.

I already tried uninstalling and reinstalling without success, I tried again putting it on another drive and got the same results.

I couldn’t see anything related to Rack in the event viewer either (or any even at the time when I tried launching the application).

I have very little time for this right now so I guess I’ll just use something else when I have some time to make music on the laptop…

  • Bug reports and feature requests for VCV Rack are allowed in order to discuss with other users, but they are not handled by VCV developers. See Bugs and Features for properly reporting bugs and requesting features.

Updating here to mention that after some help/pointers on a github thread I created I managed to find out my issue came from the fact that OneDrive was backing up the My Documents folder, which actually changed the path of that folder and seemed to trick Rack into non-existence.

Disabling the OneDrive backup made VCV Rack behave normally. I’ll change the thread title to better reflect this in case other people have the same issue.


Bad software, bad … :unamused: Good you cleared it up and thanks for sharing!

1 Like