Problem with Hora Hi-hats and Resetting sequencers

So I have three problems actually and it would be cool to hear what you guys think.

  1. After one of the previous big updates VCV Rack 2 just do not recognise the name of my Audio interface on Direct Sound (on Wasapi it does), could be the font issue or something, cause it’s in cyrillic, all the latin letters look fine


  1. Sometimes Hora Hi-Hats output says “NaN”. I don’t really think that’s the Hora glitch, cause it looks like it could be related to the first problem or something else, like my CPU or something. I tried re-downloading the module, but no luck

looks like it is a Hora glitch, wrote an email reporting the bug

  1. Sometimes some sequencers (ADDR and GateSeq) reset to the second step instead of the first (I use Impromptu Clocked for clocks and resets). No swing, no delay, no modules between clocks and sequencers. Usually I just set the starting step to the last position (the one before 1st) if it’s possible and everything’s fine. But it annoys me, especially if it’s GateSeq, cause the offset rhythm makes me seasick. It could be CPU related, cause it happens more often when there are many modules in the patch. Any ideas?

probably solved!

For item 3, make sure to use both run and reset cables between the clock and the sequencer, and let the clock control the sequencer’s state. More reading here, see recommendation iv in particular:

1 Like

Hmm, it works with GateSeq, but not with other types of sequencers that don’t have a run input. Like ADDR or NoteSeq… Thanks for advice anyway!

I think there’s a discrepancy between module makers whether a module should restart instantly or restart on the next incoming clock.

When I used ADDR or Gateseq, I would turn the dial on the bottom of ADDR to 8 instead of 1. The same goes for Gateseq. There should be two knobs next to the pattern knob to offset the sequence.

1 Like

What do you use now?

I use Entrain Timeline and Voxglitch digital sequencer.

The Voxglitch sequencer has an option to either reset instantly or on the next clock signal.


Ah! Yeah, I love this collection! Entrian collection is commercial, i think, so I think never tried it. I am just a poor boy from a poor family

I’ve also noticed this as well as it not having as long a duration as before. And i’m using onboard audio.

The Hora hihats NAN issue has been around for a while. I’ve actually stopped using that module because of it. But if you must use it, and it outputs a NAN, duplicate the module with all the connections and delete the original. This used to work for me.


Just make sure that “outputs high on reset when not running” is turned OFF.

And it works as you want, starting on step 1 :sunglasses:


I was just about to mention this and you beat me to it :joy:

1 Like

Oh! Thanks, I never even noticed this thing in the menu, haha. Alright, so it probably solved the 3rd problem!

1 Like

Oh, so it is a Hora problem… Was this glitch ever reported? I think it was, but maybe we should report it again anyway

Just wrote an email to, let’s see what happens

1 Like

It’s been reported before, and I remember being it brought up here in the forums also and the author stated that they made a fix for it.

It remained an issue and I reported it again many months ago now along with an issue I had with the Hora drum sequencer and although I received a response neither issue has been addressed.

Development for Hora’s modules is dead as far as I’m concerned and I no longer use them.

1 Like

As for the sequencer start issue, I find that setting Impromptu Clocked to ‘On Start - Send reset pulse’ found in the right click context issue solves this most of the time. Notably Entrian’s sequencers start as expected when Clocked is set like this.

Looking at my default settings for Clocked, I also have ‘On Stop - Do internal reset’ selected but cannot remember if I have this set to work with my On Start setting or for another reason entirely. Try both is the On Start setting doesn’t seem to work.

Sometimes I’ll also use a module like the Seq Adapter from RCM when I have a lot of sequencers in a patch and some are not behaving as expected. I find Valley’s Topograph syncs better with this utility for example.

Seq Adapter solves the issue that HBBoogie mentioned. You connect the master clock’s Reset, Run and Clock output to it’s inputs and connect it’s Reset and Clock output to your sequencers. I’m sure I have come across similar utilities in the Library recently but cannot recall their names.


1 Like

Thanks! Well, for now it looks like Yeager’s solution works well, so I’ll wait with trying new settings and modules… Thing is… I rarely stop the clock, I don’t like it for some reason. I just push reset and that’s all. I stop the clock only when recording and if I am trying to record and all the sequencers and modules sound weird on starting the clock (like Autobreak goes mental for a second), I just record it continuously and then cut off the weird parts if they are not interesting. They could be interesting though… So yeah! Thanks!



Raphaël Hoffman (from Hora) just answered to my e-mail, he’s saying that they’re working on this glitch and the update will be out soon! Nice


Soon means… right now, just downloaded the update(s) and a new module. :sunglasses:


The first thing I did was pop in a Hi Hat module after updating and immediately got a nanV on the output.

1 Like

To be fair I don’t think today’s update was to fix Hi-Hats module. Also for now Hi hats are working fine in my patch… It might change later though, of course