Lindenberg Research Announcements Thread

Ah, okay, makes sense now. But interestingly, looking at OrangeLine Fence code, Dieter has code to not run process() until initialization is complete, or at least it appears so on quick review. So, in a weird way, I think it may have been appropriate to tag me :wink:

I cannot remember the history on Meander’s use of this safeguard. I will take a look at my backup files to see if I can refresh my memory,

Do many modules safeguard process() until initializations are complete?

Rack v2 has a headless mode (I’m not sure if it is actually working), so modules should run without any widget initialized. I did not look at anyone‘s code but I always considered it mandatory to have no dependency from module to the module‘s widget.

1 Like

Yes makes sense. I was just mentioning what Dieter said at the time in case it offered some clues, as the crash on adding a module from the browser sounded quite similar.

I just tested @steve 's idea of adding all modules except ones known to have issues in both standalone rack and when running as a VSTi. I can close and reopen the program in standalone. The same test crashes both Reaper and Studio One.

Interestingly, I can load the saved Rack save file when running VST but if I save and reload the project file it crashes the DAW.

No obvious errors in the log file.

Following on from what Seth said above, I tried in Bitwig adding all the modules except ‘Blankpanel | Multiple’ and if I then delete the Rack instance, then undo, it crashes Bitwig’s audio engine.

I noticed something else… If I add the modules then close the Rack window then reopen it, there are graphic glitches for the 4 modules that have a text display in the newly reopened window - Sally, No!zer, Spreader and Voltages - sometimes I just get a white box where the display should be and sometimes the display shows but it’s glitched (see grab).

This made me think that could be what is causing the crash when deleting the Rack instance then undoing (or quitting Bitwig and reopening it) and that seems to bear out. If I add all modules without a display (except Blankpanel | Multiple) then I can delete the Rack instance, then undo, and it all loads fine again. But if I include a module that has a display like Sally, then delete Rack instance/undo leads to the audio engine crash.

Here’s an image showing what I mean by graphical glitches on the displays:

I can confirm the same. Tested in both reaper and S1. I can add the following modules without issues. As soon as I add a module with a text display, close and reopen, the DAW crashes.

I fixed the Issue of the Blankpanel, now it works fine. If my Windows didn’t crash it would be already uploaded :frowning:

The gliches are not the reason for the crashes, but I will take a look tomorrow…

Thanks again to the great testers here :smiley:

2 Likes

SANGSTER!!! I was looking everywhere for this delay about a month ago. I couldn’t remember the name or who it was made by. All I could remember is that it had a lion picture on it. Glad to see these modules are coming back!!!

3 Likes

It’s awesome. Modulating time by small amounts is awesome.

2 Likes

Yes! Sangster has such a great character!

1 Like

Okay, so all issues have been fixed and it is running stable :wink:

I’m going to do some excessive testing tomorrow, supported by a very dangerous amount of Italian espresso, to get sure the next beta won’t crash… (or Whisky if it goes horribly wrong…)

Sorry for the delay and the amount of Betas, I am alone and just testing and developing a small amount of time… so please be patient, it will definitely be released, but first it must run stable and look great :smiley:

More on this tomorrow, stay tuned!

20 Likes

No need to apologize! Bug-hunting can be a PITA—thank you for following through!

3 Likes

Hi all,

let’s go for a new Beta 5.2 :

Windows

Mac

It fixes all reported issues and was tested for stability and stable rendering. I really hope it works now and passes user tests :slight_smile:

I hope you’re all well and Thanks for testing!

Cheers Patrick

7 Likes

Initial testing looks very promising!

No issues adding all modules, closing then opening again in Standalone.

Same in the VST (Mac, Bitwig) for the most part… The first time I added all the modules, then closed the Rack window, then opened it again, I did get a graphical glitch on some modules (see grab) but I have been unable to repeat this since. After closing the window that had the glitches and opening it again, it opened fine and has now been through many close/open without issue.

Deleting the Rack instance and then undoing also fine. I’ve not experienced any crashes with this new version - just that one-off graphical glitch.

Edit: I should add that I originally placed these modules in the VST instance using the previous version - so perhaps that may have had something to do with that one-off glitch.

2 Likes

Hi Patrick,

Thank you about 2.0-beta5.2, but I report the same GUI issues… OS is Windows 10 Pro (22H2, x64), I have exactly the same issue than Steve (and Rodney) have reported about 2.0-beta5.2.

Either from Bitwig Studio v4.4.6 and REAPER v6.71.

VCV Rack 2 Pro v2.2.1 preview (as VST 2.4 plugin).

This issue appears as soon as I close then I reopen VCV Rack window. Affected: all modules have “wood” texture (I’ve noticed this fact) + Neo. No crash. Doesn’t occur by using Rack as standalone app, and if I delete the VCV Rack instance then create new one.

YT Video (not referenced) HERE

Cheers. Dominique.

Thankyou for Beta 5.2. On Windows I too can still see the graphical glitches but so far only with Neo and Preheater. I see it after closing and reopening the plugin window multiple times.

1 Like

Oh man, I hate it… :frowning:

Can anyone confirm this on Mac? I tested a lot with no problems at all :-/ Even on Windows 10.

1 Like

I’m on Mac Intel.

On the plus side there are no longer any crashes so things definitely moving in the right direction!

1 Like

As indicated above, my rig is Windows 10 Pro 64-bit (22H2).

Behaviors seem identical than OSX.

Don’t hesitate if I can help for additional tests!

1 Like

I tested on both a fast Win10 computer and an old Intel Macbook Pro and did not experience glitches.

Also of note, all the previous issues using the modules when running as vst have been fixed :slight_smile:

2 Likes