Could not load patch: Unarchiver could not write file to dir: could not unlink. Help Please

I see this has occurred before ( unarchiver could not write file to dir: could not unlink - #4 by user841) but there does not seem to be a posted solution. I have been running Rack 2 since it came out with relatively little problem that wasn’t somehow related to a misunderstanding on my behalf. I have been running it today for several hours, and in searching for a way to do long grouped fades for scenes, I had been following along with Omri on his lengthy video on the Shapemaster. I downloaded his patches and was using the “Patch 5 - as a sequencer”, worked fine, and decided I was ready to try fiddling with it in my own patch, but as soon as I tried, I had this error message pop up. I did a re-boot to no avail. I am on a Windows 10 Pro machine. Nothing has happened today in the way of updates. I have not changed any settings. Anybody?

Edit 1 - I can load / import a selection, but not open a patch. Edit 2 - I was going to do an uninstall and re-install but it’s getting late and perhaps there’s an easy enough fix out there now.

as far as i can tell, there are a variety of causes - folder permissions, anti-malware software, running file-sharing software like onedrive, etc…

2 Likes

Yeah, like Bruce says. Try in Windows and turn off the “Ransomware Protection” feature and see if that works. It’s been known in here to reek havoc. Also try disabling 3rd party anti-virus software, check your Documents folder is not on OneDrive, DropBox or the like.

1 Like

I will look at this when I get back there but why would it randomly decide to do this? I haven’t changed , added, or deleted any features or the like for quite some time and it’s been running smoothly. Pretty sure I have no 3rd party AV software. All my programs are on a single 1 TB SSD while all my work is on a 2TB HDD (mirrored by another 2 TB HDD). I am semi computer literate at best - I can find my way around and follow instructions reasonably well - but I’m definitely more of a “let’s do a hard reset!” type of guy. So I’ll take a quick look at this Ransomeware issue but it’s more likely then that I will do a re-install. In any case I will detail my results here for future reference. Thanks guys.

I’m on Win11 and had to reboot my PC yesterday, apparently due to updates. When these happen on a Tuesday, typically, often I find that my computer is not asleep as I left it, but rather has been shutdown, forcing an attended reboot. Sometimes updates seem to come via daily Defender patches, but I may be wrong on this. I had some strange behavior yesterday that I assume was due to updates. It took me a couple of reboots to get everything working okay again.

My Windows updates log did not show any OS or driver updates for yesterday.

It’s the nature esp of ransomware protection to “suddenly” decide to do some thing.

1 Like

So I uninstalled all 3 instances of VCV Rack - I had the original one, VCV Rack 2 Free, and VCV Rack 2. When it re-installed, I let it startup like it will ask you when you install a new program, and the last patch opened. So I closed that and then got the Unarchiver problem again. I uninstalled it once more and this time did not let it start automatically, and chose a patch I’ve been running without issue for several days - and Unarchiver again. Before I did this, I checked this Ransomware thing and it is off. As mentioned before, I am not doing any file sharing, all files are local on this machine. The only thing I am running is Windows Defender and Windows Security. This is very frustrating. here I can run Rack 2 on my Surface Pro sitting over on my kitchen table, but my studio computer that has everything set up for doing the studio stuff is useless for Rack all of a sudden.

Edit - Tried installing VCV Rack 2 free but same problem. Edit 2 - changed a number. Edit 3 … gawd! I have to use Ableton without VCV Rack. I feel like I’m missing a limb…

Is anyone aware of how quickly (or not) Support gets back to you? I sent a request in via the web form … I was going to leave a link even though I suspected everyone here would be well aware of it, but I don’t see this web form, just an email address now. I sent a request in and I’m very sure I used a web form because I recall dragging the change log into it… Has this changed recently? Like in the last two days? I was going to ask how long it normally took and mention I didn’t receive an acknowledgment or reply with a ticket that they would look after it and get back to me. I absolutely realize this is a new venture and things will be fluid, so I’m not griping. Just inquiring. I will send an email now as well.

On VCV - Support the form is there, to the left, it takes a couple of seconds to load…

1 Like

Thanks u/LarsBjerregaard. Paul Gatt from support has gotten a hold of me. I will post details as things progress.

Well, an update of sorts - there has been no solution found to this unarchiver issue and I have not been able to use VCV Rack on my main computer for 9 days now. I can use it on my desktop at work and on my Surface Pro 7 - but not on my main studio rig which is very frustrating. I had contacted Support via the online form and then via email and did get a response from a Paul Gatt 5 days ago but nothing since. There doesn’t appear to have been a real solution found for the last time this was brought up per my initial post. What is this unarchiver? Is it a Windows thing or VCV?

Someone correct me if I am wrong on this.

My understanding is that the unarchiver is responsible for “unzipping” a new plugin or updated plugin to the Rack plugin folder. That is probably done via a 3rd party library such as zlib, but that is just a guess. This would be part of Rack. The most common reason for an unzip failure is that the destination folder or drive is unwriteable due to permissions or a ransomware protection system controlling access to the harddrive folders.

Edit: Rack could use the unarchiver for opening patches. I don’t know. If so, I can imagine there could possibly be an issue with a corrupted patch file that was downloaded from the web, but I have no idea whether that is possible or has occurred ever.

2 Likes

“could not unlink” is a valid zlib error message. It appears that such can be related to the archive containing paths that do not exist on the destination machine.

So if I understand correctly, Rack runs fine until you try to open a patch, then it spits out the error? Try a quick experiment. Load the default template that comes with Rack, or start something from scratch. Then save it in the same folder where Rack is installed (in program files) or in the Rack folder in “documents”. See if you can open these again, if so, Rack is having trouble trying to open the patch from your other drives.

I will try this tonite. Thanks for something to try!

Okay - Just to clarify, my C: Drive is a 1 TB SSD. I have two 2TB HDD that I store all my project files on for Reaper, Ableton, and VCV, along with all my music and videos.

So I can open any of the Selection files I have. If I save it as a project to the drive where all my other VCV projects are, I can no longer open it due to the unarchiver issue. So I recreated the project as above and saved it to the Patches file in C:\Users*ME*\Documents\Rack2\patches and tried to open it but get the same unarchiver error.

Now, something different I am noticing - and this is after uninstalling it and reinstalling it for the purpose of trying all this with a fresh install - it tries to open one of the last patches I was working on with the Shapemaster when this problem started 9 days ago (and several re-installs later). Even if I create these new projects as I have been discussing and then close VCV, if I open VCV by using the taskbar shortcut (expecting to see the project I just saved), it instead opens the Shapemaster file. As well, this Shapemaster project file has no name - it just says VCV Rack Pro 2.0.6 at the top where I would expect to see the project name. (I’m not 100% positive about this but was pretty sure that was the case). So I can’t really go find this exact file and delete it.

If I open VCV by trying to open the project from it’s file location, I get the unarchiver error and when I acknowledge that, it clears the template / project so there’s no modules there. I cannot open a file or a recent file from the file menu.

Have you tried deleting your autosave folder contents?

2 Likes

Just trying this now actually… BRB

YES!

I moved a bunch of the files out of the Rack2 file in documents - licenses and my Selections file along with several 1kb Max JSON files that were just kind of hanging out - deleted the autosave file and did a complete re-install and re-downloaded my plugins library, and I’m back baby!!! Thanks k-chaffin and everyone else that sought to lend a hand. Have a great weekend. I will :slight_smile:

2 Likes

you have to give rack “rights” to open documents in your documents folder. Whatever it is you system that is preventing that, tell it not to.

I respectfully disagree. I never had to “give any rights” to begin with, so why should things change? Well yes, of course there are the unwanted consequences of the various updates that sometimes don’t play well within someone’s particular system, but that’s not (supposed to be) the norm. I suppose the type of person who might be drawn to VCV Rack, and especially someone like you who develops the software and understands the coding, might be more technically astute then the average musician. But most people are not going to know what it means to “tell it not to”. So I consider this a bug that needs to be understood and dealt with. IMHO.