Announcing MFX for VCV

Hello, I maybe having problems with MFX and Axon Expander- when I change things in this patch below it crashes, I have built the same patch without the MFX module, and it works fine. It might even be another module.

Please see if you can reproduce the crash your end. Windows 10 Laptop

Here’s the patch:

Wave tape ensemble-varying wave +MFX Axxon.vcv (8.4 KB)

I loaded your patch, I don’t have these plugins: Could not find module Ahornberg/TapeRecorder Could not find module rackwindows/tape Could not find module Ahornberg/TapeRecorder Could not find module ChowDSP/ChowTapeChew Could not find module rackwindows/chorus

But I could make changes, no issues. I tested on Linux.

Thanks for having a look, those modules are all available in the library. So in theory it could any of those modules playing up!

I know, but it doesn’t mean I want to install of them :wink: But I don’t expect your issue is related to MFX, at least I haven’t had any issues (except for the known one that is fixed now).

Thanks, so the mystery still continues. I’ll keep experimenting with the patch.

2.0.1 is crashing for me on Windows, both in Rack standalone and VST.

Adding it to an empty rack - with or without an Audio module - causes MFX to have a blank screen and Rack will then crash following any other interaction (e.g. deleting the module, adding another module etc). If you add it to a rack with, say, a clock running, the clock will freeze; so Rack’s processing crashes immediately but the application itself doesn’t until you invoke it to by doing something else.

image

image

image

1 Like

Thank you! Despite the encountered problems outlined above, in turn just a note on my part that everything is now working as expected over here. Tested in Win 10 / Reaper. Can run multiple instances of VCV and have different algorithms in separate MFXs at the same time, no crashes yet :+1:

Same issue for me, just bought it and getting the blank screen and locks everything up. Latest versions as far as I know…

:+1:

I normally use 44.1 @ 64 samples on my audio interface. But I set 96 on the VCV engine for better audio quality / downsampling.

I’ve been on with ALM support - I think the issue is with the VCV engine setting for anything set manually above 48. It works for me at 44.1 and 48 (after restarting)

I hope they can get it working on the 96 engine setting - host plugins really benefit from running at 96 - I really don’t want to lose that higher quality just for MFX.

Update: version 2.0.2 has fixed my issue, thanks.