Announcing MFX for VCV


Just tried it out, it’s great now and I don’t know how I missed that there are presets last time round, very usable device.

On Windows 10 I still see “too many instances for # of threads” on 2 instances in VCV standalone (multi threads enabled) and VST. Is this expected? Perhaps the update has not succeeded for me although it states version 2.0.

I could use two happily with multi-threaded turned off. Couldn’t previously. Haven’t tried it multi-threaded.

Ah, but that was plugin version, never use standalone these days.

1 Like

Thanks, seems OK now in both VST and standalone (I rarely use it too). Perhaps I needed a DAW restart.

Based on your announcement of multi threading limitation being fixed, I bought the module. But unfortunately with 2 threads enabled, I still get the problem. If I change to 1, it’s fixed. Am I doing something wrong? Using standalone VCV 2. Thanks

1 Like

So happy to see you guys coming over to Rack! Have you considered cloning MCO and Megaslope/Pip Slope anytime soon?

1 Like

Thanks a lot for looking into this! Fixing the multithreading problem widens the possibilities of MFX a lot; from my perspective, the ability to use it inside a DAW in multiple VCV plugin instances is the big one :+1:

That being said, I see on the library page that MFX shows it’s indeed updated three days ago, but the version of the actual module is still marked as 2.0.0 (both on the library page and after installing)? It actually didn’t show up as an update inside VCV because of this, the 2.0.0 version number is the same as the already previously installed one.

After I removed the module and reinstalled it - i.e. made sure it downloaded the currently available module from the library all fresh - it shows as 2.0.0 and behaves in a multithreaded context like it did before.


Can you check what the version screen under utilities on the MFX is showing ? What OS are you running ?

Thanks. Running Windows 10. (Actually I use both Win and Linux for VCV, but haven’t yet tested this on the latter.) The utilities version screen shows “FW VERSION: 104”

Yep thats not the newer version (should show ‘104vcv2’) . Apologies and are investigating…



Oh, I also just made sure and pulled the earlier MFX plugin.dll from a system backup, and can confirm this newer one is still different in multiple places (I compared the binaries against each other), so indeed it has changed in some way during the update, even though the fw version isn’t what it was supposed to be :slight_smile:

A small addition: I now tested the Linux version as well, and after deleting the plugin and letting it reinstall (as it won’t show as an update because of the unchanged version number), there the MFX Utilities screen shows “104vcv2” as expected - and indeed multithreading seems to be working.

Yes seems we messed up with the windows build/submission :frowning: A new hopefully correct windows build has been submitted.


Super cool, I’m glad you fixed the threading issue! Much appreciated.

1 Like

I don’t seem able to retrieve the corrected version on Windows; deleting and reinstalling results in a build with the 104 firmware still.

Perhaps this needs to be submitted as a 2.0.1 or similar for it to propagate through from the Library?

It still hasn’t updated in the library since that last time (the library page shows MFX updated nine days ago). A load of updated modules hit the library today, but the submitted MFX wasn’t in that batch yet, it seems. It will most probably arrive in the near future :slight_smile:

Window build should be good now :sweat_smile:

1 Like

Not for me. I’ve tried 2.01 in Bitwig and Cubase 12 with VCV VST. It seems to hang Cubase. Bitwig give “hung processing audio” message. Just adding MFX to the rack. Previous version seemed OK.

Good over here. 104vcv2 on the Utilities display.