A strange one: Rack looks like it's there and open in my task bar but doesn't appear on screen

I have this post open about running two instances of Rack 2 on 2 different computers over an ethernet connection. I was going to work on this and tried opening Rack on my laptop but the weirdest thing - it’s like it’s open in another window / screen even though I have no other screens connected. It’s “alive” in my task bar and when I hover over it I see it but when I click on it to bring it up it doesn’t show on the screen. It’s running fine on my desktop. I have restarted the laptop, uninstalled and re-installed Rack. Any ideas on this? Ableton works fine… In saying that about Ableton I tried to open Rack in Ableton as a troubleshoot but got a message that “This VST2 plug-in is not compatible with Live” (and holy f**k but everything seems t be fighting me - I took a screenshot on my laptop of this and emailed it to myself because the networking isn’t networking properly and though I can open and look at the jpg file on my laptop it won’t open on my desktop when I try and download it … so the attached pic is actually a pic from my phone). I tried using the VST3 version and it just crashes Ableton.


Windows 10 Intel i7 machine.

Here’s a pic of my screen with Rack apparently open but will not open on the only screen available. 20230127_194530

In Display Settings there is nothing to indicate the existence of another screen.

Perhaps it’s off the edge of the screen? Click its entry in the taskbar, then press Alt+Space, M, Left-arrow, then wiggle your mouse around. With any luck it will reappear…?

I tried your suggestion as well as a few others - cascading windows for example. It does not bring up the screen. There is a quick little visual effect of the program sliding down to the taskbar when I click on it but that’s all. On My Desktop (and normally on my laptop) if I have software like this open and I reduce the screen, if I hover my mouse over the task bar icon I get an image of that program:

I have tried opening a patch that I had working previously but when I hover over the Rack icon it’s just blank.

If you kill all Rack.exe processes and start it again, then kill it again, what do you get in Documents\Rack2\log.txt?

I do not pretend to understand code:

log Jan 28 2023.txt (65.9 KB)

Thanks, but I can’t see anything unusual in there.

Try moving aside Documents\Rack2\settings.json and Documents\Rack2\template.vcv and see whether that helps?

(The settings file might contain a silly window size or similar, and the template might refer to a problematic plugin.)

1 Like

Thanks very much for the troubleshoot Richie, this has worked. I see after restarting that there is a new settings.json file. I screen grabbed this shot below prior to that restart. I do not know much about the .json files but why are the ones I have shown located here? Is this fine?

Ah, great! Happy to help.

Those JSON files store settings, for Rack itself and for some of your plugins. It’s fine that those are there. They’ll typically get recreated with the default settings when you run Rack again.

Sometimes they can get corrupted, or a new version of a plugin can be confused by something stored in one of those files by an earlier version, so it’s worth trying moving them aside if things go wrong.

1 Like

Thank you. A good learning experience for a Saturday morning. Have a great weekend!


Another way to fix this is to edit the settings.json file. I’ve had this happen to me, and editing these values resolved the problem. (In my case, windowPos was way off in la-la land. :slight_smile: )

1 Like

Also shift + rightclick on the taskbar button gives you the option to full screen/minimize/maximize.