vcv VCO + LFO gives Clicks


Can anyone try this patch and confirm the strange clicks that the VCO generates when an LFO is connected to the PWM input. Wait a bit and you can clearly hear them and see them on scope and mix4. Whatever LFO I get the Clics. But only with the vcv VCO. Curious to know if the problem is on my side. (Hardware, or whatever)

Clics.vcv (2.3 KB)

PS : I just see a similar problem happened with WT VCO, and was fixed in 2.0.3. Although I’m using 2.0.6, It probably has to do with.

There was a bug logged quite a while ago against Fundamental VCO-1. I thought that was fixed, but it sounds very similar.

I have noticed this, I thought it was my soundcard because I mostly use VCV vcos, but when I export the audio, it looks like the wave is resetting.

mmh… sound like a bug then.

Should it be reported ?

1 Like

It happens here as well and is very odd. Definitely report it. the patch file was helpful.

This has been addressed (back in January!) and a solution provided here: Clicks and Pops from PWM - #5 by slimechildaudio

The issue has already been reported: **SOLUTION** Fundamental VCO Pops and Clicks from PWM · Issue #140 · VCVRack/Fundamental · GitHub but as yet no fix commit has been made…

Bruce pointed out here: Clicks and Pops from PWM - #2 by Squinky that this was first reported back in August 2020!

yep, a lot of my old VCOs just the core from VCV, have the same issue.

This is where bugs in Fundamental have always been logged. I’ve logged some years ago that are still open, But this one with the PWM says it’s fixed: Issues · VCVRack/Fundamental · GitHub

That only goes to the issue page, not a closed issue that references the fix.

you are right, the issue is still open. I was fooled by the title, which included the word “fixed” It’s awfully frustrating that VCV never fix these ancient, easy to fix bugs, but they are pretty busy…

Your Functional VCO doesn’t, not from the OP’s patch anyway.

Functional is an ancient one. It isn’t minBlep. That one I took VCV Fundamental version 0.6 and made it use 1/4 the CPU. I’m sure Fundamental 0.6 didn’t do it either. but they are both 16X oversampling VCOs, use way too much CPU.

But my EV3 and BasicVCO are both minBlep, and probably have the bug.

Ah yes, I remember you doing that.

Not from what I can tell from adding them to the OP’s patch.

oh, whatever you say.

I used similar settings on the VCO’s and the same time on the scope and levels into the mixer, no clicks at all.

Interesting. Well, that’s good to know.

Don’t know why I hadn’t gotten around to mixing your Basic and EV3 VCO’s together before down at octave 2.

Holy **** do they sound good together! :astonished:


Thank all It’s good to know that this bug has been identified and that it will be fixed one of these days.

And it’s also good to know that my hardware, which is not at its best, is not at fault.