Hi. I am by no means a developer (yet). I did however manage to build vcvrack from source using mingw64. Also managed to build and make install the hello world example from Leonardo Gabrielli his book.

I then tried to build the VCV-Recorder from source. Took me a while to figure out I needed to let git install the submodules and such, but managed a build and a make install without errors.

Somehow though it doesn’t show up in the module library. I can see the folder and the files in the plugin folder. But Recorder isn’t found when scrolling through all the modules. (hello world does show up) anyone an idea of where to check what to find a sollution?

The log.txt doens’t report any error.

In the module browser, set sort to last updated and it should be the first in the list:

Yes I did that, No luck yet. Wondering if it’s a whitelist thing as described here I had the VCV-recorder added from the library. Saw no change when I make installed it (except for the date) so removed it via the library and unsubscribed.

I’ll try a few other modules and see if the problem is just this one…

Just what I did:

  • git clone recursive
  • make dep - to build all dependencies
  • make - to build the plugin

then there has to be a plugin.dll in the VCV-Recorder folder

Make install

make install = make dist

This is only needed if you want to generate the .vcvplugin file.

Doesn’t dist copy it to the other folder? Don’t know myself…

What’s ‘the other folder’?

The one where the downloaded version of rack and plugins lives? I always build rack itself and build plugins under there , so it doesn’t matter to me…

1 Like

Me too, but dist does copy the .vcvplugin file to this ‘other’ folder. I didn’t know that.

1 Like

Thanks for the reply’s I have successfully build and installed the Ahornberg modules.

But then deleted the VCV-recorder folder. downloaded it again and since the ffmpeg is giving all sorts of warnings. So I am trying to get that installed inside mingw64 instead of pointing the PKG_CONFIG_PATH to the windows folder.

Not sure if that is the right path/decision, but so far everything is in flux and on the verge of being deleted and freshly installed again… We’ll see how far my patience reaches…

I don’t think so. make dist made a dist folder with a plugin file, But I think I needed to make install to get it installed in my working installed playable Rack/plugin folder.

1 Like

I’m working on the command line exclusively, using the shell provided by msys64.

I always do a git clone directly inside the plugins folder to clone open source plugins because downloading a .zip from github and extracting into the plugins folder sometimes makes problems, especially when a plugin has dependencies like the VCV-Recorder.

But my question is: On VCV-Recorder, did you run make dep and afterwards run make, and did you check that the file plugins.dll was generated inside the folder plugins/VCV-Recorder?

If here’s no plugins.dll, the plugin can’t be loaded by the Rack and therefore can’t be shown in the module browser.

yup did that myself. over https and ssh. I downloaded them in my build version of rack though. Which make me think they don’t show up when I do make run. Because that opens a development environment. The do show up (well not vcv-recorder obviously) in my normal Rack.

I always work with 2 shell windows, one is pointing to /Rack, to run the dev version of Rack, and the other is pointing to /Rack/plugins/<the-plugin-I'm-working-on>.

I do not use https or ssh, because I’m building on a single machine.

The shell window opens by calling C:\msys64\msys2_shell.cmd

Ah I see,

You do download from github though I think? That’s what meant by https and ssh. cloning the repositories. I have a ways to go yet before building my own modules. For now trying to get the recorder to record mp4’s would be a win though…

getting ffmpeg installed within Mingw64 proves to be a pain so back to idea one. the makefile states:

So I am guessing changing the (DEP_PATH) with the path the ffmpeg libraries (lib) folder and (include) folders are located should do the trick yes?

Also this.

# Don't use ./configure --prefix="/c/Users/HP/Rack/plugins/VCV-Recorder/dep" --host=x86_64-w64-mingw32 because this is a handwritten configure script
# ffmpeg bug: The pkgconfig dir is not set from pkgconfigdir at all. Set it with PKG_CONFIG_PATH instead.

In ~/Rack/plugins I did

git clone --recursive

cd VCV-Recorder

make dep


and the plugin was created and ready to run.

sigh… That worked up to a point until yesterday. Now it’s producing this…

HP@CatsKlap MINGW64 ~/Rack/plugins
$ git clone --recursive
Cloning into 'VCV-Recorder'...
git: 'remote-https' is not a git command. See 'git --help'.

The most similar command is

Over ssh is a little better…

HP@CatsKlap MINGW64 ~/Rack/plugins
$ git clone --recursive
Cloning into 'VCV-Recorder'...
remote: Enumerating objects: 292, done.
remote: Counting objects: 100% (88/88), done.
remote: Compressing objects: 100% (61/61), done.
remote: Total 292 (delta 44), reused 69 (delta 27), pack-reused 204
Receiving objects: 100% (292/292), 99.57 KiB | 536.00 KiB/s, done.
Resolving deltas: 100% (151/151), done.
Submodule 'dep/ffmpeg' ( registered for path 'ffmpeg'
Cloning into '/c/Users/HP/Rack/plugins/VCV-Recorder/ffmpeg'...
git: 'remote-https' is not a git command. See 'git --help'.

The most similar command is
fatal: clone of '' into submodule path '/c/Users/HP/Rack/plugins/VCV-Recorder/ffmpeg' failed
Failed to clone 'ffmpeg'. Retry scheduled
Cloning into '/c/Users/HP/Rack/plugins/VCV-Recorder/ffmpeg'...
git: 'remote-https' is not a git command. See 'git --help'.

The most similar command is
fatal: clone of '' into submodule path '/c/Users/HP/Rack/plugins/VCV-Recorder/ffmpeg' failed
Failed to clone 'ffmpeg' a second time, aborting

I would goolge for git: 'remote-https' is not a git command. and try to solve this problem first. It seems git is not installed correctly on your machine.

Well I solved it by reinstalling msys2. and building everything anew.

everything installed fine. did the – recursive thing and even ffmeg gave no troubles and continued to ./configure during the make dep step.

I’m a little lost. Still no luck. I’m done for today. Thank you for your patience… I