VCV Recorder: .MPG files don't play cleanly (both v1 and v2)

I use the VCV Recorder to record screen sessions, but the resulting MPEG-2 .MPG files are only barely playable on any player I’ve tried. I’m running on Mac (Mojave) and have tried Quicktime and VLC to view the resulting files. What usually happens is that the first 5 or 10 seconds play fine, but then the player stops playing audio (on Quicktime) or it continues to play audio, but stops updating the video (VLC). This happens with both VCV 1 and VCV 2.

I’ve had some success converting the mpg files to mp4 with Handbrake, but would much rather it just work as directly produced by VCV. I’ve tried various combinations of audio and video bitrates and havent found any that work.

Is there a trick I haven’t tried? I’m trying to avoid using AVI to conserve disk space.

I also transcode to mp4.

Works perfectly for me: MPEG-2, Rack v2, VLC Player, 44.1KHz, 16bit

Windows 10 though…

@Autinn Interesting! I was initially fully prepared to blame Apple when Quicktime didn’t work, but when VLC doesn’t work, I was sure there was something wonky in the file itself.

@Squinky Boo! But, if no one else reports a better work around, I guess I’ll just continue to transcode.

will ffmpeg do this conversion? It’s so easy to use…


will ffmpeg do this conversion? It’s so easy to use…

I initially tried to use ffmpeg, but never found an incantation that worked on these files – ended up trying Handbrake and it worked right out of the box. I’d prefer a straight ffmpeg solution - if you have a working command line, I’d be much obliged…

This works for me

ffmpeg -i untitled.mpg untitled.mp4


@PaulPiko Jeesh! I was apparently over complicating things (and not for the first time…) That simple ffmpeg incantation works for me too. Thank you!

I have had good success using Blackhole (opensource virtual audio driver) on my M1 to make a aggregate audio device with Blackhole 16Ch and my audioo Interface in Auio Midi Setup. Have Rack output to The aggregate device and Quicktime to use the blackhole 16ch as audio input and use QT to record screen. Works fine here, no skips, scratches, straight to mp4… Just got it working last night. Seems to work just fine.

1 Like

Is it as simple as inputing this command into terminal to perform the conversion?

I’m having similar issues with VCV Recorder. It was this way with Rack 1 as well, until the video bit rates were added in an update to the version 1 module. I found the second highest video bit rate setting to work. I hope these video bit rates are added back to the version 2 VCV Recorder module, as that seemed to fix the issue for me on multiple Mac systems.

I’m on Windows. I have ffmpeg in a folder, copy the mpg in there, and type that at a command prompt. That’s it.

Honestly, just record video and audio with Quicktime (File → New screen recording). It always works trouble-free, gives a max. quality result and spreads the load nicely on your CPU cores. I use “Soundflower” to route the audio from Rack to Quicktime but you could also use Blackhole. You can record a seperate .wav file with Recorder inside the Rack patch at the same time as recording with Quicktime, no problem, that’s what I do, always.

Or even better, just “Save” in Quicktime, saves to a max. quality .mov video which uploads perfectly to YoutTube and preserves the max. quality of your screen recording.


@LarsBjerregaard I use to use QuickTime as well, and for all intents and purposes, it works great. So I will use it when it makes sense to.

The issue arises when trying to screen record larger patches. Buffer underruns will be captured with the audio. One of the great benefits of using VCV Recorder is that these pops and crackles don’t print to the audio recording.

So here’s hoping that the video bit rate settings are added back to the module.

And thank you @PaulPiko for the ffmpeg suggestion, it’s definitely worth looking into.

Yes, if you have crackling audio it will be captured. But isn’t it just a case of upping the audio bufffersize in Rack, and/or upping the # of threads in your Rack to solve that?

To reduce the underruns, yes. I’ve messed around with the buffer size and threads to minimize it, but if a patch is too resource heavy the underruns still occur. So VCV Recorder has been a go to in those instances, which for larger patches is often, especially on my aging studio Mac Pro.

1 Like

Does anyone know how we can get the MP4 option back into the V2 Recorder just as in V1?

I can remember that it wasn’t in there by default (v1), and that something had to be done if we wanted mp4 in it.
But that was a while ago :sweat_smile:

I think you needed to build it yourself to get mp4? But I may be mis-remembering.

Ah that was it, you might be right Bruce.
I wonder if that still counts for the v2 version.

The built-in mp4 option with all the settings was very useful (besides using QT on Mac).

don’t know. I could never build the v1 version - it requires an assembler I was unable to install. iirc it’s an mpeg licensing issues the prevents using mp4 in the VCV distributed version.

1 Like

I was struggling today with VCV Recorder MPG videos that didn’t play back audio in QuickTime Player.

After some trial and error, I made a discovery: If you only connect audio to the L/MON input in VCV Recorder, it outputs a file with a mono audio track. QuickTime Player recognizes the mono audio channel in the Inspector window (choose “Show Movie Inspector” in the Window menu to see it) but seemingly doesn’t play it back.

The workaround is to use both the L and R inputs in VCV Recorder, even if you’re just sending the same mono source signal to both channels. Then, it writes a stereo audio track and plays back in QuickTime correctly.

I hope this will help someone.