VCV Rack running native on Apple m1

Reaper also can load Intel VSTs and is ARM64 native

1 Like

So the ARM version of Reaper can load Intel VST’s? Any word yet on the stability and performance of this?

so far tests have been stable here even with old and long not updated ones. seems fine CPU-wise as well. Those of course run in a wrapper so latency may be a tiny concern, but again, not noticed anything yet

1 Like

Yes, agree.

For one I’m anxiously awaiting at least an AU version of Rack Pro as Logic is my workhorse DAW. Logic does fine with mixed Intel/M1 plugins, but at the moment there’s no AU to VST bridges that support mixed architectures.

Native M1 support would be amazing. I do hope this comes soon-ish!


Running Reaper on an M1Max MBP here, and the Rack Pro VST loads, but it’s pretty much unusable. Even the simplest patch breaks up at anything under a 1024 buffer, though oddly the CPU usage is not terribly high at all. And anything serious breaks up at 1024. I also notice just moving a window - anywhere - when the Rack Pro VST is making any sound causes glitches. The only other VST I have that behaved this way bridged is Traction’s F-em (it now has an M1 build, though I haven’t tested it yet). Everything else bridges fine, almost all even at a 128 buffer. FWIW, the standalone Rack Pro seems fine under Rosetta, though I haven’t stress tested it yet. It’s just the VST that glitches out as far as I can tell so far,

Is that a native/ARM/M1 version of Reaper?

Have tried with both - non-native Reaper under Rosetta, and ARM /M1 native which bridges intel vst’s.

Please push this to the Pro Version and AU-Vst. If this gets out I will be paying the Pro price. Your work should be payed as well. You should be on the Paybook!!! We need ppl like you!!!

It just makes sense to have two separate install, one for M1, and one for Intel. I don’t want to mess my folders, I’m also running Reason 12 that has some wonderful VCV pro 2 Bridge Combinator 2 patches, which runs yet on Rosetta, but M1 is on the roadmap… I’m not also sure Vcv rack 2 Pro would run on the Mac in Reason bridge…

I just tried building Rack on M1 myself, again, then found this thread! I managed to get Valley building using simde. This script when run from the Rack/plugins source checkout directory will clone Valley, patch it to include the simde headers and build it natively for apple silicon.

git clone
pushd ValleyRackFree
git clone
find ./src -type f -name "*.[hc]pp" -exec sed -i -e 's/pmmintrin/simde\/x86\/sse3/g' {} \;
sed -i -e 's/^FLAGS +=/FLAGS +=-Isimde -DSIMDE_ENABLE_NATIVE_ALIASES/' Makefile
make -j8

Dont know if it helps but I see you disabled luajit

we link luajit in surge and have a script which builds luajit as a fat (x86 + arm) static lib

if that helps

1 Like


Is there somewhere a kind of manual to build Rack Free on Mac M1? I tried and read this thread but cannot find or do not understand how it works…

I did get the code here and tried make dip which worked, but the make seems to hang…



Hey all, I have stumbled upon this thread and I was wondering what is the current status of the native M1 port? Is it supported by the main branch or this is still under development/testing? I am especially interested in the VST for VCV Pro, as I heavily rely on it + Ableton Live 11 for my production needs.

Basically this is the only thing refraining me from buying a new MacBook Pro :grimacing:

1 Like

@Jens.Peter.Nielsen thanks for your quick reply.

Blockquote Ableton Live 11.2.6 on M1 Monterey + VCV 2.2 AU = "Lost the Connection ..." - #3 by LarsBjerregaard

I read here that AU is just for developers to test their modules compiled for M1 architecture. So, if my understanding is correct, the VST3 for Mac ARM is fully working for all modules (although in beta) but the AU version is not? Or the VST3 plug in also doesn’t have support for all the modules yet? Can you please clarify?

No - the Rack ARM beta is just for developers to test their modules compiled for M1 architecture.

“Builds of Rack for Mac ARM are available for developers to build and test their plugins on Mac ARM.”

I see. Thank you both @steve @Jens.Peter.Nielsen for claryifing.

Does anyone know what’s happened with the development for Apple ARM? It’s like all progress has halted. I’m desperate to use my Pro license with Ableton, but can’t unless I run EVERYTHING in Rosetta which is a massive performance hit.

I thought the AU version of Rack pro does not need Rosetta.


Well holy heck it works! Thank you :slight_smile:

1 Like