VCV rack broke all system audio.


After installing VCV latest version (1.1.6) and getting no audio in VCV rack, I had the bad surprise that it broke all my system audio. I had to reinstall all audio drivers to ear a sound again.

I use a scarlett 18i20 + octo pro on W10.

Am I doomed to be unable to try VCV rack?


What operating system?

just in the op

You’re not the only one, and I don’t think VCVRack is to blame, apparently Focusrite Control needs a re-install once in a while.

I will also link the Focusrite support page.

If you find the need to set a block size in VCV Audio-8 that is not listed. You can edit the .vcv patch file or .vcvm module preset file to set the block size to any integer.

After a reinstallation, it seems to works?!





So after playing with VCV for a couple of hours, I have noticed after closing the app some audio glitchs on the system… and today no sound at boot up. I had to reinstall the drivers again.

As much as I would like to blame Focusrite drivers, there seems to be at least correlation between vcv rack and loosing audio on my system.

Does anyone got a similar problem and a solution?


I think it’s come up once before? For sure not common. And VCV does not “do” anything to audio setup. I’m sure that act of running VCV did make something bad happen, but it doesn’t go in any make any system changes.

I think drivers are still a good culprit. fwiw (very little, I realize) I was thinking of getting a Focusrite when I needed new audio hardware, but was scared away by the posts that said “these are great on a mac, but the windows drivers a not very good”.


I would try to install some other drivers like the ASIO4all
or better the FL Studio ASIO driver, this one works fine here on Win10. And have you tried running VCV with the onboard driver from Win10 (WASAPI or DirectSound)?

I would try these first.

Find links to the drivers in this thread:

Please don’t ever install ASIO4ALL.

Some more info about what you did before the sound went away would be useful too.

Were you loading a patch you made earlier ?

I read in the focusrite control release notes, that they previously exposed some unsupported buffer sizes to the DAW, and fixed it in a later driver. So perhaps if one loads an old patch with an unsupported buffer size it would act up.

Did windows change its default audio driver to the motherboard audio perhaps? That can happen if an audio driver is unresponsive.

Also, perhaps related. Filling the expected number of channels.

Since you have 18 input and 20 output channels, try using the Audio-64 module instead of Audio-16 (I’m just guessing - not well versed in the Rack code).

I had some strange issues, that i never reported, running a Behringer Uproria 1820 with an ES-9 extender and the VCV Audio-16 module. Now that I got an old M-Audio Profire Lightbridge with 34 inputs and 36 outputs, I alway use Audio-64.

I had no problems using it, but FL Studio ASIO works better.

1 Like