VCV Rack ASIO (Win10 Pro) issues

I have several RME interfaces here, and use a master clock because I wire all of my machines to a venerable (scope pci based) DSP system via adat.

When running on external clock, I am unable to select the ASIO driver in VCV Rack 2 Pro, specifically I cannot select an i/o because the application seems to be set to 48khz by default. When I set the card to use internal clock, and then changed Rack to be 44.1 (which is what I was running the master clock at), things worked.

However I also tried my Scope DSP system, and its ASIO driver. There are NOT other audio drivers on that system (no nvidia HDMI, onboard sound or etc) because those cards are installed in a Supermicro server/workstation board for E3-1200 Xeons (which gives me 4 PCI slots for the cards). The cards are older, but the software and drivers were updated 2-3 years ago. It never gets that far, and bails at the WASAPI check:

Here is the log:

[0.002 info adapters/standalone.cpp:137 main] VCV Rack Pro v2.0.0
[0.002 info adapters/standalone.cpp:138 main] Windows 10.0
[0.002 info adapters/standalone.cpp:144 main] Args: C:\Program Files\VCV\Rack2Pro\Rack.exe 
[0.002 info adapters/standalone.cpp:147 main] System directory: C:\Program Files\VCV\Rack2Pro
[0.002 info adapters/standalone.cpp:148 main] User directory: C:/Users/Valis/Documents/Rack2
[0.002 info adapters/standalone.cpp:152 main] System time: 
[0.002 info src/settings.cpp:455 load] Loading settings C:/Users/Valis/Documents/Rack2/settings.json
[0.003 info adapters/standalone.cpp:175 main] Initializing environment
[0.005 info src/rtaudio.cpp:254 RtAudioDriver] Creating RtAudio WASAPI driver
[1.007 fatal adapters/standalone.cpp:60 fatalSignalHandler] Fatal signal 22 SIG. Stack trace:
16:  0x0
15: raise 0x7ffd65b7abe0
14: abort 0x7ffd65b7f1e0
13: ZN9__gnu_cxx27__verbose_terminate_handlerEv 0x7ffd4d5bf4c0
12: ZN10__cxxabiv111__terminateEPFvvE 0x7ffd4d5b5cd0
11: ZSt9terminatev 0x7ffd4d6a78d0
10: _cxa_throw 0x7ffd4d6b0670
9: ZN5RtApi5errorEN12RtAudioError4TypeE 0x7ffd25e54a20
8: ZN11RtApiWasapi13getDeviceInfoEj 0x7ffd25e60870
7: ZN4rack13RtAudioDriverC1EN7RtAudio3ApiE 0x7ffd25e93720
6: ZN4rack11rtaudioInitEv 0x7ffd259efca0
5: ZN4rack11rtaudioInitEv 0x7ffd259efca0
4: ZN4rack11rtaudioInitEv 0x7ffd259efca0
3: ZN4rack11rtaudioInitEv 0x7ffd259efca0
2: ZN4rack11rtaudioInitEv 0x7ffd259efca0
1: BaseThreadInitThunk 0x7ffd668f7020
0: RtlUserThreadStart 0x7ffd670c2630

After reading this thread, I have removed Bome Midi Translator, RTPMidi and any other audio or midi driver that may have caused conflicft. Since the log above shows a bomb on the WASAPI wave driver, which my Scope cards do not support, I would guess that’s the issue.

Is it possible to set a config option to skip drivers that cannot be accessed on a system? Bidule recently added this (as well as registry entries on Win & application support entries on Mac) as a troubleshooting method, and this is very useful.