Rack 2 doesn't load on Windows 10(Fixed, Uninstalling Jack)

Hi Folks, anybody running into this issue of Rack 2 not loading on Windows 10?

I have Rack 1.1.6 installed, not running. I installed Rack 2, fresh download from the website seconds ago. Windows did throw up a warning, saying unknown publisher. I went ahead anyways. I tried rebooting. I tried reinstalling. I also tried to run it with Win 8 Compatibility mode. Lastly, I tried the -d command line option, but saw nothing to the stderr, nothing to the log. I checked Task Manager, Rack shows up and then just disappears.

Any help would be greatly appreciated.

Thank you.

Huh! It’s running fine with Win10 over here. So it doesn’t even write to log.txt in your Rack2 user folder?

Did you install any of the V2 betas, or is this the first time V2 has reached your machine?

Thank you for the response! First time install Rack 2, no previous betas.

I found the log file, and here are the relevant lines

[0.053 info src/rtaudio.cpp:254 RtAudioDriver] Creating RtAudio ASIO driver
[0.094 info src/rtaudio.cpp:269 RtAudioDriver] Found RtAudio ASIO device 0: ASIO4ALL v2 (2 in, 2 out)
[0.127 info src/rtaudio.cpp:269 RtAudioDriver] Found RtAudio ASIO device 1: Audio Kontrol 1 (0 in, 0 out)
[0.136 info src/rtaudio.cpp:269 RtAudioDriver] Found RtAudio ASIO device 2: Blackmagic Audio (0 in, 0 out)
[0.138 info src/rtaudio.cpp:269 RtAudioDriver] Found RtAudio ASIO device 3: Expert Sleepers USB Audio (0 in, 0 out)
[0.140 info src/rtaudio.cpp:269 RtAudioDriver] Found RtAudio ASIO device 4: Focusrite Thunderbolt ASIO (0 in, 0 out)
[0.248 fatal adapters/standalone.cpp:60 fatalSignalHandler] Fatal signal 11 SIG. Stack trace:
1:  0x0
0: jack_ringbuffer_get_write_vector 0x69a168a0

Ah, interesting. Are you running JACK and ASIO4ALL on Windows? That’s not a known incompatability AFAIK but the first step would be deactivating one, then the other, and seeing what happens.

I can assure you that rack 2.0 (and previous) works fine on win10 for most of us.

1 Like

I wonder if there’s a latent conflict between Rack’s multiple-card support and JACK/A4A. @djsignal7, I’m stepping away for a bit, but will check back shortly unless someone else picks up the baton.

1 Like

Yup. It seems to be Jack’s problem.

But haven’t had any issue with other audio programs or the previous version of Rack. Rack 2 is running now.

Thanks folks!

1 Like

Oh good. Rack V2 has a very different approach to audio output so it makes general sense that it would

In a lot of ways–plugins, the DSP engine, etc.–Rack V2 is a true v2.0, but this is more like V1.0.0 of a new audio driver.

I’m now going to ping Benn Jordan as I think he uses Jack and he had serious issues getting a beta running. Maybe the same problem! When you get a sec would you mind updating the thread title with something like “(uninstalling JACK fixed it)” and maybe marking your own post as a solution? That could be really helpful, especially right now.


Done :smiley:

1 Like

Would love to hear more about this new audio driver.

I am having issues with Rack2 on a few machines, most have RME drivers but one also has DSP cards. Should I start a new thread or report here?

Also interested on that information. Before VCV 2 Pro, I’ve been using Jack alot for routing.

Same issue here on Windows. Nothing happened when clicking the vcv rack 2 icon. Couldn’t even see an entry in task manager.

Uninstalled Jack. Rebooted. All working.

I got my VCV 2 Pro running with Jack, but I got other issues with Library… Tested VCV 2 pro with Jack already - works for me

+1 on the Jack conflict: couldn’t get Rack to run (it only ran as a background program) so I removed Asio4All, Jack, LoopbackMidi and Bome, and now it is GO!

1 Like

+1 on the Jack conflict (maybe). I uninstalled Jack (which I never used anyway) and all FocusRite drivers in favor of the driver for my Mackie ProFX mixer. I wasn’t using the FocusRite anyways and knew it wasn’t playing nicely with the mixer.