VCV Rack 2 Free and Pro released

I don’t think that 1024 automation parameters is a VST2 limitation, but we found that most DAWs either don’t support more than that, or their parameter UI/menu becomes unwieldy with say, 4096 parameters.


Premium Rack modules include free lifetime updates (I’ll add this information to the VCV Library later.)

As for Rack Pro, we’d rather you spend your money on new Rack modules rather than Rack Pro updates, so I’d expect Rack 3 or 4 or 5 Pro updates to be either free or cheap, but I don’t know at this time and can’t offer guarantees or predictions. However we certainly don’t want to make customers hesitate to update due to a high update cost.


Hey Would you by any chance know how to fix this? Ive had it running for maybe 10 mins built a patch then it just crashed and now it seems that its not compatible with ableton. Ive had it for some time in ableton still and after few restarts nothing happend. So apparently now Ableton cant even find VCV Pro vst ao I can try again. Ive tried to uninstall it several times too but that went unsuccessfull as well. Im desperate here

Do you mean just premium VCV modules or all commercial modules?

All modules sold on the VCV Library include free lifetime updates, provided the developer continues to maintain them (which is incentivized with continued revenue.)

1 Like

Have you tried a Plugin Rescan in Ableton? If you hold ALT while clicking Rescan Ableton will disregard previous plugin status, I think…

edit… Found a support document:

In the Plug-Ins tab, you’ll notice a button that says Rescan. Just clicking that will not rescan Blacklisted plug-ins.To reset the blacklist, hold down the Option/Alt key on your keyboard, then click Rescan while continuing to hold down Option/Alt. Ableton will begin to reset and rescan all of your plug-ins.

…so hopefully that will work

1 Like

I don’t know what platform you are on but on mac you can solve this (or at least get it to rescan) by moving the plugin to somewhere slightly different - like put it in a folder within your VST directory. Somewhere that still gets scanned but has a different file path.

I do it using a Blackhole virtual cable, creating a HW CV out and sending that to a BlackHole Mono out and then using a HW CV In to send the signal to VCV. But I guess that the VST does not have more than 128 steps, not sure actually? I used to do this with VCV as Standalone, combined with my HW Eurorack.

1 Like

Made a track in Reaper with VCV 2 VST fx and now it crashes Reaper when i try to open the project… The track was finished (except for final mixing, so i dont have any rendering) and i dont want to lose it forever. What can i do?

EDIT: seems to be NYSTHI Confusing Simpler after bug reproduction. Wrote to Antonio.

This is awesome! I had trouble trying to integrate into my setup before. already off and running.

my question: Any way to purchase as a gift for someone?

1 Like

If that happens again, you can open Rack in standalone if it works well and split the project into several parts. The drum patch, the bass patch, the guitar patch, and the violin patch (for example), so that by opening the various patches in Reaper, he doesn’t have to calculate everything together and doesn’t go crazy. If that’s not enough, just upload one patch at a time and render, so the cpu stays light.

My rack offered to update to 2.0.1 this morning through the help menu when I started it up… hoping it might fix the crashes I am getting with Ableton Live. Have to say though, the stand alone is waaaay quicker to start up and load projects and seems more stable that v1 so far.

  • Edit - it did! seems to have sorted the crashes I was experiencing using with Live now.

Strange that the update fixes your problem since the changelog says only that it fix network connection timeouts and flushing of log file but that’s great that it does!

In any event, the Update VCV Rack option doesn’t do anything for me; still at 2.0.0 and still see the little red dot.

true. I thought I saw somewhere here a different changelog that said “fixes crash on exit of vst”. Is it possible that the VCV changelog doesn’t reflect changes that are just for the VST? I have no idea, just wondering.

It is not because the patch is heavy or over active. I have retried it with a single confusing simpler module with nothing else and it still does not want to load and crash on boot. I think NYSTHI is on it.

I do not know. Personally I have a bad laptop but some NYSTHI modules I use without problems. If you have a good pc it seems strange to me it is the fault of the modules. But anything can be, Rack 2 has just come out, compatible modules have just come out, in my opinion they still needed time but we rushed the developers because of the enthusiasm and probably now many will find bugs that will be fixed in the next updates.

NYSTHI made three updates in two days… Things will get better soon.


Yeah a few people had the same issue with Simpliciter too. My computer runs big patches of VCV 1 at 96khz hahaha so yeah there is some bugs. Im gonna be patient. Making this all fits and work perfectly with all the different makers is sure a hell of a job.

1 Like

Had one crash with simpliciter. The patch reloaded and ran fine after that. All in all, VCV 1 (and now 2 with the limited amount of time I have used it) have been quite stable and crashes have been rare.

1 Like

congrats!! and simple question (as i did not find answer for that one) - is there vst2 (or planned lv2) for linux in pro version? i am just wondering if it is possible to integrate vcv 2 in ardour ‘natively’ and not just through jack configuration…