VCV Rack 2.4.0 released

Same thing happened to me I can’t get impromptu modules and a few others to load after rolling back to Rack v2.3 from v2.4, even though they are in the plugins folder

they require Rack 2.4.0 and won’t load in previous Rack versions

1 Like

Did Rack 2.4.1 fix this ?

can you point me out to previous version (version earlier than 2.4) of impromptu modular plugins for mac intel may be i can try installing it manually

its not out yet

Yes it is :

1 Like

not sure if its the right place to make a request but I would really like a host module with more outputs , I’d like to do higher order ambisonic stuff inside rack but I’m limited by the host module only having 8 outputs , alternatively some implementation of multi-channel audio thru a single cable(to and from host module) will simplify things even more.

1 Like

From VCV - Support ( (emphasis mine):

For assistance with your VCV account, feature requests and bug reports for VCV products, the VCV Library, and business/private requests, email or use the contact form on this page.

I requested this when host came out, hopefully we get one day.

What exactly bug in VCV Routers elaborate please ?

They don’t save state. Take ROUTER 4:1, hit the clock button so output 2 is selected, exit rack, restart, output 1 selected. Literally a five minute fix if someone could be bothered. Thankfully there are better, free alternatives.

1 Like

Very few modules save state. This may be more like a missing feature than a bug?

It was acknowledged as a bug by VCV, then, silence…

Virtually all modules save state, if not, how would shutting down rack without saving, then restarting, produce exactly the same patch (unless using VCV ROUTERs)?

So if I go and try 5 random LFO they will all save the phase, for example?

I don’t know, for what I do things like that are of little concern to me. So long as I can hit a reset button and everything is in sync I’m happy.

“Very few modules save state”, so saving a patch, then reloading it, and having everything as you left it (unless you’re using VCV ROUTERs) is done my magic? All functional modules save state otherwise people wouldn’t use them.

I’m a bit boggled by this, YOUR modules save state.

My modules most certainly do not save state. All modules save a “patch”. Some may go over and above and save what I consider “state”, like LFO phase, current sequence step, etc…

None of my LFOs save phase, and none of my sequencers save the current position. Although, as you point out, they do save enough stuff that is most cases they load up and sound “right”.

Patches loading and not “playing” quite right is an ancient problem, you will find may discussions about it here.

Ok, seems our interpretation of state doesn’t match, so if I replace state with settings are we on the same page? VCV ROUTERs don’t save their settings so are not fit for purpose, Count Modula switches do so I use them instead, plus they have dark panels.

well, my interpretation of state does seem to match how most modules work. Count modula seems to save it (I just tried couple of them). VCV, ML, Nonlinear circuits don’t. Those are the ones I just tried.

My guess is that most don’t. I think if you logged a bug for every module that doesn’t save “state” you would be very busy!

Fun thing however. Knobs position, or selected mode (like in Mutable devices) this is current state, right ? And all this saveable.

EDIT: Although in other hand, being unfamiliar yet with VCV Router modules, i’m not sure, maybe really described feature can be close (by application) to lfo’s phase position example. Then this is not critical.