Vcv in daw can’t send cv to Expert Sleepers

Well I bought Pro tonight. I can unfortunately confirm the problem: whereas in standalone version I can choose between a list of audio drivers, in VST I can only choose DAW. So sending CV to Expert Sleepers ES-3 is impossible. Big disappointment.

That’s just how plugins in Windows DAWs work.

You can send CV or Audio to an ES-3 though, it should show in your DAW as just one of the audio outputs. I have one and it works fine, just use an Audio-16 module to send the CV from VCV into one of the CV output ports other than 1-2 (so you don’t hear it) then in the receiving track route that audio channel to the output port where the ES-3 lives. Mine is via ADAT from my audio interface.

Can’t give more specific details as how you do that depends which OS, DAW and interface etc.

1 Like

Yes it seems that the windows version of the Vst RACK plugin simply cannot accommodate an independant ASIO driver , even with DAW set to Direct X, no asio drivers are available on the menu. But perhaps in the next update they will bless us. What youre saying is very intriguing though, let me see if i understand you correctly… because if so this could work both ways? So , if i wanted to to run the CV and gate from a hardware sequence into a voice inside VCV plugin. it is arguable that i could patch the cv and gate into the ES9 , say channel 5,6 and then monitor that channel, in ableton, and send it to the AUDIO 16 in VCV and then onto the SW module? Its quite a clusterf*ck but ill test it!

I don’t know if you can do that with an ES-9 because I believe that’s an interface in itself that needs a driver but if it will run in a kind of passive driver free mode to just pass audio around like an ES-3 then maybe.

And yes, it works the same way in both directions. Audio in and out can funnel audio and/or CV to and from the ES devices just be careful with monitoring, try and avoid listening to CV output because it can be crazy loud and nasty.

Benefit of passing CV directly is very little latency and you get full resolution. None of the stepping inherent in converting it to some bit value.

I will try that tomorrow, thanks

1 Like

I believe the problem is not with Rack - the problem is with ASIO. ASIO cannot be used by more than one application at a time. So if your DAW is using it already that’s it - it won’t be available to the Rack plugin.

The audio module will list whatever audio drivers are available to it. If ASIO is not made available by the system, Rack can’t list or use it. Further up this thread vanjelangs got it working (direct access to his ES-9 from the Rack plugin) on Windows so it must be possible.

Did you try setting the DAW to use the Wasapi driver? just asking as it looks like that’s something vanjelangs did. That and disabling exclusive access in the ES-9 settings.

1 Like

Wasapi does not appear as an option in Ableton audio preferences for me. Does anyone know how I can find this?

Please see below:


Was very excited to read this, but i checked my version and it is, in fact, 2.1.2 . So for windows users, even the previous versions dont seem to be able to access Asio drivers. I will perhaps revert to an even earlier version to test, and update here, and i will report the problem too.

VCV support say it will be fixed in next update which will be released “soon”.

1 Like

For clarity, I think the issue that will be fixed is that currently only the DAW driver can be accessed by the Audio modules in the 2.2.0 plugin version.

If 2.1.2 isn’t working for you, I wouldn’t be too confident that the fix coming for 2.2 will work for you either.

The 2.2.1 update still doesn’t fix this issue.

Below is the basic patch I am trying to play through my ES-9. Works in the standalone.

Hi, instead of DAW can you select the ES-9? Routing audio to DAW shouldn’t automatically send to an external interface unless routed that way in Ableton. If you want to send it to DAW and then send it to ES-9 could you please show us how you have set it up in Ableton?

The 2.2.1 update reenables rtaudio from the plug-in so you should now be able to access other audio drivers than just the DAW one.

Hi. Please see screenshots of current set up. In the VCV I am only given the option of DAW/WASAPI/DirectSound - no ES-9 unfortunately. Grateful for any advice!

Okay. Couple of things here. Using ASIO only one audio device is supported. If you want to use multiple as you are in this case I recommend WASAPI. Secondly if Ableton can see the ES-9 can you set DAW in the VCV plugin and then route the audio from that channel into the ES-9?

Unfortunately WASAPI sounds terrible (badly distorted) and I can only get 2 outputs. I can use multiple audio tracks in Ableton to route audio/CV in and out but it’s just very convoluted and nowhere near as seamless as with the standalone version. See screenshot. It’s just frustrating I can’t use the VCV Rack VST as I can the standalone version.

1 Like

Same problem here with my ES-3. It seems there’s no solution for this problem other than not choosing ASIO driver in your DAW, but that’s really not a good option. I now do two things: if I want to use my hardware modular in combination with VCV, I use the standalone version. If it’s “pure” VCV Rack, then I use the DAW version. :face_with_diagonal_mouth:

Sorry for this very late reply. I broke my ankle and in time forgot about the forum. Unfortunately in the end it did not work for me either… A friend of mine is very good with Reaper and he sort of managed to do some under the hood routing that worked. Im not a Reaper user though. In Ableton I think I also found a rather complex workaround with making a group of tracks receiving and sending ‘audio from’ from and to vcv rack. Than running Ableton on Expert Sleeper Asio I could somehow route audio and cv back and forth. I made a template out of that but it became messy and troublesome to work with and got me out of my flow all the time. So I gave up silently hoping an upgrade will save us. I got the paid version of VCV rack to do what I can not do. To be using ES I can only do so in the free VCV standalone.

Sorry to hear that - It does sound like a pain on PC!

Still hoping someone who has been successful with it will post the solution at some point for PC users.

I doubt any Rack update will provide a solution because I don’t think Rack is the problem here - the issue is with PC audio drivers like ASIO and using multiple drivers (in DAW and Rack plugin) at the same time. None of this is a problem with Core Audio on Mac.