unarchiver could not write file to dir: could not unlink

rack 2.0.3b unable to load patch windows10 no problems until 2.0.3b

Check if your anti-virus software is part of this issue. Are you using Avast?

Do you have your documents/ folder on Dropbox or Onedrive? That’s not a good idea with Rack. Did you have Rack VST and Standalone open at the same time?

Had the same issue. There’s a Rack2 folder under your user folder. For some reason some of the files are set to read only. If you uncheck the “read only” box in the folder properties you might have better luck.

Worked for me at least. Good luck!

3 Likes

im using https://www.immunet.com disabled it from startup in taskmanager rebooted without its not part of this issue

no cloud service involved all files local only standalone

C:\Users\myusername\Documents\Rack2 was set to Read-only! unchecked hit ok apply to subfolder hit ok again worked

BUT! its not opening the the file also open a new rack is not working (file > new) only the error msg disappears

uninstalled 2.0.3b installed 2.0.2 same issue

Some dodgy software on your computer did that. It might have set all the files read-only as well if it’s crazy enough. I strongly recommend you NOT use that anti-virus program of yours, they’re absolute junk most of them and cause nothing but trouble, and instead use the default/inbuilt Microsoft Defender which is perfectly adaquate.

I have spent over an hour on this same issue and have found a number of disturbing things…

Rack2 requires some deep changes for Win 10 Home users when it comes to security settings in order to set the Rack2 folder to not say “read only”. One of the better documents on this is here:

However, that’s not the end of the road for me… so far I’ve had to perform this operation to get access to GPEDIT.MSC

It seems if you have Win Pro you would already have GPEDIT.MSC - but I hope that the folks testing Rack2 were not just using Pro…

But that’s not all… I still can’t access Controlled Folder Access because I am running Norton 360. So basically, in order to use shared patches from other users, I need to jump through a bunch of additional hoops, rearranging my security software. Why was it done this way?? Why should I have to put my system at risk (and turn off a major industry standard program like Norton - regardless of what one thinks of them as a company)?

controlled

No need to tire the community with this - we allready know.

The only people who can change VCV Rack don’t read their forums much - contact form here: VCV - Support