Time to Upgrade?

This is not strictly a VCV Rack issue but I find myself at a crossroads. In some music apps like Carla using a single plugin like Emergence the DSP is over 60% and the Xruns/audio glitches are many. I’ve adjusted Jack’s buffer sizes but to no avail. My soundcard is just the onboard Asus motherboard’s.

So I’m thinking my PC’s specs are below par (Intel Core i7 8th Gen, 16GB RAM). I’m toying of the idea to build a new PC box with a GPU and running Linux but use either a dedicated USB sound card - Focusrite - or a PCIe soundcard from Sound Blaster.

Would the use of such a dedicated sound card GREATLY help against DSP loads and Xruns or am I being too naive? I don’t want to spends funds and find I still have Xruns etc.

Thanks.

Proabably the bigger question is whether your audio applications are receiving enough constant power from your system?

https://linuxmusicians.com/viewforum.php?f=27

Run with the right scheduler/governor (performance) - error #1

I don’t think exchanging onboard DAC for pci-e or usb DAC will do much for your XRUN errors. Sound quality will probably improve, but you will still get underruns (XRUNs) if your system isn’t configured right.

Don’t know what distro you’re on etc. - tell us more.

Here are some valuable tips from the Archlinux people: Professional audio - ArchWiki

and other fine pages:
GitHub - chmaha/ManjaroProAudio
GitHub - chmaha/UbuntuProAudio

1 Like

I’m on openSUSE’s tumbleweed with xfce.

I’ll have a read of the arch wiki - keep forgetting about those pages :slight_smile:

Edit: forgot to add my Jack settings through Cadence.

It’s been a while since I looked at this, but here goes.
on the first pic - governor - should say “performance”

on the second pic, I would have “realtime” checked - and run on a rt patched kernel. You could probably find a kernel that is better suited than 6.1.4-default (something with rt and/or preempt) also on the second pic, I would have realtime priority to around 85.
I would hpet as clock source - HPET has to be configure in the kernel - don’t know if it’s in the default kernel (High Precision Event Timers)

on the third pic, I would have a smaller buffer size (256-ish)

Thanks. The governor option is unavailable. I assume due to not having a RT kernel. And if I do select ‘realtime’ the Jack log complains about not being a correct kernel.

I’ll hunt down a RT kernel for my OS unless you can recommend a web site with one.

I don’t know anything about OpenSUSE - seems there are not many audio users on it.

I suggest going to Manjaro (Arch) or Ubuntu Studio.

But, you don’t 100% need a realtime kernel to run Jack without xruns.

you wrote: “Jack log complains about not being a correct kernel” copy paste the exact error message, then perhaps someone can help.

Maybe try a liveusb with AVLinux or UbuntuStudio - see how they have it configured. I think they will both work better with VCV Rack than a default OpenSUSE.

Well well well, I did some basic adjustments as you suggested - realtime set with prio 85, cpu performance, hpet set and 256 buffer - and the patch I had in Carla hasn’t produced any xruns (yet) and the DSP load went from ~50% to ~20%.

I’m very much indebted - thank you. But I’ll still read the refs you linked me.

:+1:

1 Like

Well this is embarrassing, Carla worked fine with the previous settings but it seems to cause an abhorrent clicking sound in VCV. The only way to clear that sound is to reboot the PC then run VCV first.

I spent the afternoon reading the arch wiki and other articles and am slowly coming to the conclusion that Pipewire is the way to go. I upgraded an old laptop with Pipewire and it seems to behave. I had avoided Pipewire for a long time as I "thought’ I was comfortable with Pulseaudio and Jack whereas Pipewire had teething issues.

But not anymore it seems according to unfa’s year old Pipewire video.

I’m going to build a full system with VCV, carla and Pipewire in a VM and test before I commit doing so on my main PC. :crossed_fingers:

I had a bit of a “sit down and RTFM” over the last day or so. It seems openSUSE tumbleweed installed pipewire by default last year but did not disable pulseaudio and jackd. My PC was running all 3 systems and causing issues.

After manually cleaning up pulseudio and jackd and making sure that pipewire - with the appropriate modules - is the only running system, all my audio issues seemed to vanish. Even audacity and LMMS started working again.

Live and learn?

2 Likes

take a look of this

I was a great writeup, but there is not a singe mention of pipewire there - many (edit: or not that many, Fedora 37 at least, Ubuntu 22.04 partly … ) distros changed to pipewire as default now. I’m pleased to see that @therealkitman got his box playing music again.

Seems even Debian on Chromebook uses Pipewire.

Screenshot 2023-01-21 14.48.50