Resource directory issue on Linux

I’ve just installed VCV Rack on Linux Mint and created a desktop shortcut as follows:

[Desktop Entry]
Name=VCV Rack
Comment=Virtual Modular Synth

When I try and run Rack from this shortcut I get an error:

Rack’s resource directory “./res” does not exist. Make sure Rack is correctly installed and launched.

Simply copying the executable to the desktop produces the same error. Not a deal breaker for sure, but would make life easier if I could figure this out.


You must make rack the current directory. Try the methods of running that are in the manual. Assuming they work, then try to make a shortcut that will make the rack directory the current directory.

Another thread on the same topic:

Rack needs to load several “system” resources (graphics, fonts, etc) when it launches, so it needs to know where its system folder is located. There are two ways of specifying this:

  • Pass the folder via the -s <system folder> flag. See VCV Manual - Installing & Running for Rack’s command line argument reference.
  • If no -s flag is present, the system folder will default to the current working directory on Linux, so launch Rack from its system folder. This is why double-clicking the Rack binary in a file manager works.

Try something like this:

[Desktop Entry]

Thanks everyone. Simply adding the “Path” variable to the .desktop file solved the issue. Can’t believe I didn’t spot that.

Thanks again.

instead of run the rack directly with a launcher I use to run a script to launch the VCV Rack, it is very handy since allow launch complementary programs like Jack (I use this trick for launch some other apps like blender which use Jack if you are animator to sync the audio , sunvox among others )

qjackctl &
cd Rack

also I hide this annoying text files with the .hidden