Rack V2 Problems after installing Cumulative Update for Windows 11

I installed Cumulative Update for Windows 11 x64-based Systems (KB5007215) a couple of minutes ago and I don’t see the modules rendered anymore when I try to add modules to my patch in Rack Studio Edition 2.git.2efb7ff5. It was working before applying the update so I am quite sure it is related. I also tested V1 but in that version it is still working, no issues.

From the Microsoft site it says this is included in the update:

This security update includes quality improvements. Key changes include:

  • Addresses an issue in which certain apps might have unexpected results when rendering some user interface elements or when drawing within the app. You might encounter this issue with apps that use GDI+ and set a zero (0) width pen object on displays with high dots per inch (DPI) or resolution, or if the app is using scaling.

Be warned before applying the patch

(Edit: I am at the moment trying to uninstall this patch)

What version of Rack, as I have this problem with Studio Edition 2.git.2efb7ff5

Sorry my bad, i misreaded the version. I’m still not in V2. ^^

So after uninstall, reboots reinstalls etc. etc. my machine is back to normal again. And all updates are appied.

So I am not clear what has happened and if the issue was really caused by the update(maybe it partly failed).

Anyhow, not sure if we should keep this post or delete it.

I installed the patch today as well, but didn’t have any issues. V2 is running great for me on 11.

1 Like