Rack stutter audio-noise Loading a Patch

Hello, noob to vcvrack (about a year), first time posting here, but not a noob to synthesis or computer music technology. Hello to everyone!

I did try searching the community, asked support (email), however, I am not finding anything even close to helping me decipher why I get this “random” annoying issue loading a patch that should not be happening.

The problem? When loading a patch, I receive an “audio-stutter noise.” A loud burst of ugliness lasting a couple seconds, it is not DC, but it’s a loud nasty sound that generally scares the crap out of me and screams through my monitors or headphones.

Crazy thing is, it doesn’t happen on every patch, nor does this happen on the same one patch.

I save presets, ALL presets, with mixer bus mains muted and sequence / clocks not running. I have use the mindmeld mixer, I’ve used bogaudio mixers along with a few others too, depending on my needs and application. I generally use my default ASIO device drivers, but I also have used JackAudio and ASIO LinkPro. Come to think of it, using Jack and the skJack modules I don’t recall this issue - then again, it sidesteps the vcv audio module.

Which brings me to this thought… What seems to be consistent is I am using the vcv audio-8 vcv audio-16 when I have the problem. I’ve run the LinkPro driver along with using stoermelder ‘s Audio-64, I can’t recall this happening on his module.

To be fair to all, I say I can’t recall, because it only rears it’s ugly head when I forget to turn down the mains on my audio interface before loading a patch.

I should not have to do this. Before I load another patch, I go to my audio interface’s software and lower/mute the level, load the patch, then up levels.

I have other music app configurations on my system that this never happens. I am using the same audio interface and the default asio drivers for that interface. For example: Abelton, Reaper, Max8, audiomulch, Plogue Bidule… I can push my system and squeeze every ounce I can out of it…my buffer size at 256, sampling rate 48khz, I am running sadly in a Windows 10 (64x) environment.

I can be running all the above listed apps in a massive routing midi/audio complexity nightmare, including using my iPad Pro, and it all works well. I make music and I have had no issues. I share this point to give a snapshot, a glimpse how I have my windows 10 laptop running and what it can handle with all of those apps … concurrently running.

I only get this issue running vcvrack as a stand-alone app. I am running the latest v1.16. IF I remember to pull down my audio interface’s mains, obviously it’s not apparent. The clock is not running and I mute the module’s mixer that’s wired/cabled directly to the vcv audio module…

If the mixer is muted, if the clock isn’t starting at startup …

… where is this coming from and why is this allowed to happen? I don’t even know where to look. To me, even if a module is auto-running at start up, but the mixer main bus is muted, it should not allow for a “leak,” nor should, by default I would think at load, the vcv audio out modules burst out this “audio-noise” at startup… if everything behind it in the signal chain is muted, nothing is running(ostensibly) - but yet it bursts out during a load - this is really odd true? - it is not healthy for my nerves nor particular great for my studio monitors.

any ideas where’s this coming from ??

I much appreciate your help and guidance Gary

which audio interface do you use?

have you tried the Alikins “Big Mute Button” module in a patch that bursts? I use it to avoid unwanted sounds/noises at patch load.

did you install the latest drivers for your audio interface?

which graphics card do you use, which cpu which … please provide some more information, that we can hunt the issue.

@rsmus7 Thanks for replying, much appreciated.

It’s nice to know I am not the only one who has had such a challenge. If its a thing, its a thing-which I am happy to ‘program’ around it.

I am not adverse to using a Alikins Big Mute Button, I had even thought of disconnecting the signal path to the audio-8 module. I like the idea of a button, if it will actually work.

To be clear, it is not just one particular patch - I have had several with the same behavior. I must also say its is not all the time. I will put the mute button on all for constancy and peace of mind.

My video drivers are updated, my audio interface has the latest drivers for it too.

my current setup:

  • ASUS gl552vw (notebook)
  • Video Geforce GTX 960M (notebook) / Intel HD Graphics 530
  • Intel i7-6700HQ
  • 16gb RAM
  • Samsung SSD 860 pro 512gb
  • OS: windows 10 home,64bit, v1909, build:18363.1082
  • audio interface: iConnectivity iConnectAudio2+ (usb) man, I dislike this interface
  • ASIO iConnectivity interface drivers
  • MIDI: midisport 4x4 (usb)

VCV settings:

  • sample rate 48khz, threads 4, frame rate 30hz

I think I mentioned, by default for all apps, I run buffers settings at 256

Thanks for the help and your insight! Let me know if I need to share anything else… Cheers

That doesn’t necessarily mean it’s Rack’s fault: my sound interface often makes ugly pops with other applications, but never with Rack. After some research, it turned out this doesn’t depend on the applications but on the interface itself. For the record, the noise I get lasts much shorter than in your case, I’m not on Windows and the interface is a Focusrite Scarlett 2i2.

@mixer

That doesn’t necessarily mean it’s Rack’s fault: my sound interface often makes ugly pops …

As the title of my thread states, and I have stated many times, this is from VcV Rack loading a patch…

…not running a patch

Sorry about the useless comment then. Welcome to the forum and good luck.

could be perhaps an abrupt change in the audio driver (for instance your default is asio ant this patch use the other one)

I also have a focusrite scarlet and the same bug

for me, changing the mixer module solved the problem (for now)

Sorry about the useless comment then. Welcome to the forum and good luck.

@mixer…not useless, just out of the scope of my problem. what you were talking about, there can be a plethora of different issues at play - especially on a windows machine, plus - you are on Linux, so that’s apples/oranges. my issue is specific to load time only. thanks though for sharing your experiences …

@David I had thought that too - a good point. I have been making sure to use just the default ASIO drivers for my audio interface. There was no need to muddy the waters trying to track down a challenge with extra variables. It has happened again couple times recently, randomly, with the default ASIO drivers. That’s what encouraged me to go ahead and post the question here…

I am also thinking, that maybe could be my video drivers (i do have the latest updates) - but still - with everything muted/off, no clock, (i know some things start running at-load like wiqid’s chaotic lfo module for example ) how is “audio sneaking/jumping” to the vcv-8 and the signals passes on out to the ‘To Device’ ports - ? - i.e.my monitors or headphones… its like there is a ‘short’ (stupid analogy) on the back-panel ???, happens and ignores the mixer’s main bus mutes and eeks right out to the device ports.

i put the big mute button into play yesterday - we will see if this helps. If my hunch is correct - it won’t. I will give updates this evening.

the problem seems not easily to be solved, imho it could be a audio driver issue, but that is only a guess.

maybe you can upload a patch that makes the start up noise or a screenshot from the patch at start up.

I would try to change the ASIO driver to WASAPI or direct sound (if your audio interface works with them too) and then I would test these, if the noise is still there. The performance with these drivers shouldn’t be much worse.

If it all doesn’t help you should report an issue/ bug at github

thanks @rsmus7


just so happens…this patch started consistently with the noise. I basically was hoping it would happened. It’s always good to have consistent behavior.

So per your suggestion, I added the big mute button to this patch that I knew constantly had the noise during load.

I saved the patch w/Mute Button engaged. I loaded the patch several times in a row-no noise. I had No Noise!! Grateful. I saved with the button not engaged, hello noise, welcome back.

Crazy. As you can see from the screenshot, the mains are muted and levels are set at infinity.

I am happy that the big mute button worked, but very puzzled why it’s needed in the first place…it is a simple fix to an annoying problem. I have no idea what’s going on internally with this module, but it I am glad it works.

That solution is puzzling indeed.

In theory, there should be no difference between the muted mixer and the muted big mute button. Both should just send zero volts to the audio module. Could it be that the problem is with the MixMaster?

The button module doesn’t do much internally, just a bit of anti-click, while the mixer is doing much more obviously, so maybe the problem relates to longer processing time of a module directly patched into the audio out?

I’m guessing you don’t want to deal with this anymore, now that it is somewhat solved (more like worked around), and I’m also just shooting in the dark, but can you reproduce the problem with a patch that doesn’t have the MixMaster but instead has some other “heavier” module at the end (for example an input-less portland weather)?

This could suggest either the mixer being the culprit, or some issue with Rack itself.

I experienced the same but on Ubuntu 20.10 - the fix for me was to simply change the sample rate in Audio 8 to another value and then back (in my case 44 to 48 and back).

What do you mean? How can you do the back and forth switching if the noise burst is happening right when you open a patch?

Sounds like you have an issue with performance in general. I suggest reading through the relevant entry in the manual, and if you still have problems, searching the forum for topics that deal with linux optimalizations, using jack etc. after that you should be good, otherwise open a topic detailing your setup so others can help.

It is better to not derail this topic with this, so @rsmus7 could you move this somewhere else? Feel free to delete my last two comments.

Can you try using the VCV Scope on the mixer outputs when you get the noise, if it’s a bug with the mixer I’d like to know about it and fix it. If the Mixer output (or the Mute module output) are perfectly flat and you still have the noise, then it could perhaps be an audio driver problem.

1 Like

the picture isn’t the whole patch, it would really be helpfull if you would upload the patch.

Then we can test it in different environments and see if we can reproduce your issue.

I get stutter noises from time to time on startup; don’t think it’s patch related. I’ll keep my eyes open. I use a Steirnberg UR22C with current windows drivers, btw.

@marc_boule No. Using the vcv scope seems to be after the fact-isn’t it? Unless the scope has a ‘history’ to view. . . I am not sure if it can capture the event quick enough to be analyzed - or it can be streamed to the HD, ( ha! doubt) because it is gone within 500ms-1500ms. I will absolutely give it a shot see what magic we can capture

It could very well be the audio drivers - I can take them out of the loop by selecting WASAPI or DirectSound see what happens then . . . but it is only happening time to time, and its not on all patches - there has must be a common thread… I appreciate everyone’s help!!

@Squinky.Labs Thank you. I’m glad, and not glad if you get my meaning, that you experienced the same stutter noise time to time on startup… much appreciate it

@unlessgames The big mute button is a work around - I am very interested in getting to the bottom of the issue. What approach should I explore? Taking mindmeld out of the loop replace with another mixer - ?

@rsmus7 yes that quick pic was just to show the signal path out, I will attach a full shot of this particular patch. I will find another patch too, that has given me the same issues and share this as well… I’ll just randomly start loading - levels low, headphones on desk :slight_smile:

@rsmus7 Here is a quick pix of one of the patches that has given me the issue, and the one in question above. This is probably a horrible horrible example-no, it is a horrible example. There is a heavy load at startup . . . after a bit I will come up with a better example. Sorry guys…

Anyway, I am using Host to load external synths and Host fx loading an external effects. This example probably is not the best to explore since its very dependent on what I have at my disposal. I am using Kontakt, 2 instances (drums/percussion), Massive X and a physical modeling acoustic sound synthesis plugin . . as you can see there is a lot of control data (sequence data) flying about… I had set out to use only external sources for this patch and see what I could come up with - it grew into a polyrhythmic sequential composition. You would think I would hear stutters while this is running - I do not.

To be fair, the load stutter sound I had loading this patch, is exactly as I have heard, using no external sources - only current vcv library modules - after dinner I will provide a more reasonable patch to explore and share…