Problem with saving and loading patches

When trying to load saved patches I get an error “Could not load patch: unarchiver could not write file to dir: could not unlink.” I am on Windows 11. Any ideas? Thanks!

This has very recently been discussed:

Just a note though, there seems to be at least two ways this error message can be generated and as a result the cause of the problem under Windows may be different than under MacOS.

1 Like

I just thought the OP might find some answers there, as it did evolve quite a bit. But yes, you are right. I hope this matter gets resolved, it must suck not to be able to open or save patches.

1 Like

Thanks guys, deleting the “autosave” folder files fixed the issue right up! :grin:

1 Like

Yes, this seems to solve Windows issues, but not MacOS issues.

Others have warned that we should never delete the autosave folder contents. I do not know enough to know whether this is good advice or not, but doing so has solved the problem on at least 3 different user Windows machines.

Glad it worked.

1 Like

deleting autosave on Mac is no problem, it only stores state of patch between last saved and when it crashed. So all changes after last save go poof, but if it doesn’t work anyhow that is the logical outcome whatever one does, regardsless of platform. I have never seen a warning on deleting autosave on Mac and never had a problem if I had to go that far

1 Like

I was thinking that my problems started when I downloaded some Omri Cohen patches, just like the OP in that other thread, so maybe this has something to do with downloading outside patches?

In my mind there is fairly strong circumstantial evidence that the problem is sometimes caused by downloading a patch. But, this seems to also perhaps be correlated with the patch having modules in it that I don’t have or something like that. I’m not sure. If this is in fact a cause, I suspect that the autosave files get corrupted in some non-trivial way, perhaps due to manifest differences or even perhaps version differences

I don’t see the problem here - but I seldom download patches.

try seeing what’s in the patch file using commandline tar ? maybe some patches look different ?

This is in a Msys2-MinGW64 shell on Windows 11:

$ tar tvf /c/Users/jpn99/Documents/Rack2/patches/test.vcv --zstd

drwxrwxrwx 0/0               0 2022-01-04 16:02 ./
drwxrwxrwx 0/0               0 2022-01-04 15:58 ./modules/
-rw-rw-rw- 0/0             446 2022-01-04 16:02 ./patch.json
1 Like

never had any issue with any downloaded patch if i had all modules in it, else would be thrown out

1 Like

Yeah, it is difficult to imagine what might lead to this problem. Three of us had similar problems after downloading patch files from the same source, but past that, it seems impossible to determine what the root cause might have been.

In my case, the crash was so traumatic and it took me so long to determine I could recover by deleting the autosave folder contents and I had tried so many other things that I was not willing to try to recreate the problem and try to understand what had happened.

yeah, had one of those that drove me a bit into stress, but that was way back in the early 1.0 days, luckily pretty damn smooth sailing since 2.0.6 and now 2.1.1, that apart from some folks having plugin download issues that VCV is working to resolve, seems very stable and solid. There will always be bugs, that is simply how things are. Perfect software does not exists, neither does perfect hardware or perfect OSes. However the lack of issues has been refreshing. yes, 2.1.0 was broken for me, but alas, 2.1.1 seems fine.