Nysthi Samplers and their Click

When I play a sample with a Nysthi Sampler once after every EOC I get an audible click is there any way to turn that off? It happens with every sample. Otherwise the modules are so good

Other samplers are doing fine

1 Like

I’m also interested :slight_smile:

Hello! Welcome!

Have you tried adjusting the anticlick knob at the bottom?

Screen Shot 2022-03-31 at 6.05.22 PM

4 Likes

Yes, I always do this but I got no success.

It would be useful if someone could point out how to correctly fade in and fade out the loops.

I use that knob in the video to no effect

  1. can you send me your sample ?
  2. are you on? (mac?)
  3. are you connecting sussudio DIRECTLY to the AUDIO OUT for a REAL test ?
  4. have you tried to remove the “output 0v if sample is stopped” option ?"
  5. are you sure the sample doesn’t contain any DC at the end ?
1 Like

There are unavoidable clicks if you start getting cute with your samplers, as I

In Confusing Simpler - which I abuse shamelessly.

  1. Live sample the input with a randomly timed trigger.
  2. Turn on grid.
  3. Connect a trigger to ‘Start’
  4. Turn on Slicing
  5. Select some number of slices. I use hundreds when I’m chopping up a sample that takes several minutes.
  6. Put a random CV into the slice selector inpu.

Do this and There Will Be Clicks.

That’s a module idea for the DSP nerds: a declicker module. To do so you’d use a small window (don’t know what a good value is) and continuously compute the angle of slope of the input. When it gets too steep filter it - either a one pole or some other filter.

Because I’m not a Rack developer & I’m ignorant of most DSP, I don’t know how difficult this would be or how expensive it would be computationally.

1 Like

It would be difficult to remove clicks. They are at the same frequency as the signal. not easy. Much easier is to slice up samples without putting clicks in. If the de-clicker worked right it would put a small fade in / fade out on the sliced. Just like the way any decent mixer in VCV has a lag on the mute signal so you don’t get pops with the mute button.

Or if there was a way to delay the start/stop of a sample to where the audio wave crosses zero, there would be no clicks.

I like the idea of a generic “de-click” module and I started to write a proposal, but really there’s no way around building it into the sample player/looper itself, if the aim is to play looping samples. To clarify:

For one-shot sample playing, or for the beginning and ending of playing a loop, the possible click at beginning/end could be removed by making a one-shot slew-limiter with an emphasis on very short timing, which we don’t have in Rack as far as I can tell. But … I think that when people are talking about removing clicks they are almost always talking about sample-looping, which is where it will really be annoying, and for that there’s no way around building it into the sample player itself. You could make a new module that does it but then you’ve basically made a new sample player or looper, so…

We have a few loopers, Sonus comes to mind, so for the person who’s really feed up with sample looping clicks, it might be worth investigating if any of them implements an effective anti-click strategy for their loop playing.

I’m still waiting for the answers

can you send me your sample ?
are you on? (mac?)
are you connecting sussudio DIRECTLY to the AUDIO OUT for a REAL test ?
have you tried to remove the “output 0v if sample is stopped” option ?"
are you sure the sample doesn’t contain any DC at the end ?

I pretty much always use an envelope along with samplers in vcv.

Did you try this?

An envelope with a short attack time should remove most clicks that you hear when triggering a sample in any sampler.

3 Likes
  1. Bolt_CHat01.wav - Google Drive
  2. I dont quite follow? Im on PC
  3. yes same thing Base Profile 2022.04.06 - 22.29.13.01
  4. that constantly putes out low end as seen in the video I sent in this post
  5. yes, I used another sampler in my first video and that did not have the problem
1 Like

ok, thank you for the videos!

Is this problem unique to me/my computer or is anyone having the same issues? Does anyone know a fix beside routing every signal through a separate vca with an envelope that cuts the signal before the klick?

This sampler would be literally perfect for my uses and there’s no alternative on vcv

Same problem here, running Rack on Windows.

1 Like

:point_up: This is how I manage click removal in some of my modules, but I’ve never known if that’s a common practice.

1 Like

please update to 2 1 16

here

1 Like

Aw I was already happy when I read this message. Sadly the problem still persists.

1 Like

I think I forgot a merge! (my bad)