NYSTHI crashes VCV

Hello everybody, I’m starting my VCV rack journey and I discovered that adding the Nysthi modules crashes the app when I right-click to add a new module.

If you have constant crashes try to remove that module and let us know if it’s the same for you.

Please let me know what informations do you need to help the developer to find a bug. I’m on win 10 64 bit with 12 Gb of RAM on ASUS motherboard i7 PC.

Is it with a Nysthi module in particular or all of them ?

I don’t have this problem with the ones I used so would be useful to know which ones you are getting this behaviours from. Post the log that the crash produces.

Please do a precise report with reproducibility steps (if you can find it), and open an issue on nysthi github; in the meantime I suggest you to remove nysthi libs from your setup

@Olival_Clanaro: I considered the entire folder. Can you explain how can I add the modules one by one to test them?

@TroubledMind: where can I find the error log?

@synthi: yes, removing the Nysthi folder VCV works fine.

oh i see, i though adding one module in your patch made it crash. i had misunderstood :slight_smile:

It should be in the user documents Rack folder as log.txt

there was a misterious bug report from @VCVRackIdeas about 2 months ago and he solved like this: . .

guys! it's solved! You have to go in Nvidia settings, choose Rack in programs list and select NVIDIA GPU instead auto and so on. It's working as hell now! wow

don’t know, maybe it’s related

1 Like

There will be a log.txt file in documents/rack. Can you copy/paste this to pastebin.com and reply here with a link to the log? With the Nysthi folder added back to plugins of course.

@Coirt: here’s the log:


Sorry should have said when the crash occurs. When VCV crashes there will be code added to the log naming the source of the crash. The crash sounds like a module is not being checked for NULL when the browser opens, it is / was a common crash in v1.0.0.

for sure it’s not my case… I’m 100% sure is a problem with the graphic card


@Coirt: Sorry I was not accurate in the description. The program freezes when I right-click to add a module, and I’m forced to quit it by clicking on the X.

Is maybe for this reason that the log doesn’t have the code?

@VCVRackIdeas @synthi Is there anymore context to this?

If there’s integrated graphics and a dedicated GPU. Then the integrated probably should be disabled from bios settings.

sorry no, only @VCVRackIdeas can give more info

Is there a method to try the module one by one, or the module files can’t be separated?

not sure about disabling integrated GPU is possible in the BIOS

but can you update your drivers to the last version ?

if you have only integrated GPU , i suggest you to add a dedicated graphic card, because even 8th GEN Intel CPU has got poor GPU for VCV (i m using it on a HP probook 430G5 with 8th gen @ the moment)

ok, go to Nvidia driver configuration, in 3d section choose Program and then choose VCV Rack and use only Nvidia graphic card for it, just click accept and ok. That helped me so much for 820m GPU.

It seems that I found a solution! Here’s what I did:

In documents/Rack/plugins-v1/NYSTHI/res/ I deleted all the .SVG files, leaving only AttackDecay.svg that I wanted to try.

The results is that all seems working fine now! I didn’t try every single Nysthi module, but VCV doesn’t freezes anymore when I right-click.

You can try this if you have issues and let us know if it works for you too. Also please let me know what these .SVG files are working for.


Yeah then Imo it’s probably a graphic card problem. Loading the module graphics must be hard for your PC, and since NYSTHI is the biggest modules collection with way over 100 modules, i guess your computer just gave up lol

1 Like