Nysthi: Clockable Delay, changing prameters?

Hi all. I don’t use nysthi modules all that often but recently I needed a long delay and I found only one option in my collection; the clockable delay from Nysthi. I found however a couple of things quirky about the module; first I discovered that when a clock (Clocked from Impromptu in my case) is used as a time base the timing starts fluctuating. (E.g. when having a time set to 16 seconds - beat count multiplied by 16- it starts giving 15.997, 16.000 and 16.004.) This resulted in glitches and other unwanted artefacts in the sound. In the end I used the module without the clock input and it works fine, keeping perfect time. A second quirk is the way the parameters have to be edited (this is the case with other Nysthi modules I’ve tried but not all); one has to click in the appropriate window and slide the mouse up or down. I find this cumbersome and difficult, making it hit or miss to insert a correct value. With the Janneker module I can use the numeric keypad but not with the clockable delay. Or is this an issue with my computer only? Related perhaps to the fact that I have an AZERTY keyboard? And finally I wonder if I’m the only one regularly annoyed by the way one has to change the parameters on quite a few Nysthi modules? Apart from that and nevertheless respect and admiration for all the effort each and everyone of the developers put into creating all this wonderfull tools. Enjoy.

Holding Ctrl, while moving the mouse allows for finer control of parameters.

Thnx for answering. Did you try that with clockable delay? Because in my case it doesn’t. And I’m not saying this is inherent of the module, might be a problem with my keyboard or something, although it works with most other plugins, e.g. for tuning non quantized sequencers.

I did try it myself before posting and it works fine for me.

Thnx for answering. I’m not a programmer however and you might as well have typed Chinese or Latin cause the text means nothing to me. Could you clarify, please? Does this mean my keyboard layout is the culprit? Or not?

Just tried again. Defenitely not working for me. I wonder why. I use windows 10, azerty keyboard (Belgium flemish), VCV 1.1.6.

I was just pointing out that there’s a known problem with non-QWERTY keyboards and that it will be fixed in Rack v2 Maybe @Olival_Clanaro can chime in because apparently his AZERTY works fine for him.

I haven’t tested in a while, but my French Azerty keyboard used to work well, and i didn’t even need to put it in EN mode, the notes played were still the right ones :slight_smile:

Thnx for answering. The note are not the issue; they play fine. But as the other member points out, he can control the input of parameter values in the Nysthi module Clockable Delay via the ctrl key while I can’t. I don’t know if you have VCV still installed or not and if you have the relevant module but if yes could you try if the control key works for you when inputting parameter values in Clockable Delay? If not, no problem. Thnx anyway.

Ah i never tried the ctrl key ! I’ll have a try later today


nysthi click and drag “RED” filed are not “keyboard” aware

but they are positional

the more you click on the right, the more fine is the control

the more you click to the left the faster the change

regarding the clock computer: correct, it’s always computing the time best thing to do if you have a steady time is to disconnect the calbe after the tempo is computed probably I need to add a “RE-ARM” latch to avoid micromovements (like in the Clock Muiltiplier divider)

1 Like

Thnx for taking the time to reply. Concerning A; yes, I am aware of that. I would however like to make a request concerning that: would it be possible to change the way to input parameters on your modules? Either by using knobs on which a right click gives the possibility to enter a value by numeric pad, or, in case you really want to stick to the numeric fields change it so that, like with Janneker, one can use the keyboard when hovering over the field with the mouse? I request this because when one has a large patch the only way now to input a detailed value in, for instance, the Clockable Delay, is to zoom in on the module thus making it easier to scroll more precisely through the numbers. This has as a drawback however that when zooming out it takes quite some time for the view to restore and, while restoring one can’t edit anything else. (And yes, I have a dedicated graphics card, but it still takes time to restore an entire large patch.) Concerning B; I am not a programmer, so I have no idea how to solve this. I solve it simply by calculating the exact value I need and letting it run without a clock. Up till now it proves to be quite reliable that way.