Neither SurgeXT nor VCV Free plugins are installing/updating in VCVRack (Arch Linux 6.3.x)

Greetings. Quite the newbie here, so this must be a classic PEBCAK issue…

Despite repeatedly +Add’ing (and ultimately Subscribing to) the SurgeXT plugins in the online Library, after selecting Library > Update all... within VCV Rack, I still cannot see any of the SurgeXT plugins as available for selection within my own desktop library.

The Library menu (with red dot showing connectivity) suggests that I need to update the SurgeXT plugins (which show as version which then scrolls through 0% to 100% update message and tells me to restart VCV Rack.

Have done this repeatedly, including rebooting and trying again. No dice.

I have no problem using all other plugpins in the VCV Rack Library but for some reason the SurgeXT plugins will not load/install. I’ve tried individual plugs and the entire collection via subscribe - neither has any effect. None are visible for selection.

Must be something really lame on my part. Any insights appreciated!

FWIW - When I look in ~/.Rack2/plugins/SurgeXTrack/plugins folder, there are a few plugin entries - hardly any, though. There’s also a ~/.Rack2/plugins/SurgeRack/plugins folder with a few entries. None of those plugins named appear in my desktop Library though. A search for SurgeXT in my offline Library produces nothing.

Would you suggest I delete both of those folder and see if I can reinstall from scratch? Hesitant to do so if it’ll make matter worse.

[BTW: I’m running VCV Rack on the latest Arch Linux 6.3.4-Zen OS on a Dell Optiplex 7010, quad i5 @ 3.6GHz, 16gig RAM, with the latest release VCV Rack 2.5.0]

EDIT UPDATE: I’ve since tried installing various other plugins and they load and work perfectly. But the SurgeXT plugins are still showing up in the Library > Update all... as needing to be installed despite the 0% to 100% loading dialog running successfully, prompting me to restart again.

There should be a folder called SurgeXTrack inside the plugins folder, but it should not contain a folder called plugins

~/.Rack2/plugins/SurgeXTrack/plugins should not have a plugins folder.

This should be inside the SurgeXtrack folder :


I think you should have a instead of a plugin.dll.

In the top right corner you can see what version of Rack you are running


There is no 2.5.0 only the fundamental (free) plugins are 2.5.0 not Rack.

Maybe @baconpaul knows what’s going on ?

Also you could try downloading this :

The file for linux, and put it in the Rack2/plugins folder and see what happens when you restart Rack.

Many thanks for your reply @Yeager

However, I’m not quite sure I know what to do based on your comments. The version of VCVRack was installed directly from the AUR (Arch User Repository) as the latest version 2.3.0-1.

It works perfectly with every other plugin set but cannot “see” the Surge plugins.

Perhaps I’ll just uninstall the entire VCVRack and all related plugins and start again.

The interesting thing is that I also have VCVRack installed on my laptop (an old MacBookPro converted to running the latest ArchLinux). It suffers from the same issue … i.e., I cannot “see” any of the SurgeXT plugins - despite the VCV online Library telling me they’ve been successfully downloaded.

Something is not just wrong with one platform, but two. :thinking:

Your symptoms sound familiar. It’s because the system of adding/removing individual modules in the library is messed up, and people should never use it. Only ever subscribe/unsubscribe to whole plugins, never individual modules. So, here’s what you do:

  • Close Rack.
  • Delete the directory Rack2/plugins/SurgeXTRack/ on your disk, because that sounds a bit messed up as well.
  • Go to VCV Library - Surge XT
  • In the upper right corner click Unsubscribe and wait a few seconds.
  • Now click Subscribe on that same link. Now you have subscribed to the whole plugin.
  • Run Rack again and click update all when the red dot appears.
  • Restart Rack as usual and enjoy the full Surge plugin.

In general, when you want to subscribe/unsubscribe to plugins, I recommend going to VCV Library - Plugins and use the Subscribe/Unsubscribe links, never the Add/Remove links.

Let us know if it works.


@LarsBjerregaard Thank you kindly, this was extremely clear! I followed your instructions precisely (and repeatedly) but could not change the result…

After deleting, unsubscribing, and resubscribing, the Library feature within VCV Rack continues to show me the need to update only the SurgeXT plugins awaiting installation.

I then go through the apparent update routine, reaching 100% prompting me to restart, but the SurgeXT plugin file still shows up as needing to be updated in the Library menu pulldown, and there are no SurgeXT modules showing as available. In fact, the “Brand” SurgeXT is not listed in my search for available plugins within my instance of VCVRack.

FWIW, the SurgeXTRack subfolder within ~/.Rack2/plugins is created (after my having deleted it earlier per your guidance) and there are various subfolders with content. But not the full listing of all SurgeXT offerings associated with a full subscription (only about 3 plugin entries).

Can’t seem to get this one working when all of the other plugins sought thus far install and load flawlessly (without subscription).


EDIT: BTW, I get these same identical outcome when following these steps on my other installation on my laptop. Whatever is going on is still not unique to one particular PC.

So after installing, I mean you see the red dot and it updates to 100% you restart and the red dot re-appears ? Can you show a pic of the content of the SurgeXT folder in plugins ?


does it look like this ?

Also could it be something about GLIBC_2.29 or 2.28 or whatever, after you close rack in the rack folder what does the log.txt file say,are there errors ?

1 Like

Thank you for continuing to try to help me out of this glitch…

Here’s what my Library pulldown menu looks like (yes, it has a red dot indicating connectivity):


…and here’s what’s in the SurgeXT folder within the plugins folder:


After closing VCVRack, the log.txt file exists and is very lengthy. I did a quick visual scan but didn’t spot anything glaring … is there a particular error message I should be looking for, perhaps doing a text search?

Search for SurgeXTRack ?

[0.601 info src/plugin.cpp:137 loadPlugin] Loading plugin from C:/Users/Me/Documents/Rack2/plugins/SurgeXTRack
[0.676 info /home/vortico/src/vcv/library/repos/SurgeXTRack/src/SurgeXT.cpp:25 init] [SurgeXTRack] initializing
[0.677 info src/plugin.cpp:208 loadPlugin] Loaded SurgeXTRack

As you see it ends with Loaded SurgeXTRack.

1 Like

You’ve clearly helped confirm the load failure! Not sure how to resolve :man_shrugging:

1 Like

I see that the Library pulldown also wants to update VCV Free, does this also “loop” I mean does it give a red dot after update ?

And could you post the first line of the log.txt file ?

Here are the first few lines. Not seeing anything of concern, but then again I don’t know what to look for :wink:

As for the red dot, yes, it’s seemingly always there after a brief period upon opening VCVRack as it checks for connectivity. I assumed it was to confirm a connection, not to indicate that something needs to be updated.

Again, all other plugins work/install/load perfectly. Only the SurgeXT plugin suite is problematic.

And the VCV Free is also in the dropdown ? Or have you installed it ? Oh and the first line tells me that you are indeed on VCV 2.3.0.

And I see that fundamental is still on 2.3.1 so it also does not load.

Frankly, I don’t know why VCV Free is showing up as needing to be updated. What might that suggest?

I don’t recall explicitly selecting such a “VCV Free” plugin set. I’ve assumed that was simply the basic rack app, and when it got updated I was notified to update. Perhaps I should just uninstall the entire VCVRack and start over again.

Then again, I’ve also assumed the red dot was a connectivity confirmation, not a “need to update something” indicator.

All other plugins I’ve “added” have loaded just fine, though.

Odd that SurgeXT would somehow present a unique challenge.

VCV Free is the new name for the Fundamental plugins and they are on 2.5.0 and you are still on 2.3.1 so this also does not update.

1 Like

Ah, interesting! Okay, I will uninstall the entire VCVRack on my laptop, delete all related directories, and start from scratch. Will report back…

Good luck.

1 Like

If a reinstall doesn’t help, you might want to try spinning up an alternative linux, say ubuntu studio, and try installing on that, the issue may be arch related.

Well, having uninstalled, deleted ~/.Rack directory, and reinstalled from the Arch AUR repository again, completed a “clean build” … I seem to wind up in the same place:


… with both VCV Free needing to updated (from 2.3.1 to 2.5.0) and Surge XT needing to be installed (

Even the VCV website download section only offers the 2.3.0 version as the current file if I were to try to avoid the AUR and go direct. Still won’t be able to jump to 2.5.0 through that approach.

I un-subscribed to the SurgeXT suite through the website, and it ceased to appear in my “need to update” list. Although the need to update to the 2.5.0 version of VCV Free remains.

All other plugins which are reflected as having been “added” on my account were installed and loaded perfectly in this new installation of VCVRack. So perhaps the latest version opf SurgeXT requires 2.5.0, whereas the other plugins do not?

Regardless, it’s unclear why the 2.5.0 VCV Free won’t install itself. I can see the changelog but neither of my Arch-based installations of VCVRack seem capable of updating to the 2.5.0 from 2.3.1, so yes, perhaps this is an “Arch” thing.

Not sure I want to start creating different Linux distributions (Ubuntu, whatever) to resolve this :thinking:

Fair enough, though it would either confirm or eliminate arch. All works fine here on ubuntu.

1 Like

“undefined symbol” … It may be that the SurgeXT modules have a dependency on an external library that is not installed (or not in the LD_LIBRARY_PATH) of your system. If this is the case then the issue is not with Rack or the SurgeXT modules, but with the environment and the set of libraries that are available/installed on your system. Recommend chatting with a SurgeXT developer to diagnose.

I am not a SurgeXT developer but scanning through their code in GitHub shows a few calls to a “src_process” function that appears to be related to sample rate conversion. There are no definitions of that function in the SurgeXT codebase, so it must be getting that code from somewhere else and linking to it at runtime. The calling interface to the function is very similar to the src_process() function described in the Secret Rabbit Code sample rate converter library (aka libsndfile):

If the SurgeXT modules are expecting to find that library (libsndfile) or one like it installed on your system and it is not there then statements like “undefined symbol” indicate that the linking loader is not able to locate the external dependency which prevents the module from being loaded.