Max/MSP with Rack?

Does anybody here use VCV and Max/MSP together?

I am particularly interested in creating generative visuals with audio coming directly from rack into max/jitter.
Is it possible to connect them?

Hi Jack, I remember a quick experiment made by connecting Rack via VCV Bridge to the vst~ object in Max. Really basic, but just for the needs of audio routing, it worked out.

Here the FB permalink where I posted a screenshot of that test: https://www.facebook.com/groups/vcvrack/permalink/217717692221716/

However, I didn’t try any further experiments since then, although I am focusing some time to the chance of developing a couple of PD modules for Rack.

Edited: just forgot to upload the screenshot via the RTE toolbar :slight_smile:

2 Likes

‘Apropos’, I forgot to mention the other, more obvious, way around. You should always be able to use third-party interapp audio routing devices/drivers and virtual midi busses for your purposes. There are a few generally accepted solutions for both audio and midi, depending on your platform of choice.

1 Like

thanks so much! this is great help. i will do some experimenting but ideally i hope to be able to send midi information from vcv rack through to max/msp to manipulate live visuals, ill see how i go haha

1 Like

Driving midi from Rack is still in the to-do list, for what I know, but you can take a look at this thread here in the forum: VCV Midi ?

1 Like

hey yes! this has been very much my area of interest, too (less so due to visuals, but more just using VCV modulation as control signals for the ‘larger world’ of my studio and DAW)

The Trowasoft cvOSC module has been great for this!

3 Likes

Any luck since? Im trying to send midi cc to max as well

Got things fixed. It seems like its always a simple mistake instead of a hard one for me haha! Both Max 1 and Max 2 midi channels were shut off in Max. So I ended up passing cv to cc signals through the cv to cc module in VCV rack. Then using ctrl in in Max scaling the signals to suit my purposes. Should be working smoothly now!