LowFatMilk Updates

The solution I described creates a favourite list for each module instance within the patch. When closing vcv, the favourites will be stored within the context of each lfm module. When restarting vcv they will be read from the json again.

Maybe additionally I can create a list that is stored on disk that can be read as a standard list that can be imported that gives you quickly a list when you add a module to the patch. Plenty of possibilities, only thing I need is time :grinning:

So if we send you lots of forks, you will be able to release this soon? :wink:

3 Likes

Does this mean projectM expects a folder with preset files, and the list is always an alphabetical list of its filenames? If so, another possibility might be to create aliases/symlinks (details vary with each platform) of the presets in the main folder, and use these named folders as “favorites” and the like. Then we’re just pointing projectM at a different “plugins folder” and its simple rules will Do The Right Thing.

This also means the symlinks/aliases might have munged names to force the desired order, like so:

Favorites/
    0001~Super Preset.milk
    0002~Another preset name.milk
    ...
atmospheric presets/
    0001~Lava Lamp x smoke machine.milk
    0002~Puffy clouds.milk
    ...

Is this related to the earlier issues? . . .

Both LFM modules appear to work for me, but Genie 2.2.2 causes a crash as soon as I select it from the Library. Even if the patch has no other modules (not even the template), it crashes immediately.

MacBook Pro / Catalina 10.15.7 / VCV Rack 2.2.0

[edit] GenieExpander 2.2.2 is fine.

I can’t see why this is related, but thanks for reminding and raising this. I will have a look and fix this.

1 Like

The problem isn’t that big it needs symbolic links. I already have a solution running on my local branch. No worries.

1 Like

A new version of LFM 2.1.7 has been released. It now has the functionality to create your own playlists. See the manual for a description how it works. Curious to hear what you think of it. I also fixed some minor issues and added some smaller functionalities. Enjoy!!

4 Likes

And another release of Low Fat Milk has been uploaded to the library. This was needed as I spotted a bug that caused crashes when selecting a visual from the menu. Some more changes in this version:

  • Changed menu to be clear between visuals and presets
  • Selecting visuals from the menu caused crashes
  • If playlist mode active whilst closing, next and prev work properly when restarting
  • When playlist is active whilst closing, the active visual will be active again when restarting

It is great to see more videos coming online with LFM in it. Please let me know if you would like to see some more functionalities added.

4 Likes

Have updated to 2.1.8, restarted rack, prompted to update to 2.1.8 again etc. Linux.

The following issue has been raised by @docB , where some frames in LFM are black causing flashes. The effect has been captured in the below video. I see the same effect on my Linux box, but I can’t produce it on my windows machine.

I would like to know if other users have seen the same behaviour. And if so, I would like to see what your configurations are. For now what I would like to know is what OS you are on (including version) and what video card you are using and if possible the driver version.

Thanks for your help.

I’m having the same problem under Linux (Mint 20.2,based on Ubuntu 20.04 LTS): LFM refuses to update and the rack log file contains a “… version ‘GLIBC_2.35’ not found, required by …/RPJVisualizer/plugin.so” warning. Looks like the plugin has been build using a too recent version of GLIBC, making it incompatible with Linux distributions that are slightly older (but still used a lot). I’ve seen the same problem with the Blamsoft XFX plugins (see Blamsoft is back thread ).

3 Likes

Yes, you are right. My latest automated builds are built using the latest available os.
I will work on a new version that will build with older os. Hope that will fix the issues for you.

1 Like

I have uploaded new builds to my Google drive. Can you please test if this version works for you? If so, I will ask Andrew to deploy again to the library.

LowFatMilk - Google Drive

Fixed it for me. Thanks! Running MX Linux Wildflower (Debian 11.6)

1 Like

The new build also fixed it for me. Updated flawlessly (no more GLIBC warnings) and runs as expected on my Linux Mint 20.2 (Ubuntu 20.04 LTS based). Thanks!

1 Like

Version 2.1.9 of Low Fat Milk has been released. The following fixes have been implemented:

  • Github builds with older platforms instead of latest
  • Size of embedded window is restored when restarting rack
  • Incidental black frames on Linux fixed (kudos to @docB for raising the issue but also pointing me to the right direction for solving)
  • LFMEmbedded blacked out if left-side controls where out of view
2 Likes

Hi Robert,

I don’t know if I’m doing something wrong, but I only see one preset and that’s with a flying M with headphones. If I click Next or Previous, nothing happens. Not even when I select presets in the menu via the right button.

I’m using Windows 10, VCV Rack Pro 2.3.0, RPJ Visualizer 2.1.10

Thank you for answer.

You can’t do much wrong here. The behavior you describe normally would happen if the module can’t find the presets. So what you could do is see if some rights are set differently in the plugins folder. If you are an experienced user you can use a windows tool that can tell you if there are access issues (filemon). Looks to me something exceptional in your config.

Thanks for your reply Robert,

I thought of one thing that could prevent the presets from being found. The plugin is located in this path C:\Users\Vašek\Documents\Rack2\plugins\RPJVisualizer

Could the folder name “Vašek”, where the letter “š” is used, be a problem? I’m not a programmer, but would some Latin Extended support help?

You’re right that that’s the likely trigger for a bug in path/text handling somewhere in the software. The question is if it’s a bug in Rack, the plugin, or one of either’s dependencies.

There are plenty of software around with this particular issue, but it’s still a bug. There should be nothing wrong with spelling your name the way you spell your name. Unicode is a generation old now, but somehow software still needs to catch up.

Of course, you can simply stick to plain ASCII for your user name and sidestep this distressingly common issue.