knobs don't appear after v2 build [fixed] but more v2 issues

any idea why my knobs don’t appear after building in v2?

they do actually work though :slight_smile:

code: GitHub - jeremywen/JW-Modules at v2

3 Likes

I’ve got the same issue, I reported it to support. Mine show in the module browser, but not in the actual modules.

Same here GitHub - RareBreeds/Orbits: VCV Rack Plugin, knobs are only shown when in the module browser.

Mine worked fine. I am using my own knobs tho - I assumed you were too, Jeremy?

Feel free to look at my code to see if I am doing something different than the folks that are having issues

same here, let me know what you find out

something about the fact that you draw your own knobs and don’t directly use svg?

I use SvGs - just my svgs tho

This?
https://vcvrack.com/manual/Migrate2#2-1-Don-t-store-Font-and-Image-references-across-multiple-frames

I’ve managed to get mine working. I inherit from RoundKnob, which now has a background SVG. Looks like that needs to be set or it won’t show.

I just hacked it for now by loading the same SVG. Maybe it’s better if I directly inherit from SvgKnob.

void OrbitsSkinnedKnob::loadTheme(int theme)
{
        setSvg(APP->window->loadSvg(m_config->getSvg(m_component, theme)));
        
        // Adding the following line worked around it
        // !!! Don't do this unless you actually have a separate background
        // !!! if you just have one svg for the knob you can switch to inheriting from SvgKnob
        bg->setSvg(APP->window->loadSvg(m_config->getSvg(m_component, theme)));

        fb->dirty = true;
}

Yep, switching to inheriting from SvgKnob and setting min/maxAngle in the constructor, the same as RoundKnob also works for me.

@jeremy’s knobs also inherited from RoundKnob. Switching it to inheriting from SvgKnob and setting min/maxAngle in the constructor, like RoundKnob does, fixes it.

		minAngle = -0.83 * M_PI;
		maxAngle = 0.83 * M_PI;

I suppose you’d want to continue inheriting from RoundKnob if you want to upgrade to new knobs with the separate indicator and reflection layer.

1 Like

thanks now on to my other problems…

I got my knobs back, but snap is not working. Anyone come across similar issue?

snap is snapping to incorrect values for me

also my lights are all white and not the color i set (fixed)

Hey Jeremy, I’d love to start testing your modules if you have a build handy?

Edit: I’ve built these myself (was actually super easy)

windows build: Dropbox - JW-Modules-2.0.29-win.vcvplugin - Simplify your life

^^ Same here. I’m on a Mac if that helps.

This has been fixed and will be available in the v2 branch soon.

The issue was due to the Rogan and RoundKnob class adding other SvgWidgets, the default size of Widgets being infinite, and FramebufferWidgets refusing to allocate infinite framebuffers. Since your RoundKnob subclass doesn’t set the new SvgWidget bg (which is okay if you don’t have a background SVG), the knob framebuffer does not allocate. Fixed by making the default size of SvgWidgets (0,0).

2 Likes

Can you post an example of one of your modules’ parameters with incorrect snap values so I can take a look?

so my issue is that I am not getting any consistent values from knobs with snapping (not sure if other knobs have this issue)

In the video below, I am moving the NOTE knob between position 0 and 1 but getParamQuantity()->getValue() is giving me weird values as shown in the logs. This is causing me to show the incorrect value as seen in the video where C# is shown at position 0 before C at position 1. This is just a simple example and my other knobs are also doing similar weird things like this.

here is my method for getting the note name: JW-Modules/JWModules.hpp at v2 · jeremywen/JW-Modules · GitHub

I’m still using things like “params[SLANT_CV_ATTENUVERTER_PARAM].getValue()”

and my snap knobs work fine. What is getParamQuantity() supposed to do?

edited above to add this link to where I am doing this JW-Modules/JWModules.hpp at v2 · jeremywen/JW-Modules · GitHub