knobs don't appear after v2 build [fixed] but more v2 issues

Did you have any idea on this issue?

@marc_boule might be able to help you with this - we had an issue with snapped knobs on MindMeld that he managed to fix today - apparently the way that works has changed.

The issue we had reminded me of yours a bit so fingers crossed.

The thing with snapped knobs now is that they no longer have to be snapped in their wigets with snap = true, but like this instead:

This might not be what solves your problem, but worth mentioning in case.

Seems like a nice thing to put in the porting guide. Or is it already?

I tried that but no change. Thank You though!

edit: I think I may have something. I changed getParamQuantity()->getValue() to getParamQuantity()->getDisplayValue()

Not sure if this will help or not but AB made a commit last night that seems to be relevant to snapped/stepped knobs.


Thank you. I just rebuilt and that fixes the other part of my issue. I think I have it fixed now.


Marc, do you happen to know the difference between making ‘Lights Off’ work and make ‘Room Brightness’ work. My LightWidgets worked for lights off buy not for this new thing.

Does this help?

1 Like

Thank you! I guess I didn’t scroll down far enough :slight_smile:

1 Like

just re-compile and everything will be working. porting is easy :wink:

1 Like


Sorry for late reply, Steve beat me to it :slight_smile:

1 Like