Issue with ES-9 and VCV integration with audio modules

I have been successfully using my ES-9 with VCV Rack for almost a year now but out of nowhere I started having issues. I normally am able to select my ES-9 as a device on a Audio-16 module and be able to both send audio in, and signals/audio out, through that one module. Now out of nowhere I’m only able to do one thing per module. I have to have two audio 16 modules now, one selected as ES-9 Out to send things to my rack, and one selected as ES-9 in to send audio from my rack into VCV. Can anyone familiar with ES-9 and VCV integration help me out? I’m sure it’s something to do with the ES-9 configuration tool but I cant figure out what setting that would be.

Perhaps your bug is related to this:

Note: Using multiple Audio modules is experimental and may crash Rack or render unstable audio.

https://vcvrack.com/manual/Core#Audio

Stoermelder has an Audio 64 module, maybe worth a try?

Are you on MacOS? I am and a similar thing happened to me, very confusing. It turns out that Apple likes to release OS updates that turn one audio device into two audio devices - one for input and one for output. Crazy, I know, and definately a bug in my world but hey, it’s Apple. So go into your system settings, find the ES-9 audio device, and see if it is now two rather than one device. If it is, make an aggregate device (e.g. “ES-9-united”) from the input + output ES-9 devices and voila, normalcy is back.

Yuk! Which Mac OS update causes this issue of a single device suddenly appearing as seperate devices for in snd out?

Yuk indeed! Well, I can’t list the exact updates, but it happened to me on Sierra (10.12) so I figure this could have happened multiple times. I’ve frozen my system for a long time on Sierra so I can’t point to other updates, but if it happenened once it can happen again. On the last update to Sierra it’s still multiple devices, so they never fixed it.

image

Oh I see - I don’t remember having any issue like that on Sierra or any system since - currently on Catalina. I thought you were going to say it was something new in Big Sur. Does your interface have a driver? might be that needs updating?

Have you tried right clicking the device in Audio Midi Setup and clicking configure device?

Never installed external drivers for any gear in my Mac since thing otherwise just work. Nothing to configure on right-clicking, no way to force them to be one device other than making an aggregate device, which I do and that works just fine. Is Catalina a good stable system? Because I’ve been toying with giving it one last update, probably to Mojave, but maybe it should be Catalina instead?

Yes I have found Catalina to be very stable. I find all the Mac OS’s generally end up pretty stable - it’s just the very latest that tends to have some issues when it first comes out. I normally update to the latest about 6 months after it first comes out - but have held off longer with Big Sur (although I have recently installed that on my laptop and no issues so far) - still on Catalina with my main iMac.

1 Like

It’s what Apple recommends.

“You can create Aggregate Device to increase the number audio inputs and outputs available at the same time. You can also use an Aggregate Device if your application doesn’t support separate input and output devices.”

Yeah, it’s a solution, which means there’s a problem, and I would contend that they created the problem. If their idea is that a physical audio device can only have inputs or outputs, but not both, and therefor they have to split it into two devices, I call that crazy, and it was working perfectly before they changed it. At any rate it’s the weirdest change to happen with an OS update, and quite user-hostile if you ask me.

2 Likes