Issue - Rack crashes on assigning audio out

Completely new user here, trying to get VCV rack running for the first time.

I’m trying to get VCV rack going on my laptop with the inbuilt sound card. It’s set to ASIO, 44.1 KHz. When I open VCV Rack, it opens the default rack config. I can assign a MIDI in to the MIDI module with no issues. My problem is with the output module.

The default audio out module appears to be named “Audio 8”. There are drop-down menus to assign different things (Audio Driver, Sample Rate, and Output).

All of my other audio software I run (Pro-Tools, Cakewalk, Maschine) run fine on ASIO, 44.1 KHz. However, whenever I try to assign my output in VCV Rack, it immediately crashes. I get the following error message in the log:

[4.308 info src/audio.cpp:279] Starting RtAudio stream 1 [4.414 fatal src/main.cpp:45] Fatal signal 11. Stack trace: 5: ZN4rack10appDestroyEv 0x456435 4: gai_strerrorW 0x739800 3: _C_specific_handler 0x5f897fd0 2: _chkstk 0x62254670 1: RtlWalkFrameChain 0x621b3730 0: KiUserExceptionDispatcher 0x622534d0

Can anyone tell me what this means, or how to remedy it? I can get it to work in WASAPI mode I guess, but the lack of ASIO functionality is irking me. Any thoughts?

You say built in soundcard…

What soundcard is it? Is the driver up to date?

Are you using ASIO for ALL is that up to date?

ASIO works fine for myself but I have a dedicated interface.

“RealTek High Definition Audio” is the named chipset, manufacturer is Intel. Should be whatever audio processing is included with the Intel i7 7500 CPU chipset.

When selecting from the dropdown in the Audio 8 module, the option is named “Generic Low Latency ASIO Driver, 1-2 In, 1-2 Out”. I’m concerned that the input and output being conflated together is part of the problem? Idk though.

I’ve never heard of ASIO for ALL. I keep my Win 10 up-to-date, and assume that includes standard ASIO driver updates. Would that not be the case? I didn’t realize third party installs were required to keep ASIO drivers updated.

Edit: FWIW I do have an interface I use in my home studio, Zoom LiveTrak L-12 to get all of the I/O I need for my hardware stuff. I’m just concerned about not being able to use ASIO on the go with this - never encountered that kind of problem before with other software, but I’m new to VCV Rack so not sure what to expect. I don’t have issues with my other DAWs or production environments using the laptop on its own, as long as I keep the CPU utilization respectable and don’t run 50+ plugins.

On my system there is a dedicated Realtek ASIO driver: realtek

If I instead choose the Generic Low Latency ASIO Driver, I also get a crash. But the Realtek ASIO option works fine.

You may want to check if there are driver updates available from your laptop’s manufacturer. For example, a search reveals that Dell provides a RealTek HD Audio driver which recently added ASIO support:

In my case my driver came from MSI, the maker of my motherboard.

1 Like

I’m almost certain RealTek and ASIO are 2 completely different drivers. RealTek has HD Audio. Generic Low Latency ASIO Driver seems like it could be a left over driver form a previously installed device perhaps?! I’d recommend disabling unconnected devices from the sound control panel in windows.

ASIO is third party it will not be included with windows 10 updates. ASIO4ALL is also 3rd party but not sure if it is maintained any longer.

1 Like

As far as I know ASIO drivers, with the exception of ASIO4ALL which is more of a hack rather than “real ASIO”, are always vendor-specific. You’ll find a separate ASIO driver for every hardware interface manufacturer, including RealTek’s onboard audio.


Damn, thanks for the input everyone, but it still didn’t resolve it.

I’m using an ASUS UX330UAK model laptop. I went to the ASUS site and downloaded the latest audio drivers, because it looked like you were onto something. I ran the installer which uninstalled the previous drivers, rebooted, reinstalled the new drivers, then rebooted again. I should now be 100% up to date on my Realtek audio drivers.

However, even after that process, VCV Rack doesn’t “see” any ASIO drivers other than the “Generic” one I mentioned. There isn’t one that specifically names the Realtek driver in the dropdown, as @ xandermogue pointed out in their screenshot. I also made sure there aren’t any other enabled audio devices in my Windows settings. There are a few Bluetooth devices that show up where I’ve sync’d in the past, but they’re all disabled and only the “RealTek High Definition Audio” output is enabled. I’m pretty comfortable handling those settings - I’ve been making music in Windows and juggling sound cards and hardware for well over a decade now.

I’d say this qualifies more as minor annoyance than deal-breaker issue - I’ll just run in WASAPI mode since that works, I guess. It’s just an odd bug to encounter, and I was hoping someone might be able to suggest a fix. I’m still open to any solutions someone might have, but updating the OEM drivers wasn’t the solution. Nonetheless, I appreciate the input!

Edit: I also fired up other software to see if they saw new drivers after the update, but they all still just see the “Generic ASIO…” one I mentioned. Those all worked fine before, and still work fine now. VCV Rack still crashes as soon as I try to select it as an output, though.


There seems to be some confusion going on here. ASIO is not a driver it is a protocol, and an ASIO compatible driver therefor is usually supplied by the audio interface manufacturer as mentioned above/before. This is usually only with the more expensive audio interfaces.

Realtek has no ASIO driver, it is a basic embedded soundchip on most mainstream motherboards. You can use the driver for it that is supplied by their site, i think it was a Taiwanese site. That driver is i think either DirectX or Windows WDM compatible.

The “Generic Low Latency ASIO driver” driver is some sort of virtual driver that gets installed when installing certain Steinberg Software. At least this is the info i found with a small google search.

You could try as suggested above to install ASIO4ALL as a wrapper for your Realtek audiocard. Although this is not a real native ASIO driver, it might solve your problem.

Rack, can crash if an input/output that you are trying to assign to it is “in use/occupied/reserved” by some other software or system setting on your computer.

Hope this helps.


Then what is installed on my computer?


I do not have ASIO4ALL. It appears that some motherboard manufacturers are providing their own drivers which provide access to RealTek hardware using the ASIO protocol. This is the case with MSI and apparently Dell, at least.

I’ve got realtek on the MOBO of my new computer. Gonna get a real device soon. It “works” with VCV for me, but not well. Gonna get a Steinberg USB interface.

As far as i am aware i have only seen people complain over so called Realtek “ASIO” drivers, which indicates if any exists it’s either not native or sorry to say very crappy.

Again as mentioned before install ASIO4ALL to see if it helps you fix this problem.

btw. my other post that you replied on, was for OP.

I understand. I just wanted to clarify that point you made, since you were contradicting screenshot evidence I’d already provided for OP. That could be more confusing than helpful. Based on my experience it seems that depending on their particular motherboard there could be a genuine Realtek ASIO driver (i.e. not ASIO4ALL) that they could use which, crappy as it may be, at least would function without crashing Rack.

For what it’s worth, I don’t have any complaints about the Realtek ASIO driver provided by MSI. It’s possible that other Realtek audio drivers perform worse. The actual IO jacks on this motherboard are a bit noisy, but the driver hasn’t given me any trouble.

No problem!

There have been several reports on Rack crashes that are related to audio I/O. Many times these can be traced back to the fact that the driver is not multi-client.

In some cases the ASIO4ALL wrapper solved a problem for some users.

FWIW i have a Realtek installed in my laptop as well, that works fine just with the basic Realtek HD driver, and as WASAPI device in VCV. This is what i use when on the go, in all other situations i use a MOTU Ultralite MK4.

1 Like

Just wanted to say I appreciate the responsiveness in the community to this issue. Even though it didn’t lead to a fix, the issue was non-critical, and everyone was providing helpful input towards a resolution.

I’m looking forward to working with VCV Rack and seeing what I can come up with.

Thanks again everyone!


Hi @SoundReason, I had similar issues, so I write down here my experience.

I have a Toshiba Satellite Pro C850 laptop, which I use for software development at work and for some VCVRack-related building and testing purposes.
My system is running the Windows 8.1 Pro x64 OS.
My laptop comes equipped with an on-board Realtek HDA audio device, but I can’t see it listed among my VCVRack ASIO devices.
When I tried to search for updated drivers from Device Manager, it looks like my drivers are up-to-date, listing version of the Realtek HDA driver.

When I manually downloaded and installed from the Toshiba manufacturer the latest package for my system, I found that version 6.3.9600.16384 was installed. But still I could not list it as an ASIO device in the audio output module of VCVRack. No issues with WASAPI nor DirectSound interfaces, though.

My solution for my on-the-go contexts was ultimately to install the Asio4All drivers, as already suggested here from other rackers. Although this may now look like sort of a hacked mean, or quite a obsolete, unsupported tool, they let me have my ASIO protocol wrapped and did go straight to the point.

I have to say also that when working at home or at office, I connect an old Avid MBox 1 audio interface via USB, as I managed to install the original hardware-unlocked drivers, which where once shipped only with old ProTools installers. But for my on-the-go needs, as already said, the Asio4All trick makes me happy. I have only to consider the audio-exclusive constraint, but I usually switch to WASAPI, when I really need it.

I attach a quick capture with my ASIO dropdown in VCVRack. Best