install Stoermelder's pack one

Hello I am a new user of VCV Rack 2 Free. I added Stoermelder’s pack one available via the library in the “Plugin” section of the Vcv site. Unfortunately they don’t appear in my library in VCV Rack 2. How to solve this problem. Thank you in advance for your response Thierry

The library version is 1.. - for rack 1..

The “Stoermelder Pack” is not available in the library for Rack v2 yet … but the developer has made the development pre-release plugin pack available for Rack 2 on his Github page:

Release Development build · stoermelder/vcvrack-packone · GitHub

  • Windows: get Stoermelder-P1-2.0.37d7231-win-20220524.vcvplugin

  • Mac: get Stoermelder-P1-2.0.37d7231-mac-20220524.vcvplugin.

  • put it in your Rack plugin folder.

VCV Manual - Installing & Running

Welcome, and … please search before asking - the question has been answered many times on the forum.

Thank you so much !

Well, I understand that people get annoyed by repeatedly asked questions in forums. But those are users who follow the discussions on a daily basis and don’t have to use search engines. I use to punch in all sorts of search words in forums and the results are mostly not very enlightening, from totally unrelated topic, to unanswered questions, to outdated old posts, but I rarely find what I’m searching for.

Same in this case: I download Stoermelder-P1-2.0.37d7231-win -20220524.vcvplugin from the github site, which creates a zip-file called “Rack-SDK-2.0.6-win.zip”. The “2” indicates it’s for Rack2 i understood. I place it into documents/rack2/plugins. I tried zipped and unzipped, but starting VCV2 no modules of stoermelder come available in the list of modules.

It kinda is difficult and I think I achieved to find all information available around the subject on this community page.

Anybody out there who successfully implemented that developer built?

Cheers Jono :slight_smile:

Yes, what seems to be the problem?

Or did you just want to state, that installing non-library-plugins could be easier?

Cheers! dDom

No it doesn’t. From that GitHub page, it looks like you mistakenly downloaded:

These assets were built against https://vcvrack.com/downloads/Rack-SDK-2.0.6-win.zip

when what you need to download is further down the page in the Assets section

Stoermelder-P1-2.0.37d7231-win-20220524.vcvplugin

Just download the the .vcvplugin file, put it in your Rack plugins folder and restart Rack

Nope, I try to avoid writing hidden statements :laughing:

Cheers for the quick answers @dDom and @steve What happened was that another user had the problem here in the forum of not finding stoermelder in Rack2 and he got the link to the stoermelder developer build page as an answer. The answer contained the instruction: “you can download the build here”

So I followed that link as well and i downloaded the build, instead of the asset further below. Just due to not knowing what a build and an asset is.

So thanks again @steve: you’ve assessed the problem correctly. Wrong file downloaded. It works now.

Hope my solved problem helps other noobs as well :slight_smile:

I see… :slight_smile:

Yes,it is a common mistake. Probably won’t change, as it is rare for ppl to download test builds. Only in a very small number of cases where a plug-in if popular and not ported to the 2.0 library.