How to Turn Off VCV Engine

When I’m not using Rack but don’t want to shut it down, to save CPU cycles I’d like a quick way to turn off the DSP engine and mute the sound. I expected a menu option or keystroke to do this but I’ve searched the UI and Manual and can’t find one. In the Engine / Sample Rate menu there is a “Pause” option. I’m not sure what this does but it doesn’t shut down the engine.

Is there a way to do this?

Thanks! That’s a convenient way to disable the audio out.

However when audio out is disabled, my patch in Rack keeps running and Activity Monitor says Rack is consuming 60% of CPU. Even when I right click on every module and disable them all it’s still consuming the 60% of CPU.

Is it possible to actually disable the audio engine to conserve resources when rack is open but not in use? This would be a valuable feature especially when you are running on a battery.

I loaded up one of my busier patches, and when running it took up around 97-99% CPU. At one time it spiked to 100.1% - I’m not sure how that happens.

I paused it in the Engine menu, and it dropped down to 50-52%.

Then I un-paused it and then went around disabling all of the modules, even the blank panels. It was still up to 90-92% CPU. That surprised me very much.

Finally, I opened a new patch with the standard template (plus an LFO and five simple utility modules). That took up 29% CPU.

FWIW, System Report says this about my system:

Model Name: MacBook Pro
Model Identifier: MacBookPro15,2
Processor Name: Quad-Core Intel Core i5
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Hyper-Threading Technology: Enabled
Memory: 8 GB

Doesn’t Engine/sample rate/pause do this? I think the residual CPU is GUI, but I can’t be sure. I know that with just the default template, pause cuts the cpu by half, and iconifying (no displayed GUI) drops it to 0.7% on my Linux box.

1 Like

Why not just quit Rack? I can’t see a reason to keep it running in the background if you’re not actually using it and not outputting any audio.

Also can you share the patch you mention that’s causing high CPU loads? Be interesting to see what might be causing that anyway.

1 Like

Looks like you use mac, there is unofficial(unsupported by VCV) build with ‘pause(engine) on lost focus’ feature, also you should try this build because there is important patch for Mac that enables real time audio engine, this extinguishes audio crackles. Rack v1 builds with improvements

Thanks everyone for the suggestions.

  • I sometimes multitask, switching to and from Rack for a few minutes at a time. I’d rather not save/exit/reopen every time. Choosing “no input” to mute the sound works nicely, but minimizing power and heat generation would be useful.

This is my patch Simple Test.vcv

Note that it doesn’t use an unusually large amount of CPU. It was just for testing variations under different conditions.

When the patch is running it uses 53% of CPU. Doing Sample Rate/Pause reduces it to 43% but it continues to produce (distorted) sound. Switching to No Output does not further reduce it. This is on an M1 Macbook Pro. Maybe the 43% is mostly the GUI.

I’ll try the Mac build with “Pause engine on lost focus”.