Help needed for beta testing

Hello, I have a new plugin to release and I would ask this community to test it before I submit it to VCV to be included in the library. It’s a simple idea: generate triggers from LFO intersections to generate patterns and CV that is organic to the pattern generation. I called them cross sequencers: 2 LFOs (XSeq2) and 3LFOs (XSeq3). There are also a couple of ancillary objects. See details in the README. I compiled it for Windows. I tried compiling it for Mac but I am getting error messages (*** multiple target patterns. Stop). If anyone has a clue about how to fix that please let me know.

Here it is: NLS


Manually delete the build and dist directories before running make. make clean will work after.

Ran into another error:

/usr/bin/clang++ -std=c++11 -stdlib=libc++  -fPIC -I/Users/dbrooks/Applications/Rack-SDK/include -I/Users/username/Applications/Rack-SDK/dep/include -MMD -MP -g -O3 -funsafe-math-optimizations -fno-omit-frame-pointer -Wall -Wextra -Wno-unused-parameter -DARCH_X64 -march=nehalem -DARCH_MAC -mmacosx-version-min=10.9  -c -o build/src/CrossSeq2Module.cpp.o src/CrossSeq2Module.cpp
src/CrossSeq2Module.cpp:81:2: error: C++ requires a type specifier for all declarations

Hope this helps.

1 Like

Thanks! I did what you said and run make clean

I probably fixed the error as well (though I am not sure since I was not getting that on my end)

I can’t see a win binary on your github
that I can download to test it,
as I don’t compile myself the modules

1 Like
1 Like

Still getting the error here. I’m using 10.15.6

Something to do with this line: CrossSeq2_process_init();

1 Like

I commented that line out temporarily, it might make the module unstable, see if you still get the error. Thanks!

Still getting the error.

Ok, this time it should definitely give you a different error. If you could copy paste it that would be great. Thanks for your patience (it’s frustrating not to be able to reproduce the bug…)

Are you building manually for each change? Why not just add the github action to rebuild on push? (there is a thread in this forum that shows how to do it)

1 Like
src/CrossSeq2Module.cpp:80:2: error: C++ requires a type specifier for all declarations
1 Like

The CPU usage seems pretty high. Might that come down in the future?

1 Like

Right now knob params are checked at every sample. I will add a change () function to make them run smoother. Other than that they should be pretty efficient but I will double check all the code. Thanks for checking! Other than CPU usage do they work for you?

I built on windows, no obvious problems. You now, if it’s an LFO you don’t really need to generate a sample at full audio sample rate. I think my LFN runs internally at 400 Hz sample rate, and it has a multi band equalizer in it.


Thanks for this suggestion! I am now down-sampling LFOs by a factor of 8 which makes the modules much more efficient. Maybe I can do even more, I’ll keep testing. Still working on the param update but it’s sensibly better now.

1 Like

Nice! Make sure you don’t get little stair steps on the output. I run it through a one pole low pass at full audio rate to avoid that.

1 Like

As an ignorant, now I’m curious Bruce. Is that economic because the simple filter is much cheaper to calculate than the LFO?

1 Like

I can’t find the thread you mentioned :face_with_monocle:

1 Like

Thanks. I spent a couple of hours trying to run git push from the terminal but the authentication process on Windows seems very buggy. I was using GitHub desktop for my commits, but for the automated building that is not an option. I have installed the credential-manager app but I still get this

git: 'credential-manager-core' is not a git command. See 'git --help'.

Extensive stackoverflow research has not solved the issue.