Can't save patches on C:/, but external drives are OK...?

Hello everybody,

I have a stationary PC and a Laptop. On my Laptop I cannot save patches anywhere on C:/. I am forced to save 'em on an external USB device. I tried multiple Paths on C:/. The desktop, Downloads, C:/ itself, Pictures, Music, Videos, New Folder somewhere on C:/.

When I save the patch it must be saved somewhere, because when I open up VCV Rack, the newest version is opened as well of my patch.

I tried de-installing, rebooting, newly installing. With admin rights, without admin rights.

I googled and partially found this:

But both of these describe my issue partially and don’t really show any real solution.

I also have another issue with audio drivers. Should I open up another ticket in regards to that? Basically: I can only get audio out when I select: ASIO > FL Studio ASIO or ASIO > Yamaha Steinberg ASIO.

ASIO4ALL is not working, WASAPI and DirectSound are also not working. I remember a time where I could use VCV Rack without installing FL Studio.

Hi @Leterel , can you save a file in the same folder where rack is installed? In Windows, it should be under Program files. Give that a try. If not, I would recommend temporarily disconnecting from any network and disable any antivirus software running, then try to save. It could be something preventing Rack from writing to your drive. If it is, then you can just allow exceptions in the antivirus software.

1 Like

I did what you said and tried to save my patch under “C:\Program Files\VCV\Rack”. I have to translate my issues and how I solved them since my UI is German. I got the error “You Don’t Have Permission to Save in This Location”. Then I followed this guide: Wie behebt man in Windows den Fehler “Sie verfügen nicht über die Berechtigung zum Speichern in diesem Pfad”? . Methode 1 wasn’t necessary as I was and still am still the admin.

Methode 2 however seemed to fix the issue. By granting maximum access to everyone and everything in the properties registered in the VCV/Rack folder path, I was able to save my patch in that path.

I tried to give the whole C:/ drive maximum rights for every account whatsoever and rebooted. Didn’t fix the issue.

Method #3 wasn’t relevant for me and #4 was already set.

Deactivating the internet didn’t fix the issue and deactivating Windows Defender didn’t fix anything as well. I also added special rights for the Application in the Windows Firewall. Nothing changed.

So far I can at least save projects in the Rack folder.

I also got a new error, when I tried to save directly to C:/: “Dem Client fehlt ein erforderliches Recht.” “The client is missing a necessary right.” Something like that.

If I run VCV Rack with admin rights, I can save my Patch on C:/. I can’t save it on my Desktop or Downloads folder though.

Great. I’m glad you got it fixed.