Blamsoft is back .. just great !

Same here on my Macbook running Catalina - it doesn’t want to know, however its works brilliantly on my new Mac Mini M1 running Monterey.

Has anybody else experienced problems with XFX Wave in the VCV Pro as VST? When I try to load a project in reaper, which contains a patch with the XFX Wave, reaper crashes immediately. In VCV Rack 2 Pro, I can open the patch without problems. Any idea?

PS. I am on Windows 10, Reaper 6.67. And I just noticed that if I open a new reaper project, load VCV and then open the patch, it seems to work. It only crashes reaper when loading the project, containing that patch.

I can replicate that crash also.

I’ll bet ten cents it’s the usual ( holding onto fonts across process calls crashes in vst)

1 Like

Same here Red dot . Download . Re-Launch . Red dot . download . rinse repeat

Rack 2.1.2 OSX 10.14.6

im on macOS 11.5.2 intel mac

got it to work by

-update/download the plugins

-reopen rack to install plugins

-do not redownload plugins

-close rack

-open terminal and use these commands (free version)

install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXDistortionPack/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXF35/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXReverb/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXWave/plugin.dylib

wHAT’S YOUR TAKE ON THE m1 Mac format|?? Any issues??? Tnx!! Distributor rocks!!

Worked on OSX10.14.6 just fine as well . Thanks !


At first I was getting an error with those Terminal commands, but I had only tried the first two, forgetting that I only had the XFXWave module installed.

I tried just the fourth line, and it worked.

(macOS 10.15.7 Catalina)

1 Like

Been having a lot of fun playing with XFX Wave and F-35, great weapons to have back in the armoury. So many funky modulation targets.

FWIW had no issues, using the Pro plugin in Reaper on Windows 11.

1 Like


Thanks a lot for the trick. I did it on the Free version with success (OS Catalina). Then I tried on the Pro version. Now, in the Pro version, selecting Blamsoft as “brand” in the browser makes VCV to crash. I think I will wait for an updated version of the plugin to use it in the pro version.



1 Like

No problems here; iMac 3 GHz 6-Core Intel Core i5 running MacOS Monterey 12.5.1

I should probably turn it down a bit…

Now, where are those old patches with these modules …

1 Like

Cheers! For the pro version-- if you use these commands instead, it should work

install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXDistortionPack/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXF35/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXReverb/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXWave/plugin.dylib

All credit goes to @diimdeep and @LarsBjerregaard - thank you!

and thank you @Blamsoft, really enjoying these

1 Like


In fact I first try the command line on the free version, then rune it again by changing “Free” for “Pro”. I tried again with your proposal and same issue. Selecting Blamsoft in the Browser crash VCV. I tried also a search by entering “x” in the search bar. It crashed VCV. May be I will redownload Blamsoft plugins and run the command line on the pro version only.

Interesting, no crash with VCV free version, I can search and select Blamsoft plugin. I should have run the command line on the Pro version first. :frowning:

just in case, the log when it crash.

[12.059 info src/app/Browser.cpp:202 createPreview] Creating module widget Blamsoft XFX Grunge
[12.060 fatal adapters/standalone.cpp:48 fatalSignalHandler] Fatal signal 6. Stack trace:
23: Rack(fatalSignalHandler(int)+27)
22: libsystem_platform.dylib(_sigtramp+29)
21: libsystem_malloc.dylib(malloc_zone_malloc+104)
20: libsystem_c.dylib(abort+120)
19: libsystem_c.dylib(err+0)
18: libRack.dylib(rack::contextGet() (.cold.1)+33)
17: libRack.dylib(rack::contextGet()+28)
16: plugin.dylib(DC1ModuleWidget::DC1ModuleWidget(DC1Module*)+54)
15: plugin.dylib(rack::plugin::Model* rack::createModel<DC1Module, DC1ModuleWidget>(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >)::TModel::createModuleWidget(rack::engine::Module*)+84)
14: libRack.dylib(rack::app::browser::ModelBox::createPreview()+481)
13: libRack.dylib(rack::app::browser::ModelBox::draw(rack::widget::Widget::DrawArgs const&)+27)
12: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
11: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
10: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
9: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
8: libRack.dylib(rack::ui::ScrollWidget::draw(rack::widget::Widget::DrawArgs const&)+52)
7: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
6: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
5: libRack.dylib(rack::widget::Widget::draw(rack::widget::Widget::DrawArgs const&)+461)
4: libRack.dylib(rack::window::Window::step()+1997)
3: libRack.dylib(rack::window::Window::run()+40)
2: Rack(main+3454)
1: libdyld.dylib(start+1)
0: ???(0x0+1)

I think there are two issues, right? One is the linkage issue which can be worked around with these command line fixes. The other is a crash any time it’s used in inside a VST.

Is this correct? Just trying to sort of this confusing thread. Is it correct that the command line hax will fix the linkage, but not fix the VST crash?



In my case, Pro version crashed when used as standalone. I didn’t try as a VST.

best regards


1 Like

thanks a lot this did the trick for me! :+1:

Fun I had with the modules today…

…FYI - this was via the latest official release of the pro plugin in Reaper 6.67 on Win 11 Pro X64.


I had added the XFX WAVE into a patch to play with it. I just discovered that when I launch Rack and the patch, the output level from the XFX goes extremely high and red-lines the Mindmeld mixer output. This looks like a NaN or array index bounds issue to me.

This in Rack 2.1.2 standalone under Windows 11.

Luckily I did not have my headphones on nor have the output going to my powered studio monitors. I don’t think I have ever experienced this with any other module.

You can just run it now…