Blamsoft is back .. just great !

Strange… I checked and when my Rack (Pro, 2.1.2, standalone) is running (macOS 10.12.6) there’s no Rack2 symlink in /tmp/ or anything of the sort pointing to Rack. So it doesn’t seem to be ubiquitous. All my other modules (all the free ones plus some commercial) work just fine.

Ah, just checked your link again and some contex was missing. The /tmp/Rack2 symlink only exists on Linux :slight_smile:

ifdef ARCH_LIN
	# This prevents static variables in the DSO (dynamic shared object) from being preserved after dlclose().
	FLAGS += -fno-gnu-unique
	# When Rack loads a plugin, it symlinks /tmp/Rack2 to its system dir, so the plugin can link to libRack.
	LDFLAGS += -Wl,-rpath=/tmp/Rack2
	# Since the plugin's compiler could be a different version than Rack's compiler, link libstdc++ and libgcc statically to avoid ABI issues.
	LDFLAGS += -static-libstdc++ -static-libgcc
	RACK_USER_DIR ?= $(HOME)/.Rack2

What I can’t explain though is that further down in it presumes the link exists on macOS:

ifdef ARCH_MAC
	$(STRIP) -S dist/$(SLUG)/$(TARGET)
	$(INSTALL_NAME_TOOL) -change libRack.dylib /tmp/Rack2/libRack.dylib dist/$(SLUG)/$(TARGET)
	$(OTOOL) -L dist/$(SLUG)/$(TARGET)

Also plugin.cpp seems to say that this symlink exists on both Linux and macOS:

#if defined ARCH_WIN
	// Since Rack 2, plugins on Linux/Mac link to the absolute path /tmp/Rack2/libRack.<ext>
	// Create a symlink at /tmp/Rack2 to the system dir containting libRack.
	std::string systemDir = system::getAbsolute(asset::systemDir);
	std::string linkPath = "/tmp/Rack2";

But at least on my macOS system (10.12.6) that link doesn’t exist. Could be a bug in either file + few/none other plugins using that link for anything. No idea, bigger brains needed… @cschol ?

Folks - If you’re experiencing this problem, or if it works for you with no hacks, it might be very helpful if you can indicate: OS (Mac, Windows, Linux) and OS version, thanks!

Interesting! What version of macOS and Rack2 edition and run-mode are you on? Seems there might be a macOS version issue here, with regard to the existence of the /tmp/Rack2 symlink, the plugin linking, or both.

1 Like

Mac OS 12.4, Rack Pro 2.1.2

I don’t have a /tmp/Rack2 symlink.

I don’t know what a ‘run-mode’ is :slight_smile:

1 Like

My word. Standalone vs. VST :slight_smile: The mode it runs in, makes sense right?

If you say so. Not as much sense as “Standalone or VST?”

Anyway - both and Blamsoft working fine in both.

Fair enough. Anyway, it’s interesting that on your macOS you don’t have the symlink and it runs fine without hacks, whereas on my macOS, also without the symlink, it does not run without a hack. Would be interesting to find out what’s going on there.

Do you build plugins from source? Have Xcode installed etc? I do - wonder if that might provide access to the necessary file…

I occasionally build from source, and have xcode commandline utilities installed, but that’s obviously not possible with Blamsoft. I’m not following you on providing access to the necessary file… As written above the /tmp/Rack2 symlink is defined in Rack’s code but your system works fine without it.

Same here on my Macbook running Catalina - it doesn’t want to know, however its works brilliantly on my new Mac Mini M1 running Monterey.

Has anybody else experienced problems with XFX Wave in the VCV Pro as VST? When I try to load a project in reaper, which contains a patch with the XFX Wave, reaper crashes immediately. In VCV Rack 2 Pro, I can open the patch without problems. Any idea?

PS. I am on Windows 10, Reaper 6.67. And I just noticed that if I open a new reaper project, load VCV and then open the patch, it seems to work. It only crashes reaper when loading the project, containing that patch.

I can replicate that crash also.

I’ll bet ten cents it’s the usual ( holding onto fonts across process calls crashes in vst)

1 Like

Same here Red dot . Download . Re-Launch . Red dot . download . rinse repeat

Rack 2.1.2 OSX 10.14.6

im on macOS 11.5.2 intel mac

got it to work by

-update/download the plugins

-reopen rack to install plugins

-do not redownload plugins

-close rack

-open terminal and use these commands (free version)

install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXDistortionPack/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXF35/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXReverb/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXWave/plugin.dylib

wHAT’S YOUR TAKE ON THE m1 Mac format|?? Any issues??? Tnx!! Distributor rocks!!

Worked on OSX10.14.6 just fine as well . Thanks !


At first I was getting an error with those Terminal commands, but I had only tried the first two, forgetting that I only had the XFXWave module installed.

I tried just the fourth line, and it worked.

(macOS 10.15.7 Catalina)

1 Like

Been having a lot of fun playing with XFX Wave and F-35, great weapons to have back in the armoury. So many funky modulation targets.

FWIW had no issues, using the Pro plugin in Reaper on Windows 11.

1 Like


Thanks a lot for the trick. I did it on the Free version with success (OS Catalina). Then I tried on the Pro version. Now, in the Pro version, selecting Blamsoft as “brand” in the browser makes VCV to crash. I think I will wait for an updated version of the plugin to use it in the pro version.



1 Like

No problems here; iMac 3 GHz 6-Core Intel Core i5 running MacOS Monterey 12.5.1

I should probably turn it down a bit…

Now, where are those old patches with these modules …

1 Like

Cheers! For the pro version-- if you use these commands instead, it should work

install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXDistortionPack/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXF35/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXReverb/plugin.dylib
install_name_tool -change libRack.dylib "/Applications/VCV Rack 2" ~/Documents/Rack2/plugins/Blamsoft-XFXWave/plugin.dylib

All credit goes to @diimdeep and @LarsBjerregaard - thank you!

and thank you @Blamsoft, really enjoying these

1 Like